Bug 50403 - /var/cache/man subdirectories removed after upgrading to man-1.5i2
/var/cache/man subdirectories removed after upgrading to man-1.5i2
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-30 18:33 EDT by mrnolta
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 13:01:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mrnolta 2001-07-30 18:33:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686; Nav)

Description of problem:
After upgrading to man-1.5i2, I get the following message once a day:

Date: Mon, 30 Jul 2001 04:02:16 -0400 (EDT)
From: Cron Daemon <root@xxx>
To: root@xxx
Subject: Cron <root@xxx> run-parts /etc/cron.daily

error: lstat() of directory /var/cache/man/X11R6/cat? failed: No such file
or
directory
error: lstat() of directory /var/catman/X11R6/cat? failed: No such file or
directory

There are no subdirectories under /var/cache/man/, and /var/catman does not
exist.

This problem occurs on both 6.2 and 7.1 boxes.

How reproducible:
Didn't try


Additional info:
Comment 1 Michael Schwendt 2001-07-30 20:36:35 EDT
@reporter, duplicate of bug #44117.
Comment 2 Bernhard Rosenkraenzer 2001-07-31 05:33:58 EDT
Intentional. Preformatted man pages have been the cause of around 100 security
problems in the past, so we've decided to get rid of them.
Comment 3 hjl 2001-08-05 11:07:13 EDT
But on RedHat 7.1,

# cat /etc/cron.daily/tmpwatch
/usr/sbin/tmpwatch 240 /tmp
/usr/sbin/tmpwatch 720 /var/tmp
[ -d /var/cache/man ] && /usr/sbin/tmpwatch -f 240
/var/cache/man/{X11R6/cat?,cat?,local/cat?}
[ -d /var/catman ] && /usr/sbin/tmpwatch -f 240
/var/catman/{X11R6/cat?,cat?,local/cat?}

There is why I keep getting the email from
cron. Shouldn't there be a tmpwatch update?
Comment 4 Ben Levenson 2002-01-25 19:22:20 EST
fixed w/ current errata tmpwatch errata: tmpwatch-2.8-0.7.x.
please download from 
ftp.beta.redhat.com or use Red Hat Network
to update your system.

Note You need to log in before you can comment on or make changes to this bug.