Bug 504228 - Update for new hash and checksum filenames for F-11
Update for new hash and checksum filenames for F-11
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: readme-burning-isos (Show other bugs)
devel
All Linux
low Severity medium
: ---
: ---
Assigned To: Zach Oglesby
eric@christensenplace.us
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 525911 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 17:00 EDT by Todd Zullinger
Modified: 2010-06-03 02:20 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 530215 (view as bug list)
Environment:
Last Closed: 2010-06-03 02:20:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Zullinger 2009-06-04 17:00:22 EDT
The document needs updated for F-11 to reflect the changes in verification. sha256sum is now used for checking the hash and the checksum filename has changed from SHA1SUM to something like Fedora-11-$ARCH-CHECKSUM.  This was brought up on fedora-test-list today (https://www.redhat.com/archives/fedora-test-list/2009-June/msg00207.html)

P.S. Sorry for not attaching a patch to fix this, I feel a little guilty filing a bug without one. ;)
Comment 1 Zach Oglesby 2009-06-04 22:48:46 EDT
No worries, it should be easy to fix however do you happen to know the location of the checksums for F11 preview so I can check everything that I write. Thanks
Comment 2 Zach Oglesby 2009-06-04 22:53:33 EDT
I found the checksum file.
Comment 3 Paul W. Frields 2009-06-05 16:41:10 EDT
I've made a note on the wiki common bugs page to cover this:

http://fedoraproject.org/wiki/Common_F11_bugs#504228
Comment 4 Dan Hood 2009-06-10 10:15:42 EDT
It also appears that at least some of the docs online still document the ISO verification process using the sha1sum utility.  For example, the page linked to [1] under the "Verify your ISO download" page [2] for windows users still refers to sha1.

Cygwin provides a sha256sum utility, though I'm not sure which packages provide it.  My quick poking around seemed to turn up a GPL natively compiled sha256sum for windows here [3], though I haven't tried it.

[1] http://docs.fedoraproject.org/readme-burning-isos/en_US/sn-validating-files.html
[2] http://fedoraproject.org/en/verify
[3] http://blog.nfllab.com/archives/152-Win32-native-md5sum,-sha1sum,-sha256sum-etc..html
Comment 5 Todd Zullinger 2009-06-10 10:26:52 EDT
There was a little discussion about sha256sum for Windows on fedora-list¹.  I wondered² whether it would be worthwhile to use the MingW support in Fedora to build a native sha256sum.exe for Windows which we could host on fedoraproject.org for use by new users who are currently stuck on Windows.  That seems safer and saner than having folks run random binaries from a blog (no offence to the writer of the nfllab.com blog).

¹ http://www.redhat.com/archives/fedora-list/2009-June/msg00865.html
² http://www.redhat.com/archives/fedora-list/2009-June/msg00875.html
Comment 6 Zach Oglesby 2009-06-10 12:23:55 EDT
I have been looking into the best way to check the sha256sum hashes on windows, thanks for the links.
Comment 7 Steve Chapel 2009-08-05 11:12:58 EDT
md5deep can also compute sha256sum on Windows:
http://md5deep.sourceforge.net/
Comment 8 Manatsawin Hanmongkolchai 2009-08-11 06:50:11 EDT
I always use HashTab for checking. Too bad, it's just freeware.
http://beeblebrox.org/HashTab%20Setup.exe

The usage should be familiar to Windows user: Right click on the file>Properties>File Hashes then HashTab will calculate CRC32, MD5 and SHA-1 on the file. To calculate SHA-512 wait until the progress is finished (or just cancel it) and click Options to select additional hashing algorithms.
Comment 9 Zach Oglesby 2009-08-11 09:29:06 EDT
Manatsawin, There website has been down for the last few days but it looks to be up again, I am going to add this as well. I should have an updated version this week (for Windows only) and a new version for Windows, Linux, and OS X soon after.
Comment 10 Ruediger Landmann 2009-09-26 23:58:08 EDT
*** Bug 525911 has been marked as a duplicate of this bug. ***
Comment 11 Mike C 2009-09-29 15:16:56 EDT
Is this now resolved? Can this bug be closed yet?
Comment 12 Zach Oglesby 2010-06-03 02:20:55 EDT
This is fixed in the current version. I am going to close it.

Note You need to log in before you can comment on or make changes to this bug.