Bug 504270 - [Fonts-Indic][te_IN] - GSUB shape with SSA and HA are wrong.
[Fonts-Indic][te_IN] - GSUB shape with SSA and HA are wrong.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lohit-telugu-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
: 504272 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-05 06:19 EDT by Satyabrata Maitra
Modified: 2009-10-05 05:33 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-05 05:33:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Telugu fonts with fix for this bug (159.31 KB, application/octet-stream)
2009-09-16 06:35 EDT, Pravin Satpute
no flags Details

  None (edit)
Description Satyabrata Maitra 2009-06-05 06:19:51 EDT
Description of problem:
GSUB shape with SSA (0C37) and HA (0C39) is showing wrong in the font.

Its positioning for the lower part of the composed character, should be below-right aligned which is now aligned as below-middle.

As of now The Image that is given to our Internal web page, is hand drawn and partly wrong also. But, the lower part alignment is Perfect there which is showing right-aligned.

These specific Combinations are given below :

68. U+0C24 U+0C4D U+0C37  త్ష  TA + HALANT + SSA => In image main character must be corrected as in font and in font the position of sub character(which is at the bottom) should be corrected as in image.

70. U+0C24 U+0C4D U+0C39  త్హ  TA + HALANT + HA => In image main character must be corrected as in font and in font the position of sub character(which is at the bottom) should be corrected as in image.

103. U+0C28 U+0C4D U+0C37  న్ష  NA + HALANT + SSA => In image main character must be corrected as in font and in font the position of sub character(which is at the bottom) should be corrected as in image.

105. U+0C28 U+0C4D U+0C39  న్హ  NA + HALANT + HA => In image main character must be corrected as in font and in font the position of sub character(which is at the bottom) should be corrected as in image.

140. U+0C2E U+0C4D U+0C39  మ్హ  MA + HALANT + HA => In image main character must be corrected as in font and in font the position of sub character(which is at the bottom) should be corrected as in image.

175. U+0C2F U+0C4D U+0C39  య్హ  YA + HALANT + HA => In image main character must be corrected as in font and in font the position of sub character(which is at the bottom) should be corrected as in image.

208. U+0C30 U+0C4D U+0C37  ర్ష  RA + HALANT + SSA => In image main character must be corrected as in font and in font the position of sub character(which is at the bottom) should be corrected as in image.

210. U+0C30 U+0C4D U+0C39  ర్హ  RA + HALANT + HA => In image main character must be corrected as in font and in font the position of sub character(which is at the bottom) should be corrected as in image.

243. U+0C32 U+0C4D U+0C37  ల్ష  LA + HALANT + SSA => In image main character must be corrected as in font and in font the position of sub character(which is at the bottom) should be corrected as in image.

245. U+0C32 U+0C4D U+0C39  ల్హ  LA + HALANT + HA => In image main character must be corrected as in font and in font the position of sub character(which is at the bottom) should be corrected as in image.


278. U+0C35 U+0C4D U+0C37  వ్ష  VA + HALANT + SSA => In image main character must be corrected as in font and in font the position of sub character(which is at the bottom) should be corrected as in image.

280. U+0C35 U+0C4D U+0C39  వ్హ  VA + HALANT + HA => In image main character must be corrected as in font and in font the position of sub character(which is at the bottom) should be corrected as in image.


Version-Release number of selected component (if applicable):
lohit-telugu-fonts-2.3.8-1.fc11

How reproducible:
Always

Steps to Reproduce:
1. Start system with FC11 or Latest
2. Change the ibus with RAWCODE
3. Open Gedit
4. Type the combination's Unicode as given above.
5. Observe the lower part of the composed character.
  
Actual results:
Its showing below-middle alignment.

Expected results:
It should be below-right alignment.

Additional info:
Comment 1 Bug Zapper 2009-06-09 13:07:15 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Jens Petersen 2009-06-29 03:01:22 EDT
Please file Lohit bugs against lohit-fonts.
Comment 4 Satyabrata Maitra 2009-06-29 03:05:59 EDT
H Rahul

Good to see you here taking care of this bug again. Please resolve the issue asap stealing some time from your busy academic schedule! :)
Comment 5 Pravin Satpute 2009-09-16 06:30:43 EDT
*** Bug 504272 has been marked as a duplicate of this bug. ***
Comment 6 Pravin Satpute 2009-09-16 06:35:07 EDT
Created attachment 361228 [details]
Telugu fonts with fix for this bug

please test this for above error, if any problem let me know.
if everything file, i will build package for f12
Comment 7 Krishna Babu K 2009-09-18 03:55:32 EDT
Hi Pravin,

   Thank you for your great effort. I have tested the following word list for this patch and it is working fine.

   0c39+0c30+0c4d+0c37+0c2e+0c41                ==> హర్షము
   0c18+0c30+0c4d+0c37+0c23                     ==> ఘర్షణ
   0c39+0c30+0c4d+0c37+0c3e+0c24+0c4d+0c2e      ==> హర్షాత్మ 
   0c39+0c30+0c4d+0c37+0c3e+0c15+0c4d+0c37      ==> హర్షాక్ష
   0c2c+0c4d+0c37+0c41+0c37+0c4d+0c35+0c2e+0c41 ==> బ్షుష్వము

   Thank you for this fix.

Regards,
Krishnababu k.
Comment 8 Pravin Satpute 2009-09-18 06:58:45 EDT
done commit in lohit upstream 
fix will be available with next upstream release
Comment 9 Pravin Satpute 2009-10-05 05:33:22 EDT
please reopen if any problem

Note You need to log in before you can comment on or make changes to this bug.