Bug 504326 - virt-manager's new VM dialog does not use storage pool interface
virt-manager's new VM dialog does not use storage pool interface
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
: 505429 (view as bug list)
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-06-05 11:40 EDT by Erik Jacobson
Modified: 2009-10-07 08:27 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 08:27:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Jacobson 2009-06-05 11:40:23 EDT
When connecting to libvirtd with a remote virtmanager....

When you go to create a new virtual machine, you are asked to supply the path to the ISO (If you choose to use ISO installation)

However, that path does not accept the path name I provide it.  It says the path does not exist.

In reality, the path exists both on the client where I'm running virt-manager 
and the server, where I'm connecting to the libvirtd.  It is an NFS mount
(via autofs) on both the client and virtualization host.

This remote virt-manager connection has worked fine for managing hosts.

Just before and after I hit 'Forward' after typing in the ISO path, I see
this in /var/log/messages on the virtualization host:

Jun  5 10:32:04 nada1 libvirtd: 10:32:04.788: error : Domain not found
Jun  5 10:32:10 nada1 libvirtd: 10:32:10.215: error : Domain not found

pkg versions on both client (my fedora 11 desktop) and server:
virt-manager-0.7.0-4.fc11.x86_64
libvirt-0.6.2-8.fc11.x86_64

This is fedora11 preview, with yum update run a few times on both sides to get
the latest packages.  Therefore, /etc/fedora-release says:

Fedora release 11 (Leonidas)


Detailed instructions to re-produce:
 * Set up the libvirt on the server to accept remote connections.
 * On the client, start virt-manager
 * File -> Add Connection
 * Hypvervisor: QEMU/KVM
 * Connection: Remove Password or Kerberos
 * Hostname: <name of virtualization host>
 * Enter the authenticatoin details set up on the virtualization host when
   prompted for authentication name/password
 * Click 'New'
 * Provide a name for the machine
 * Keep 'Local install media (ISO image or CDROM) checked
 * Provide a full path to the ISO file.  In my case, it is:
   /data/mirrors/redhat/fedora/releases/test/11-Preview/Fedora/x86_64/iso/Fedora-11-Preview-x86_64-DVD.iso
 * OS Type: Fedora 11
 * Version: Fedora 11
 * Click Forward
 * Notice the "Error setting install media location." message.  It reports that
   it could not find the media.

When I ssh in to the virtualzation host (as root and with -X so graphics
are re-directed), and then use the virt-manager on the virtualization host
directly, the path I provide is accepted and I can continue on.

While researching to see if others reported this, I came across two similar
bugs.  They don't seem to be the problem here though.

493692 (but I have selinux disabled on both the host and the guest)
493743 (but I seem to have trouble sooner than they do in that bug)

I'm in a position to be able to try out new packages if necessary.
Comment 1 Mark McLoughlin 2009-06-05 12:07:03 EDT
Thanks for the report

This is similar to #502204 - we should use the storage pool interface everywhere we are attaching an ISO/image file to a guest
Comment 2 Cole Robinson 2009-06-18 11:07:46 EDT
Fixed upstream:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virt-manager--devel/rev/c18281683490

Moving to POST.
Comment 3 Mark McLoughlin 2009-06-22 11:17:39 EDT
*** Bug 505429 has been marked as a duplicate of this bug. ***
Comment 4 Christopher Grebs 2009-08-04 16:11:37 EDT
Is there any progress on getting this patch packaged in the current fedora 11 release?
Comment 5 Fedora Update System 2009-09-18 11:45:11 EDT
virt-manager-0.7.0-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/virt-manager-0.7.0-6.fc11?_csrf_token=8d215225cd9b1943cd947603a037c8db9ad28548
Comment 6 Fedora Update System 2009-09-24 01:17:54 EDT
virt-manager-0.7.0-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9871
Comment 7 Cole Robinson 2009-10-07 08:27:12 EDT
This should be fixed by virt-manager-0.7.0-7.fc11 now in stable. Closing.

Note You need to log in before you can comment on or make changes to this bug.