Bug 504337 - Kickstart Profiles with virtualization type "None" listed in virt guest Provisioning page, provisioning with them fails with Koan error
Kickstart Profiles with virtualization type "None" listed in virt guest Provi...
Status: CLOSED DUPLICATE of bug 502905
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-05 12:35 EDT by Steve Salevan
Modified: 2009-06-08 09:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-07 14:39:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-06-05 12:35:27 EDT
Description of problem:
If a user creates a kickstart profile, sets its virtualization type set to "None", visits an SDC for a Virtualized Host, and clicks through to its Virtualized guest provisioning page, this profile will be listed as available for kickstarting a guest to.

If this user then kickstarts a guest with this profile, the kickstart will fail with a Koan error:

D: Sending back response (1, 'Virtual kickstart failed. Koan error.', {'koan': '--virt-type should be qemu, xenpv, xenfv, vmware, vmwarew, or auto'})

Version-Release number of selected component (if applicable):
530, 5/29 build

How reproducible:
Always

Steps to Reproduce:
1. Create a Kickstart Profile with virtualization type "None"
2. Attempt to provision a virtualized guest with it
  
Actual results:
Profile listed as available for kickstarting and kickstarting to it results in a Koan error

Expected results:
Profile not available for kickstarting or Koan error does not result

Additional info:
Comment 1 Mike McCune 2009-06-07 14:39:27 EDT

*** This bug has been marked as a duplicate of bug 502905 ***

Note You need to log in before you can comment on or make changes to this bug.