Bug 504400 - ANACONDA CRASH DURING PARTITION LAYOUT CREATION
ANACONDA CRASH DURING PARTITION LAYOUT CREATION
Status: CLOSED DUPLICATE of bug 498350
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-06 02:20 EDT by Fran Serrano
Modified: 2009-06-08 09:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 09:36:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fran Serrano 2009-06-06 02:20:24 EDT
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 917, in populate
    devname = "%s" % device.path
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1339, in getScreen
    self.populate(initial = 1)
  File "/usr/lib/anaconda/gui.py", line 1414, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1331, in nextClicked
    self.setScreen ()
AttributeError: 'NoneType' object has no attribute 'path'

Local variables in innermost frame:
sizestr: 200
drvparent: <GtkTreeIter at 0xa28b170>
disk: DiskDevice instance (0xa204bac) --
  description =   name = sda  status = True  parents = []
  kids = 2
  uuid = None  format = <storage.formats.DeviceFormat object at 0xa20b4ec>  size = 190779.719238
  major = 8  minor = 0  exists = True
  sysfs path = /devices/pci0000:00/0000:00:1f.2/host0/target0:0:0/0:0:0:0/block/sda  label = None
  target size = 0  path = /dev/sda
  format args = []  removable = False  partedDevice = <parted.device.Device object at 0xa20b5ac>
  partedDisk = <parted.disk.Disk object at 0xa20b52c>
size: 200.0
heads: 255
extendedParent: None
self: <PartitionWindow.PartitionWindow instance at 0xa1f82ac>
initial: 1
vgs: []
parent: <GtkTreeIter at 0xa27d5d0>
format: None
devname: /dev/sda1
ptype: None
part: parted.Partition instance --
  disk: <parted.disk.Disk object at 0xa20b52c>  fileSystem: None
  number: 2  path: /dev/sda2  type: 0
  name: None  active: True  busy: False
  geometry: <parted.geometry.Geometry object at 0xa326c6c>  PedPartition: <_ped.Partition object at 0xa33956c>
stripe: <PartitionWindow.DiskStripe instance at 0xa326cac>
device: None
mdarrays: []
cylinders: 24321
sectors: 63
partName: sda2
disks: [<storage.devices.DiskDevice object at 0xa204bac>]
iter: <GtkTreeIter at 0xa055b40>
sectorsPerCyl: 16065


Anaconda instance, containing members:
rescue_mount: True
reIPLMessage: None
intf: InstallInterface instance, containing members:
  intf.icw: InstallControlWindow instance, containing members:
    intf.icw.handle: 1338
    intf.icw.currentWindow: PartitionWindow instance, containing members:
      intf.icw.currentWindow.checkmark_pixbuf: <gtk.gdk.Pixbuf object at 0xa1f7fcc (GdkPixbuf at 0xa2dfae0)>
      intf.icw.currentWindow.intf: Already dumped
      intf.icw.currentWindow.parent: <gtk.Window object at 0x9e35b1c (GtkWindow at 0x9ec50d0)>
      intf.icw.currentWindow.diskStripeGraph: DiskStripeGraph instance, containing members:
        intf.icw.currentWindow.diskStripeGraph.canvas: <gnome.canvas.Canvas object at 0xa33b464 (GnomeCanvas at 0xa162148)>
        intf.icw.currentWindow.diskStripeGraph.textlabels: [<gnome.canvas.CanvasText object at 0xa33b57c (GnomeCanvasText at 0xa27c0c8)>]
        intf.icw.currentWindow.diskStripeGraph.tree: <DiskTreeModel object at 0xa33b34c (GtkTreeStore at 0xa273798)>
        intf.icw.currentWindow.diskStripeGraph.editCB: <bound method PartitionWindow.editCB of <PartitionWindow.PartitionWindow instance at 0xa1f82ac>>
        intf.icw.currentWindow.diskStripeGraph.next_ypos: 66.0
        intf.icw.currentWindow.diskStripeGraph.diskStripes: [DiskStripe instance, containing members:
          group: <gnome.canvas.CanvasGroup object at 0xa33b5a4 (GnomeCanvasGroup at 0xa2d9cc8)>
          slices: [DiskStripeSlice instance, containing members:
            box: <gnome.canvas.CanvasRect object at 0xa33b504 (GnomeCanvasRect at 0xa294500)>
            group: <gnome.canvas.CanvasGroup object at 0xa33b554 (GnomeCanvasGroup at 0xa2d9f08)>
            parent: Already dumped
            text: <gnome.canvas.CanvasText object at 0xa33b5cc (GnomeCanvasText at 0xa279d70)>
            partition: parted.Partition instance --
  disk: <parted.disk.Disk object at 0xa20b52c>  fileSystem: None
  number: 1  path: /dev/sda1  type: 0
  name: None  active: True  busy: False
  geometry: <parted.geometry.Geometry object at 0xa326d4c>  PedPartition: <_ped.Partition object at 0xa33953c>
            editCB: <bound method PartitionWindow.editCB of <PartitionWindow.PartitionWindow instance at 0xa1f82ac>>
            treeView: <DiskTreeModel object at 0xa33b34c (GtkTreeStore at 0xa273798)>
, DiskStripeSlice instance, containing members:
            box: <gnome.canvas.CanvasRect object at 0xa33b5f4 (GnomeCanvasRect at 0xa2ad548)>
            group: <gnome.canvas.CanvasGroup object at 0xa33b644 (GnomeCanvasGroup at 0xa2d9e30)>
            parent: Already dumped
            text: <gnome.canvas.CanvasText object at 0xa33b61c (GnomeCanvasText at 0xa27c1c8)>
            partition: parted.Partition instance --
  disk: <parted.disk.Disk object at 0xa20b52c>  fileSystem: None
  number: 2  path: /dev/sda2  type: 0
  name: None  active: True  busy: False
  geometry: <parted.geometry.Geometry object at 0xa326c6c>  PedPartition: <_ped.Partition object at 0xa33956c>
            editCB: <bound method PartitionWindow.editCB of <PartitionWindow.PartitionWindow instance at 0xa1f82ac>>
            treeView: <DiskTreeModel object at 0xa33b34c (GtkTreeStore at 0xa273798)>
]
          selected: None
          tree: <DiskTreeModel object at 0xa33b34c (GtkTreeStore at 0xa273798)>
          drive: sda
          editCB: <bound method PartitionWindow.editCB of <PartitionWindow.PartitionWindow instance at 0xa1f82ac>>
          hash: {parted.Partition instance --
  disk: <parted.disk.Disk object at 0xa20b52c>  fileSystem: None
  number: 2  path: /dev/sda2  type: 0
  name: None  active: True  busy: False
  geometry: <parted.geometry.Geometry object at 0xa326c6c>  PedPartition: <_ped.Partition object at 0xa33956c>: Already dumped
, parted.Partition instance --
  disk: <parted.disk.Disk object at 0xa20b52c>  fileSystem: None
  number: 1  path: /dev/sda1  type: 0
  name: None  active: True  busy: False
  geometry: <parted.geometry.Geometry object at 0xa326d4c>  PedPartition: <_ped.Partition object at 0xa33953c>: Already dumped
}
          disk: parted.Disk instance --
  type: msdos  primaryPartitionCount: 2
  lastPartitionNumber: 2  maxPrimaryPartitionCount: 4
  partitions: [<parted.partition.Partition object at 0xa20b8cc>, <parted.partition.Partition object at 0xa20b86c>]
  device: <parted.device.Device object at 0xa20b5ac>
  PedDisk: <_ped.Disk object at 0xa20b58c>
]
      intf.icw.currentWindow.show_uneditable: 1
      intf.icw.currentWindow.lock_pixbuf: <gtk.gdk.Pixbuf object at 0xa33b2fc (GdkPixbuf at 0xa2dfaa8)>
      intf.icw.currentWindow.storage: <storage.Storage object at 0x9e2eb2c>
      intf.icw.currentWindow.tree: <DiskTreeModel object at 0xa33b34c (GtkTreeStore at 0xa273798)>
      intf.icw.currentWindow.anaconda: Already dumped
      intf.icw.currentWindow.ics: InstallControlState instance, containing members:
        intf.icw.currentWindow.ics.prevEnabled: True
        intf.icw.currentWindow.ics.cw: Already dumped
        intf.icw.currentWindow.ics.nextEnabled: True
        intf.icw.currentWindow.ics.grabNext: True
        intf.icw.currentWindow.ics.title: Partitioning
      intf.icw.currentWindow.treeViewSelection: <gtk.TreeSelection object at 0xa33b4dc (GtkTreeSelection at 0xa2ab3c0)>
      intf.icw.currentWindow.treeView: <gtk.TreeView object at 0xa33b48c (GtkTreeView at 0xa0854c8)>
    intf.icw.mainxml: <gtk.glade.XML object at 0x9e31b94 (PyGladeXML at 0x9e92060)>
    intf.icw.window: <gtk.Window object at 0x9e35b1c (GtkWindow at 0x9ec50d0)>
    intf.icw.installFrame: <gtk.Frame object at 0x9e3589c (GtkFrame at 0x9e955a0)>
    intf.icw.anaconda: Already dumped
    intf.icw.reloadRcQueued: 0
  intf.runres: 800x600
  intf.anaconda: Already dumped
rescue: False
updateSrc: None
mediaDevice: None
methodstr: livecd:///dev/mapper/live-osimg-min
dispatch: <dispatch.Dispatcher object at 0x9e2eeec>
rootPath: /mnt/sysimage
platform: <platform.X86 object at 0x99d5b0c>
canReIPL: False
xdriver: None
isKickstart: False
stage2: None
id: InstallData instance, containing members:
  id.firewall: Firewall instance, containing members:
    id.firewall.portlist: []
    id.firewall.servicelist: []
    id.firewall.trustdevs: []
    id.firewall.enabled: 1
  id.anaconda: Already dumped
  id.upgradeRoot: None
  id.keyboard: Keyboard instance, containing members:
    id.keyboard.info: {'LAYOUT': es, 'KEYBOARDTYPE': pc, 'VARIANT': , 'KEYTABLE': es, 'MODEL': pc105, 'OPTIONS': }
    id.keyboard.type: PC
    id.keyboard._mods: KeyboardModels instance, containing members:
    id.keyboard.beenset: 1
  id.timezone: Timezone instance, containing members:
    id.timezone.utc: True
    id.timezone.tz: Europe/Madrid
  id.backend: LiveCDCopyBackend instance, containing members:
    id.backend.modeText: 
    id.backend.instPath: /mnt/sysimage
    id.backend.skipFormatRoot: True
    id.backend.instLog: None
    id.backend.supportsUpgrades: False
    id.backend._loopbackFile: None
    id.backend.rootFsType: ext4
    id.backend.osimg: //dev/mapper/live-osimg-min
    id.backend.supportsPackageSelection: False
  id.upgrade: None
  id.monitor: None
  id.storage: <storage.Storage object at 0x9e2eb2c>
  id.desktop: Desktop instance, containing members:
    id.desktop.info: {}
    id.desktop.runlevel: 3
  id.rootParts: None
  id.x_already_set: 1
  id.firstboot: 0
  id.users: None
  id.displayMode: g
  id.auth: --enableshadow --passalgo=sha512 --enablefingerprint
  id.ksdata: None
  id.bootloader: x86BootloaderInfo instance, containing members:
    id.bootloader._configdir: /boot/grub
    id.bootloader.doUpgradeOnly: 0
    id.bootloader.above1024: 0
    id.bootloader.defaultDevice: None
    id.bootloader.pure: None
    id.bootloader.storage: <storage.Storage object at 0x9e2eb2c>
    id.bootloader.serialOptions: None
    id.bootloader.args: KernelArguments instance, containing members:
      id.bootloader.args.args: 
    id.bootloader.kernelLocation: /boot/
    id.bootloader.timeout: None
    id.bootloader._configname: grub.conf
    id.bootloader.device: None
    id.bootloader.kickstart: 0
    id.bootloader.serialDevice: None
    id.bootloader.useGrubVal: 1
    id.bootloader._drivelist: [sda]
    id.bootloader.images: BootImages instance, containing members:
      id.bootloader.images.default: None
      id.bootloader.images.images: {}
    id.bootloader.serial: 0
    id.bootloader.password: None
    id.bootloader.forceLBA32: 0
  id.extraModules: []
  id.network: Network instance, containing members:
    id.network.netdevices: {'pan0': DEVICE=pan0
HWADDR=ea:2f:c4:15:47:7b

, 'wlan0': DEVICE=wlan0
HWADDR=00:1d:e0:21:f4:31

, 'eth0': DEVICE=eth0
HWADDR=00:15:c5:7e:a8:89

}
    id.network.ksdevice: None
    id.network.overrideDHCPhostname: False
    id.network.hostname: localhost.localdomain
    id.network.domains: []
  id.instClass: <installclass.DefaultInstall object at 0x99dbc2c>
  id.isHeadless: 0
  id.videocard: None
  id.instLanguage: Language instance, containing members:
    id.instLanguage.targetLang: None
    id.instLanguage.default: en_US.UTF-8
    id.instLanguage.displayMode: g
    id.instLanguage.current: en_US.UTF-8
  id.security: Security instance, containing members:
    id.security.selinux: 1
  id.upgradeSwapInfo: None
dir: 1
backend: Already dumped


 '1', 'ID_CDROM_CD_R': '1'}
[2009-06-06 08:14:14,269]    DEBUG: no type or existing type for sr0, bailing
[2009-06-06 08:14:14,270]    DEBUG: scanning live-rw (/devices/virtual/block/dm-0)...
[2009-06-06 08:14:14,271]    DEBUG: looking for device 'live-rw'...
[2009-06-06 08:14:14,271]    DEBUG: found None
[2009-06-06 08:14:14,271]    DEBUG: live-rw is a device-mapper device
[2009-06-06 08:14:14,272]    DEBUG: looking for device 'loop3'...
[2009-06-06 08:14:14,273]    DEBUG: found None
[2009-06-06 08:14:14,274]    DEBUG: ignoring loop3 (/devices/virtual/block/loop3)
[2009-06-06 08:14:14,275]    DEBUG: looking for device 'loop3'...
[2009-06-06 08:14:14,275]    DEBUG: found None
[2009-06-06 08:14:14,275]    ERROR: failure scanning device live-rw: could not add slave loop3
Comment 1 Chris Lumens 2009-06-08 09:36:49 EDT

*** This bug has been marked as a duplicate of bug 498350 ***

Note You need to log in before you can comment on or make changes to this bug.