Bug 504416 - Investigate rhnlib not being reported
Investigate rhnlib not being reported
Status: CLOSED DUPLICATE of bug 510798
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: John Matthews
Brandon Perkins
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-06-06 11:06 EDT by Devan Goodwin
Modified: 2009-08-20 09:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 09:25:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2009-06-06 11:06:35 EDT
Description of problem:

This is a spinoff from bug #503090, but it appears that during a RHEL 4 u4 kickstart (possibly other 'u' releases as well), the client reports it's installed packages but rhnlib is for some reason absent from the list.

How reproducible:

Seems 100%...

Steps to Reproduce:
1. Set debug = 5 in /etc/rhn/rhn.conf and restart httpd service.
2. Schedule a RHEL 4u4 kickstart and wait for it to complete.
3. Note that rhnlib was installed during the kickstart by examining /root/install.log.
4. View rhn_server_xmlrpc.log on the Satellite, search for "registration.add_packages".
  
Actual results:

The packages and versions in this list appear to be correct as per what's in install.log, but rhnlib is for some reason excluded.

Expected results:

rhnlib should be reported and recorded in our database just like all other packages.

Additional info:

#503090 details how this was found and an issue it caused, which we've since worked around. The underlying issue however should probably still be investigated and hopefully fixed.

Based on initial investigation it looks like this could be a client side issue.

Be wary of the fact that rhnlib is automatically upgraded to the latest version in kickstart post. This could be a complicating factor, but does not explain why the client does not report it as installed at all.
Comment 1 Devan Goodwin 2009-08-20 09:25:40 EDT

*** This bug has been marked as a duplicate of bug 510798 ***

Note You need to log in before you can comment on or make changes to this bug.