Bug 504450 - preupgrade fails with certain swap line
preupgrade fails with certain swap line
Status: CLOSED DUPLICATE of bug 503830
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-06-07 02:18 EDT by Scott Dodson
Modified: 2009-06-07 02:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-06-07 02:25:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Attached traceback automatically from anaconda. (173.80 KB, text/plain)
2009-06-07 02:19 EDT, Scott Dodson
no flags Details

  None (edit)
Description Scott Dodson 2009-06-07 02:18:52 EDT
The following was filed automatically by anaconda:
anaconda exception report
Traceback (most recent call first):
  File "/tmp/updates/storage/formats/__init__.py", line 289, in setup
    raise FormatSetupError("invalid device specification")
  File "/tmp/updates/storage/formats/swap.py", line 118, in setup
    DeviceFormat.setup(self, *args, **kwargs)
  File "/tmp/updates/storage/__init__.py", line 1581, in turnOnSwap
  File "/usr/lib/anaconda/upgrade.py", line 313, in upgradeMountFilesystems
    anaconda.id.storage.fsset.turnOnSwap(anaconda, upgrading=True)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
  File "/usr/lib/anaconda/dispatch.py", line 227, in currentStep
  File "/usr/lib/anaconda/gui.py", line 1372, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1534, in setup_window
  File "/usr/lib/anaconda/gui.py", line 1544, in run
  File "/usr/lib/anaconda/gui.py", line 1292, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 965, in <module>
FormatSetupError: invalid device specification
Comment 1 Scott Dodson 2009-06-07 02:19:04 EDT
Created attachment 346772 [details]
Attached traceback automatically from anaconda.
Comment 2 Scott Dodson 2009-06-07 02:25:17 EDT
Dupe of 503830, just created out of convenience via anaconda's automatic bugzilla submission.

*** This bug has been marked as a duplicate of bug 503830 ***

Note You need to log in before you can comment on or make changes to this bug.