Bug 503830 - preupgrade fails on F10 to rawhide upgrade
preupgrade fails on F10 to rawhide upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:39cac40c106c0ad12...
: Reopened
: 504450 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-02 18:02 EDT by Martí­n Marqués
Modified: 2010-05-09 01:15 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-14 12:03:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (127.34 KB, text/plain)
2009-06-02 18:02 EDT, Martí­n Marqués
no flags Details
Attached traceback automatically from anaconda. (168.57 KB, text/plain)
2009-06-07 02:07 EDT, Scott Dodson
no flags Details
New report (151.41 KB, text/plain)
2009-06-09 13:17 EDT, Martí­n Marqués
no flags Details
Attached traceback automatically from anaconda. (139.77 KB, text/plain)
2009-06-10 06:03 EDT, James Heather
no flags Details
Attached traceback automatically from anaconda. (132.86 KB, text/plain)
2009-06-14 13:14 EDT, shulamy
no flags Details
Attached traceback automatically from anaconda. (167.73 KB, text/plain)
2009-06-19 13:45 EDT, Antonio J.
no flags Details
Attached traceback automatically from anaconda. (224.30 KB, text/plain)
2009-07-01 21:00 EDT, vamsee
no flags Details
Attached traceback automatically from anaconda. (172.88 KB, text/plain)
2009-07-10 01:07 EDT, Ask Bjørn Hansen
no flags Details
Attached traceback automatically from anaconda. (215.54 KB, text/plain)
2009-07-18 10:57 EDT, Arnaud Dubois
no flags Details
Attached traceback automatically from anaconda. (228.44 KB, text/plain)
2009-09-02 09:48 EDT, josef radinger
no flags Details
Attached traceback automatically from anaconda. (225.60 KB, text/plain)
2009-09-02 09:54 EDT, josef radinger
no flags Details
Attached traceback automatically from anaconda. (277.50 KB, text/plain)
2010-05-09 01:15 EDT, Jeremy Enos
no flags Details

  None (edit)
Description Martí­n Marqués 2009-06-02 18:02:31 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.57 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 289, in setup
    raise FormatSetupError("invalid device specification")
  File "/usr/lib/anaconda/storage/formats/swap.py", line 118, in setup
    DeviceFormat.setup(self, *args, **kwargs)
  File "/usr/lib/anaconda/storage/__init__.py", line 1581, in turnOnSwap
    device.format.setup()
  File "/usr/lib/anaconda/upgrade.py", line 313, in upgradeMountFilesystems
    anaconda.id.storage.fsset.turnOnSwap(anaconda, upgrading=True)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 227, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1372, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1534, in setup_window
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1544, in run
    self.setup_window(runres)
  File "/usr/lib/anaconda/gui.py", line 1292, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 965, in <module>
    anaconda.intf.run(anaconda)
FormatSetupError: invalid device specification
Comment 1 Martí­n Marqués 2009-06-02 18:02:38 EDT
Created attachment 346327 [details]
Attached traceback automatically from anaconda.
Comment 2 Martí­n Marqués 2009-06-02 18:19:40 EDT
This was done using an uptodate Fedora 10. I'm trying to test F11-preview and yum didn't let me get there, so I tried preupgrade which is great until anaconda fails.
Comment 3 Martí­n Marqués 2009-06-02 18:23:52 EDT
Looks like it didn't like the swap line in /etc/fstab. This notebook didn't have swap partition, so I created a swapfile which does as a swap filesystem.

Does anaconda actually read the original /etc/fstab file to look for a swap partition? I'll comment out the swap line in /etc/fstab and try again.
Comment 4 Martí­n Marqués 2009-06-03 08:08:12 EDT
OK, found the source of the error.

I had this line in /etc/fstab

/home/swapfile   swap   swap   defaults   0 0

Commented out the line and right now anaconda is upgradeing my system.

Now, why didn't anaconda ignore that line after the error occured?
Comment 5 Andy Lindeberg 2009-06-03 10:02:35 EDT

*** This bug has been marked as a duplicate of bug 496529 ***
Comment 6 David Lehman 2009-06-03 17:40:03 EDT
You can try my proposed fix by adding

  updates=http://dlehman.fedorapeople.org/updates-503830.img

to the kernel command line when booting the installer.

Please let me know how it goes.
Comment 7 Martí­n Marqués 2009-06-06 08:10:21 EDT
Is an internet connection needed?

Is there a way to doenload the image, maybe to /boot/upgrade/ and use instead

  updates=hd:UUID=adbbd5f0-5fdd-496e-a832-5d868255bc71:/boot/upgrade/updates-503830.img
Comment 8 Scott Dodson 2009-06-07 02:07:29 EDT
Created attachment 346771 [details]
Attached traceback automatically from anaconda.
Comment 9 Scott Dodson 2009-06-07 02:25:18 EDT
*** Bug 504450 has been marked as a duplicate of this bug. ***
Comment 10 Scott Dodson 2009-06-07 02:26:00 EDT
Seems this still happens with the provided updates image.
Comment 11 Scott Dodson 2009-06-07 02:44:01 EDT
I was using an encrypted swap partition, if I disable that it works fine. 

Here's my config when it was failing, VolGroup00/LogVol02 is /home, also encrypted but using luks.

/etc/fstab:
UUID=ee5052b2-e92c-471d-aa52-b8b1eb76d84d /home ext3    defaults 0 0
UUID=83c47f1f-fef0-4be6-a56c-cdf2d835799a /     ext3    defaults 1 1
UUID=75704042-de87-4899-98a0-4a5419a06a11 /boot ext3    defaults 0 0 
devpts          /dev/pts        devpts  gid=5,mode=620  0 0
tmpfs           /dev/shm        tmpfs   defaults        0 0
sysfs           /sys            sysfs   defaults        0 0
proc            /proc           proc    defaults        0 0
#/dev/VolGroup00/LogVol00        swap    swap    defaults        0 0
/dev/mapper/swap    swap        swap    detaults    0 0


/etc/crypttab:
luks-VolGroup00-LogVol02 /dev/mapper/VolGroup00-LogVol02 none
swap    /dev/VolGroup00/LogVol00    /dev/random swap,cipher=aes-cbc-essiv:sha256
Comment 12 Bug Zapper 2009-06-09 12:59:42 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Martí­n Marqués 2009-06-09 13:17:21 EDT
Created attachment 347060 [details]
New report
Comment 14 Martí­n Marqués 2009-06-09 13:18:37 EDT
Tried it again with another F10 server I have, with the exact same swapfile line in /etc/fstab and got the same result, obviously using the update-505850.img
Comment 15 James Heather 2009-06-10 06:03:51 EDT
Created attachment 347179 [details]
Attached traceback automatically from anaconda.
Comment 16 James Heather 2009-06-11 04:49:58 EDT
In my case, it appears it was a result of having two swap lines in /etc/fstab, the first of which was wrong (referred to a non-existent volgroup). I'm not quite sure how that line got there, since anaconda is the only thing that's ever edited that file, but that's another issue.

Removing the bad swap line solved the problem for me.

Presumably:

(1) when the system is up and running, the kernel ignores any attempt to use non-existent swap space;

(2) anaconda should do the same.

This is rather similar to Comment #4.
Comment 17 shulamy 2009-06-14 13:14:56 EDT
Created attachment 347836 [details]
Attached traceback automatically from anaconda.
Comment 18 Antonio J. 2009-06-19 13:45:47 EDT
Created attachment 348689 [details]
Attached traceback automatically from anaconda.
Comment 19 vamsee 2009-07-01 21:00:04 EDT
Created attachment 350228 [details]
Attached traceback automatically from anaconda.
Comment 20 Ask Bjørn Hansen 2009-07-10 01:07:49 EDT
Created attachment 351214 [details]
Attached traceback automatically from anaconda.
Comment 21 Ask Bjørn Hansen 2009-07-10 01:12:10 EDT
My variation of this bug was the installer not detecting/finding/activating my "whole disk" PV on /dev/sdb . My swap volume is /dev/vg1/swap -- vg1 is on sdb.
Comment 22 David Lehman 2009-07-17 12:39:53 EDT
(In reply to comment #21)
> My variation of this bug was the installer not detecting/finding/activating my
> "whole disk" PV on /dev/sdb . My swap volume is /dev/vg1/swap -- vg1 is on sdb.  

We do not currently support the use of whole-disk formatting other than disklabels in anaconda, although support for this is planned for F12.
Comment 23 David Lehman 2009-07-17 12:41:14 EDT
(In reply to comment #19)
> Created an attachment (id=350228) [details]
> Attached traceback automatically from anaconda.  

Your problem was identified and resolved in anaconda-12.0-1, and is slightly different from the other reporters'.
Comment 24 vamsee 2009-07-17 13:49:59 EDT
(In reply to comment #23)
> (In reply to comment #19)
> > Created an attachment (id=350228) [details] [details]
> > Attached traceback automatically from anaconda.  
> 
> Your problem was identified and resolved in anaconda-12.0-1, and is slightly
> different from the other reporters'.  

I have this problem when I was trying to upgrade to Fedora 11 (Leonidas) from Fedora 10. It happened after it appeared to download all the files it needs. I was holding off on upgrading. So should I try the upgrade again now or should I patch anaconda to 12.0.1 and then try the upgrade?
Comment 25 Arnaud Dubois 2009-07-18 10:57:33 EDT
Created attachment 354255 [details]
Attached traceback automatically from anaconda.
Comment 26 Arnaud Dubois 2009-07-18 11:14:42 EDT
Bug appeared during upgrade from not uptodate F10 x86_64 (kernel version locked on 2.6.27.9-159 to prevent a bug with lvm support on my system - cf 481761) to Leonidas.

Will try to disable swap in fstab first and then to remove version lock.
Comment 27 Arnaud Dubois 2009-07-18 13:10:55 EDT
Disabling swap in fstab allowed me to run preupgrade with no more bug.
Comment 28 David Lehman 2009-07-21 12:33:44 EDT
(In reply to comment #27)
> Disabling swap in fstab allowed me to run preupgrade with no more bug.  

While you have hit the same bug reported here, you also have another problem. There is a typo in your /etc/fstab file. The swap file '/dev/SAmsung500G/swap' will not be successfully activated on any linux system since it does not exist. (Note "SAmsung" instead of "Samsung")
Comment 29 Arnaud Dubois 2009-07-21 13:36:02 EDT
Yeah, I've noticed it during post-install and correct it.

In fact, I've had to modify manually my fstab with a SysRescueCD due to a problem with /dev/dm-X (instead of /dev/vg/lv) in fstab which prevents the original F10 kernel to boot too. The typo comes from there.
But I don't know where the problem wui /dev/dm-X naming came from. It seems to appear during my first attempt to upgrade. Very strange.
Comment 30 David Lehman 2009-07-21 13:45:56 EDT
That is a relatively common problem. One should never use /dev/dm-X in fstab or anywhere else. These device names depend on the order in which device-mapper devices are created/activated, so they are not at all guaranteed to remain the same across reboots or upgrades. The persistently named devices in /dev/mapper/ are best.
Comment 31 David Lehman 2009-08-14 12:03:07 EDT
This should have been fixed in anaconda-12.4-1. Please reopen it if you see this behavior in anaconda-12.4-1 or later.
Comment 32 josef radinger 2009-09-02 09:48:17 EDT
Created attachment 359525 [details]
Attached traceback automatically from anaconda.
Comment 33 josef radinger 2009-09-02 09:54:39 EDT
Created attachment 359526 [details]
Attached traceback automatically from anaconda.
Comment 34 Jeremy Enos 2010-05-09 01:15:33 EDT
Created attachment 412599 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.