Bug 504540 - Graphics corrupted on Fedora 11 (preview) KDE Live CD
Graphics corrupted on Fedora 11 (preview) KDE Live CD
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-07 22:51 EDT by Richard Cavell
Modified: 2009-11-26 12:06 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-26 12:06:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Cavell 2009-06-07 22:51:43 EDT
Description of problem:

I downloaded and burned Fedora 11 KDE version, Live CD and verified that the .iso was not corrupt.  I booted my computer from the CD.  It gives me a blue screen with the fedora logo and a graphic that looks like an infinity sign that pulses back and forth.  A white bar down the bottom of the screen grows from left to right, but the graphics to the right of the status bar are corrupt.  The white bar manages to make it all the way to the right of screen.  Then the screen is replaced by what looks like it should be a login screen but the graphics are all corrupted.  I have a mouse pointer that is corrupted, but can be moved around.  Nothing is clickable.  The only solution is to power off.  Fedora 11 KDE is completely unusable on my machine.

Version-Release number of selected component (if applicable):

64-bit Fedora Core 11 Beta KDE Live CD downloaded from: http://download.fedoraproject.org/pub/fedora/linux/releases/test/11-Preview/Live/x86_64/F11-Preview-x86_64-Live-KDE.iso

How reproducible:

Always reproducible by booting from the CD.

Steps to Reproduce:
1.  Boot from Live CD.
  
Additional info:

I'm using a Macbook second generation, first stepping.  IntelCore2Duo 1.83GHz, 667 MHz FSB, I've tried 1 Gig RAM and also installed 3 Gig RAM.  Intel GMA 950 integrated chipset that shares RAM from the main memory.  I'm able to boot 64-bit Ubuntu (Gnome) and OS X and Windows 7 on the same machine without any problem.
Comment 1 Sebastian Vahl 2009-06-08 09:50:26 EDT
This is more likely a KDE/X/Intel issue than only related to the live images. So I'm re-assigning it to kdebase-workspace first, to get some more KDE folks in.

In the meantime: Could you please try to boot the live image with the boot option "nomodeset"? (Press tab at the boot menu and enter nomodeset there, then press enter)
Comment 2 Kevin Kofler 2009-06-08 10:18:48 EDT
Looks like an Intel KMS (kernel modesetting) bug to me, the corruption starts even before X11 is started.

As this is the preview, it may already be fixed though. I'd suggest trying the final release tomorrow. (The release is already made, it's being mirrored as we speak, so waiting that one more day before doing more testing won't change how and when this will be fixed.)
Comment 3 Richard Cavell 2009-06-10 06:08:56 EDT
Hi, guys.

I booted the Live Preview and entered the nomodeset option, as requested.  (there were many other options on the command line and I just added it)

It stated in text: couldn't find an input interrupt endpoint, with some additional text.  I'll have to reboot a few times to capture the text if you want me to.

Now the screen enters what is obviously a text mode.  Three status bars crawl from left to right and I have 'Fedora 10.92' in the lower right hand corner.  Then I boot into KDE. I am now typing this within Konqueror.

(By the way, I got a couple of errors in '/home/liveuser/.local/share/akonadi/db_data/mysql.err' while booting from the Live CD.  Should I be worried about this?)

So thanks for fixing it... 

BUT!

Today I downloaded the final version (not the preview).  Fedora 11, KDE Live disc.  And it's back to its old tricks.  I tried entering nomodeset.  memtest was the default option, and I just deleted that and entered nomodeset.  It did no good.  Now that I now what the splash screen is supposed to look like, I confirm that it definitely bugs out somewhere in the splash screen.  I get a corrupted mouse pointer, which can still be moved around, and a corrupted splash screen, and a corrupted wavy-line-that-is-supposed-to-tell-you-the-progress.  Yet, I can still cause it to react to me in some ways.  I can press my power button and it does a little disk activity, implying that it's still working in some way.  But it won't leave the splash screen and it won't give me the KDE desktop.

Richard
Comment 4 Richard Cavell 2009-06-11 19:05:29 EDT
By the way, is this related to Bug 488824 or bug 505058?  It looks like Fedora is having a bad trot with the Intel GMA 950 chipset.

Richard
Comment 5 Klaatu 2009-06-21 00:14:19 EDT
I am also seeing this bug on my Macbooks.
Comment 6 Richard Cavell 2009-06-21 00:34:46 EDT
(In reply to comment #5)
> I am also seeing this bug on my Macbooks.  

Klaatu, can you confirm that the preview works for you with nomodeset and the final release does not work, whether nomodeset or not?

Richard
Comment 7 Steven M. Parrish 2009-11-26 12:06:07 EST
We have not received feedback to the information we have requested above, we will assume the problem was not reproducible, or has been fixed in one of the updates we have released for the reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest update of their distribution, and if this issue turns out to still be reproducible in the latest update, please reopen this bug with additional information.

Closing as INSUFFICIENT_DATA.

Note You need to log in before you can comment on or make changes to this bug.