Bug 504605 - virt-manager gets sparse/nosparse mixed up in New VM dialog
virt-manager gets sparse/nosparse mixed up in New VM dialog
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-06-08 09:43 EDT by Mark McLoughlin
Modified: 2009-10-07 08:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 08:27:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager-0.7.0-to-sparse-or-not-to-sparse.patch (1.08 KB, patch)
2009-06-08 09:43 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Mark McLoughlin 2009-06-08 09:43:46 EDT
Created attachment 346871 [details]
virt-manager-0.7.0-to-sparse-or-not-to-sparse.patch

virt-manager-0.7.0-5.fc11.x86_64

In virt-manager's 'New VM' dialog leave 'Allocate entire disk now' option checked and notice that the disk is created with VirtualDisk(sparse = True)

Attaching a fix

Not a big deal, right now, since virtinst currently ignores the flag - see bug #504604
Comment 1 Cole Robinson 2009-06-16 21:27:52 EDT
Applied upstream:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virt-manager--devel/rev/bd26943d4dad

Moving to POST.
Comment 2 Fedora Update System 2009-09-18 11:45:00 EDT
virt-manager-0.7.0-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/virt-manager-0.7.0-6.fc11?_csrf_token=8d215225cd9b1943cd947603a037c8db9ad28548
Comment 3 Fedora Update System 2009-09-24 01:17:43 EDT
virt-manager-0.7.0-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9871
Comment 4 Cole Robinson 2009-10-07 08:27:48 EDT
This should be fixed by virt-manager-0.7.0-7.fc11 now in stable. Closing.

Note You need to log in before you can comment on or make changes to this bug.