Bug 50461 - non-ext2 root filesystem is not unmounted on shutdown
Summary: non-ext2 root filesystem is not unmounted on shutdown
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 50752 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-31 13:41 UTC by David Nečas
Modified: 2014-03-17 02:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-31 13:42:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (378 bytes, patch)
2001-07-31 13:41 UTC, David Nečas
no flags Details | Diff

Description David Nečas 2001-07-31 13:41:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.19 i686; en-US; rv:0.9.1)
Gecko/20010607

Description of problem:
/etc/init.d/halt umounts all filesystems not matching
/(^#|proc|loopfs|autofs|^none|^\/dev\/root| \/ )/
and then it remount read-only filesystems matching /ext2/ (and ummounts
proc).  Thus when root filesystem is not ext2, it is neither unmounted
(which is ok) nor remounted read-only (which is bad).

How reproducible:
Always

Steps to Reproduce:
1. setup system to use reiserfs (for example) root filesystem
2. run poweroff / halt / reboot

	

Actual Results:  Root file system is left mounted read-write on shutdown,
journal log replay starts on next boot.

Expected Results:  Root file system is remounted read-only on shutdown.

Additional info:

I fixed it using the same sematics for what is excluded from unmounting and
what is then remounted read only.  Patch attached.

Comment 1 David Nečas 2001-07-31 13:41:57 UTC
Created attachment 25592 [details]
patch

Comment 2 Bill Nottingham 2001-07-31 18:29:03 UTC
Will be fixed in 6.11-1; thanks for the patch!

Comment 3 Bill Nottingham 2001-08-03 02:46:32 UTC
*** Bug 50752 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.