Bug 504829 - DeviceTreeError: duplicate paths in device tree
DeviceTreeError: duplicate paths in device tree
Status: CLOSED DUPLICATE of bug 516567
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:54076484bd93f994f...
:
: 505872 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 13:07 EDT by Christopher Kaliszewski
Modified: 2010-08-17 16:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 16:37:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (128.98 KB, text/plain)
2009-06-09 13:07 EDT, Christopher Kaliszewski
no flags Details
Attached traceback automatically from anaconda. (117.20 KB, text/plain)
2009-07-15 07:35 EDT, Maarten Dijkema
no flags Details
Attached traceback automatically from anaconda. (73.00 KB, text/plain)
2009-08-05 13:54 EDT, Christoph van der Reijden
no flags Details
Attached traceback automatically from anaconda. (72.78 KB, text/plain)
2009-08-05 14:52 EDT, Christoph van der Reijden
no flags Details
Attached traceback automatically from anaconda. (90.85 KB, text/plain)
2009-08-22 19:06 EDT, Walid Zein
no flags Details
Attached traceback automatically from anaconda. (94.16 KB, text/plain)
2009-09-02 13:26 EDT, Triantafillos Paradas
no flags Details
Attached traceback automatically from anaconda. (205.45 KB, text/plain)
2009-10-23 13:49 EDT, Lewis
no flags Details
Attached traceback automatically from anaconda. (165.12 KB, text/plain)
2009-10-23 15:05 EDT, Lewis
no flags Details

  None (edit)
Description Christopher Kaliszewski 2009-06-09 13:07:33 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 1782, in devices
    raise DeviceTreeError("duplicate paths in device tree")
  File "/usr/lib/anaconda/storage/__init__.py", line 309, in devices
    devices = self.devicetree.devices.values()
  File "/usr/lib/anaconda/storage/__init__.py", line 607, in newVG
    if pv not in self.devices:
  File "/usr/lib/anaconda/storage/partitioning.py", line 126, in _scheduleLVs
    vg = anaconda.id.storage.newVG(pvs=pvs)
  File "/usr/lib/anaconda/storage/partitioning.py", line 194, in doAutoPartition
    _scheduleLVs(anaconda, devs)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
DeviceTreeError: duplicate paths in device tree
Comment 1 Christopher Kaliszewski 2009-06-09 13:07:41 EDT
Created attachment 347058 [details]
Attached traceback automatically from anaconda.
Comment 2 Maarten Dijkema 2009-07-15 07:35:55 EDT
Created attachment 353805 [details]
Attached traceback automatically from anaconda.
Comment 3 Maarten Dijkema 2009-07-15 10:19:22 EDT
Apparently there where some leftovers from a previous installation (CentOS, LVM, read only snapshot). When directing anaconda to 'remove existing linux installations' and opting for a review of the disk partitioning scheme, all went well.
Comment 4 Christoph van der Reijden 2009-08-05 13:54:21 EDT
Created attachment 356391 [details]
Attached traceback automatically from anaconda.
Comment 5 Christoph van der Reijden 2009-08-05 14:52:38 EDT
Created attachment 356405 [details]
Attached traceback automatically from anaconda.
Comment 6 Christoph van der Reijden 2009-08-06 00:09:09 EDT
Installation of Fedora11 failed for the second time (see also comment #4). 
What can I do next to install Fedora11 successfully?
Fedora10 works fine on my computer!
Thanks!
Comment 7 Walid Zein 2009-08-22 19:06:19 EDT
Created attachment 358332 [details]
Attached traceback automatically from anaconda.
Comment 8 Triantafillos Paradas 2009-09-02 13:26:46 EDT
Created attachment 359558 [details]
Attached traceback automatically from anaconda.
Comment 9 Chris Lumens 2009-10-05 09:33:35 EDT
*** Bug 505872 has been marked as a duplicate of this bug. ***
Comment 10 Lewis 2009-10-23 13:49:09 EDT
Created attachment 365876 [details]
Attached traceback automatically from anaconda.
Comment 11 Lewis 2009-10-23 15:05:59 EDT
Created attachment 365882 [details]
Attached traceback automatically from anaconda.
Comment 12 Bug Zapper 2009-11-16 05:02:22 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 David Lehman 2010-01-18 11:34:35 EST
Has anyone hit this bug using Fedora 12?
Comment 14 Andy Lindeberg 2010-08-17 16:37:59 EDT

*** This bug has been marked as a duplicate of bug 516567 ***

Note You need to log in before you can comment on or make changes to this bug.