Bug 505872 - Fedora 11 failed to install on system with fake RAID in striping mode
Fedora 11 failed to install on system with fake RAID in striping mode
Status: CLOSED DUPLICATE of bug 504829
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 09:12 EDT by Pavlo Dolgosheyev
Modified: 2009-10-05 09:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-05 09:33:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception #1 (119.86 KB, text/plain)
2009-06-14 09:18 EDT, Pavlo Dolgosheyev
no flags Details
Exception #2 (224.24 KB, text/plain)
2009-06-14 09:19 EDT, Pavlo Dolgosheyev
no flags Details

  None (edit)
Description Pavlo Dolgosheyev 2009-06-14 09:12:20 EDT
Description of problem: Failed to install


Version-Release number of selected component (if applicable):


How reproducible: stable reproduce


Steps to Reproduce:
1. Install Fedora 11 via NFS on computer with fake raid controller with 2 identical SATA disks and raid in mode 'Striping'
  
Actual results: Exception in installer

Expected results: Complete install
Comment 1 Pavlo Dolgosheyev 2009-06-14 09:18:29 EDT
Created attachment 347819 [details]
exception #1
Comment 2 Pavlo Dolgosheyev 2009-06-14 09:19:26 EDT
Created attachment 347820 [details]
Exception #2
Comment 3 Andy Lindeberg 2009-06-15 14:32:00 EDT
There are two separate problems here, one of which is RAID and one is general partitioning. The general partitioning bug may be the same as another report (505887), so I will ask dlehman to look at it when he's back from vacation and if they're the same problem, use that bug for that problem.
Comment 4 Nathan Belomy 2009-06-23 18:53:59 EDT
Ok I Upgraded from Fedora 10, through the automated process on a HP ML 310 (fake raid, set to Raid0). I also noticed that the usb failed, possibly because of the bluetooth usb adapater, in which bluetooth also failed.
Comment 5 Scott Pedigo 2009-07-01 12:02:32 EDT
I had a similar problem, when installing Fedora 11 from the bootable CD-ROM onto a system with 6 drives: a pair of S-ATA drives in a RAID 0 array, two IDE drives as single-drive stripes connected to a separate PCI card, and two more IDE drives connected to the motherboard IDE controller. 

The two single-drive stripes sounds similar to the described situation, the difference in my case being that I was able to install Fedora onto the RAID 0 array, but then not able to mount the other four drives.

Detailed description:

Fedora 11 recognized the RAID 0 array connected to the Intel ICH9R southbridge chip on the Gigabyte GA-P35-DS4 motherboard, consisting of mirrored 320 GB Samsung HD321K SATA drives. I installed onto this array.

However, the lvm (logical volume manager) did not properly handle a pair of IDE drives connected to a separate Promise TX2000 FastTrack PCI card, a RAID controller which can control up to 4 drives. Two 120 GB ATA/133 Maxtor DiamondMax Plus 9 drives were connected to it on separate cables, both set as master and each configured as a stripe consisting of a single drive. 

What I had actually wanted was just an additional plain old IDE controller, but the PCI card is such that it insists on configuring the drives as RAID drives, leaving me no choice other than two create two single-drive stripes if I want to mount them separately.

The lvm added entries for these to /dev/mapper, but it was not possible to mount them. The /dev directory had entries for the drives, but not their partitions. Running "fdisk -l" showed the drive information as expected, and running "partprobe" added the partition entries to /dev, however they could not be mounted afterwards. Any attempt to mount or reformat the drives resulted in an error message that the device was busy. However, neither "lsof" or "fuser" indicated any user, so presumably lvm was blocking any mounting.

The problem with the lvm also prevented the two other drives from being properly seen or mounted. Another pair of Maxtor drives were installed in removable bays, connected to the IDE controller on the motherboard. Like the drives connected to the PCI card, for one or both, their partitions were not shown in /dev. At one point during multiple installation attempts, one of them was mountable, but never both. Removing the PCI card solved the problem, and the drives in the removable bays could be mounted.
Comment 6 Chris Lumens 2009-10-05 09:33:34 EDT

*** This bug has been marked as a duplicate of bug 504829 ***

Note You need to log in before you can comment on or make changes to this bug.