Bug 504854 - "yum clean all" doesn't remove deltas
"yum clean all" doesn't remove deltas
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum-presto (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Dieter
Fedora Extras Quality Assurance
:
: 520834 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 14:48 EDT by Mads Kiilerich
Modified: 2009-09-13 08:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-12 16:31:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2009-06-09 14:48:22 EDT
Description of problem:

"yum clean all" does exactly the steps mentioned in the yum man page. But with the new nice rpm deltas that no longer matches the man pages intention to "clean up various things which accumulate in the yum cache directory over time".

I would expect "yum clean all" to also remove /var/cache/yum/*/deltas/* when presto is enabled.

Version-Release number of selected component (if applicable):
yum-presto-0.5.0-1.fc11.noarch
yum-3.2.23-3.fc11.noarch
Comment 1 James Antill 2009-06-09 16:11:52 EDT
Fixed upstream.
Comment 2 Jonathan Dieter 2009-07-10 13:50:52 EDT
Um, in yum or yum-presto?  I would like to close this, but it's definitely not been fixed in yum-presto's upstream code (at least as far as I can see, but maybe I'm missing something).
Comment 3 James Antill 2009-07-13 09:59:49 EDT
 Do you not see commit cba36bde1d3efca0fafa0fe079060ffff1ff7c3b in presto?

 I just did push on my local checkout of ssh://git.fedorahosted.org/git/presto ... and it said 'Already up-to-date'.
Comment 4 Jonathan Dieter 2009-07-14 05:09:56 EDT
Sorry, that's my bad.  This is the first time I've used git in a project I'm not working on alone, so I thought "Fetch from origin" would automatically merge in the latest changeset as well.
Comment 5 Jonathan Dieter 2009-09-12 16:26:30 EDT
*** Bug 520834 has been marked as a duplicate of this bug. ***
Comment 6 Jonathan Dieter 2009-09-12 16:31:57 EDT
Fixed in yum-presto-0.6.0
(available for Rawhide at http://koji.fedoraproject.org/koji/taskinfo?taskID=1674070, and should be in the next Rawhide push)
Comment 7 Amit Shah 2009-09-13 07:44:02 EDT
Is this being backported to F11?
Comment 8 Jonathan Dieter 2009-09-13 08:40:16 EDT
I'd like to test 0.6.0 for a couple of weeks in Rawhide.  If there are no problems (and there really shouldn't be, the changes were trivial), I'll happily build it for F11.

Note You need to log in before you can comment on or make changes to this bug.