Bug 504874 - Should say /dev/sda in 17.2.1. Reinstalling the Boot Loader
Should say /dev/sda in 17.2.1. Reinstalling the Boot Loader
Status: CLOSED NEXTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
All Linux
low Severity medium
: ---
: ---
Assigned To: David Nalley
David Nalley
:
: 504875 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 16:44 EDT by Andre Robatino
Modified: 2009-06-17 19:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 19:53:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2009-06-09 16:44:43 EDT
Description of problem:
In http://docs.fedoraproject.org/install-guide/f11/en-US/html/s1-rescuemode-boot.html it refers to /dev/hda, which should say /dev/sda instead.  I discovered this after reinstalling Windows and getting a "/dev/hda: Not found or not a block device." error.
Comment 1 Karsten Wade 2009-06-09 17:40:20 EDT
*** Bug 504875 has been marked as a duplicate of this bug. ***
Comment 2 eric@christensenplace.us 2009-06-10 18:29:07 EDT
Can any of these be closed?
Comment 3 Ruediger Landmann 2009-06-10 18:47:15 EDT
This isn't really a bug. The actual text reads: 

"Type /sbin/grub-install /dev/hda to reinstall the GRUB boot loader, where /dev/hda is the boot partition."

So, where /dev/hda is *not* the boot partition, you should change this to whatever is appropriate for your particular system. 

Having said that, /dev/hda is an unusual example now, and I'll change this for version 11.1 of the guide in the next few weeks.
Comment 4 Andre Robatino 2009-06-10 18:56:26 EDT
It's not good to give the boot partition argument a name that just happens to coincide with a particular common value of it, since people will take it to mean that the boot partition is, in fact, always /dev/hda.  Instead, it should say something like

"Type /sbin/grub-install bootpart to reinstall the GRUB boot loader, where bootpart is the boot partition (usually /dev/sda)."
Comment 5 Ruediger Landmann 2009-06-17 19:53:35 EDT
Updated along the lines you suggest. This will appear in the next release of the guide. Thanks!

Note You need to log in before you can comment on or make changes to this bug.