Bug 504882 - Cannot build bitlbee plugins - no bitlbee-devel package
Cannot build bitlbee plugins - no bitlbee-devel package
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: bitlbee (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
PackageBranch
:
Depends On: 505351
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 18:15 EDT by Len Trigg
Modified: 2009-09-02 20:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.2.3-4.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-16 18:50:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to spec file adding -devel package (2.61 KB, patch)
2009-06-09 18:15 EDT, Len Trigg
no flags Details | Diff
sourcefile containing patch for pgkconfig location and extra include header (1.21 KB, patch)
2009-06-09 18:17 EDT, Len Trigg
no flags Details | Diff

  None (edit)
Description Len Trigg 2009-06-09 18:15:03 EDT
Created attachment 347098 [details]
patch to spec file adding -devel package

Description of problem:

There is no bitlbee-devel package corresponding to the current bitlbee rpm.

Version-Release number of selected component (if applicable):

1.2.3-1

I would like to build the bitlbee-skype plugin, but there is no bitlbee-devel containing the needed headers. I had a crack at modifying the bitlbee spec file and have something that seems pretty close.  I am a complete novice when it comes to rpm spec file writing, so it is probably wrong in a bunch of respects, but thought I would post it here for comment/improvement/incorporation.
Comment 1 Len Trigg 2009-06-09 18:17:40 EDT
Created attachment 347099 [details]
sourcefile containing patch for pgkconfig location and extra include header

My specfile references a new patch (attached), that sets the pgkconfigdir if on x86_64 architecture (there is almost certainly a proper way to do this), and adds an extra header needed due to the existing libresolv patch.
Comment 2 Robert Scheck 2009-06-09 18:31:42 EDT
I'll try to have a look to it the next days. I'll re-read your pkgconfig
patch and try to get it upstream, if the modification is really needed.
Comment 3 Robert Scheck 2009-06-11 11:20:33 EDT
I'll come back to this, once bug #505351 is solved.
Comment 4 Robert Scheck 2009-06-11 18:33:08 EDT
In addition to that, your suggestion is unfortunately not multilib-safe.
Comment 5 Robert Scheck 2009-06-13 16:03:06 EDT
Regarding the multilib issue, I'm waiting for a clarification on fedora-devel:
https://www.redhat.com/archives/fedora-devel-list/2009-June/msg00987.html
Comment 6 Fedora Update System 2009-08-16 18:52:41 EDT
bitlbee-1.2.3-4.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/bitlbee-1.2.3-4.el4
Comment 7 Fedora Update System 2009-08-16 18:52:41 EDT
bitlbee-1.2.3-4.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/bitlbee-1.2.3-4.el5
Comment 8 Fedora Update System 2009-08-16 18:52:54 EDT
bitlbee-1.2.3-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/bitlbee-1.2.3-4.fc11
Comment 9 Fedora Update System 2009-08-17 16:44:07 EDT
bitlbee-1.2.3-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/bitlbee-1.2.3-4.fc10
Comment 10 Fedora Update System 2009-09-02 16:54:56 EDT
bitlbee-1.2.3-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-09-02 16:56:12 EDT
bitlbee-1.2.3-4.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-09-02 20:31:10 EDT
bitlbee-1.2.3-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2009-09-02 20:34:09 EDT
bitlbee-1.2.3-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.