Bug 505351 - rpmfcHelper: Zusicherung »EVR != ((void *)0)« nicht erfüllt.
rpmfcHelper: Zusicherung »EVR != ((void *)0)« nicht erfüllt.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 504882
  Show dependency treegraph
 
Reported: 2009-06-11 11:18 EDT by Robert Scheck
Modified: 2009-10-08 23:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.6.1-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-08 23:45:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-06-11 11:18:57 EDT
Description of problem:
Following *.pc file causes rpmbuild to fail the package rebuild:

--- snipp ---
prefix=/usr
includedir=/usr/include/bitlbee/

Name: bitlbee
Description: IRC to IM gateway
Requires: glib-2.0
Version:
Libs:
Cflags: -I${includedir}

--- snapp ---

Note, this only affects rpm.org, not rpm5.org when using the same pkgconfig
package.

Version-Release number of selected component (if applicable):
rpm-4.6.1-1
pkgconfig-0.23-6

How reproducible:
Everytime, see above and below.

Actual results:
Sorry for the non-english error message, but mock didn't somehow honor my
LANG=C :-(
rpmbuild: rpmfc.c:407: rpmfcHelper: Zusicherung »EVR != ((void *)0)« nicht erfüllt.
Child returncode was: -6

Expected results:
Working, no failure :)
Comment 1 Robert Scheck 2009-06-11 18:19:12 EDT
I would assume the cause is, that "Version:" tag is empty. And rpm5.org
solves this problem by doing then only a "Provides: pkgconfig(bitlbee)"
rather then failing... ;-)
Comment 2 Panu Matilainen 2009-06-12 06:09:35 EDT
Right, this has already been fixed for quite some time in rpm.org HEAD + 4.7.x branch, just not in 4.6.x.
Comment 3 Robert Scheck 2009-08-16 19:03:54 EDT
Panu, why is this bug report still not fixed at Fedora 10? It still prevents
me from pushing an update of bitlbee there.
Comment 4 Fedora Update System 2009-09-15 03:24:50 EDT
rpm-4.6.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpm-4.6.1-2.fc10
Comment 5 Fedora Update System 2009-09-15 17:02:32 EDT
rpm-4.6.1-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-9654
Comment 6 Fedora Update System 2009-10-08 23:44:51 EDT
rpm-4.6.1-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.