Bug 504994 - thunderbird-lightning is only in english
thunderbird-lightning is only in english
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thunderbird-lightning (Show other bugs)
15
All Linux
high Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 06:31 EDT by Eric Tanguy
Modified: 2011-08-17 22:27 EDT (History)
8 users (show)

See Also:
Fixed In Version: thunderbird-lightning-1.0-0.47.b5rc3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-14 12:44:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Tanguy 2009-06-10 06:31:54 EDT
Description of problem:

thunderbird-lightning is only in english. 

Version-Release number of selected component (if applicable): 0.1pre


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lubomir Rintel 2009-06-10 07:29:14 EDT
Thanks for the report
Known, see bug #494551 comment #5
Comment 2 Eric Tanguy 2009-06-10 09:17:58 EDT
It's an annoying problem for a released version please try to find a solution.
Comment 3 Lubomir Rintel 2009-06-10 09:49:51 EDT
I'll fix this once the stable version of code we use is actually released with langpacks.

Feel free to fix it yourself though :)
Comment 4 Eric Tanguy 2009-12-09 10:15:58 EST
I reassign this bug to fedora 12. I see in changelog that langpacks was updated at least twice so we can have translation now ?
Comment 5 Eric Tanguy 2010-01-12 13:53:25 EST
Lightning 1.0b1 is officially released with all languages available see : https://addons.mozilla.org/fr/thunderbird/addon/2313
Comment 6 Eric Tanguy 2010-06-13 12:51:32 EDT
The problem is still here in fedora 13.
Comment 7 tuxor 2010-07-15 14:17:46 EDT
Still here and really missing a workaround. The current version of the thunderbird-lightning package is 1.0b2pre and you don't get any xpi for that anywhere on the internet to extract language-packs from it.
I tried to replace the *-en-US.jar in chrome-directory, but especially replacing "calendar-en-US.jar" lets Lightning crash. (I used the current xpi's contents for replacement.)
Comment 8 Eric Tanguy 2010-07-23 03:31:11 EDT
thunderbird-lightning-1.0-0.26.b2pre.fc13.i686 is still only in english whereas the "official" b2 version contain all language pack. Why ??
Comment 9 tuxor 2011-03-26 05:34:09 EDT
Maybe you should also consider this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=684376

Gerard Ryan posted a link to a working multilang-xpi.
Comment 10 Eric Tanguy 2011-06-07 01:00:18 EDT
two years after the initial report the problem is still here!
Comment 11 Eric Tanguy 2011-07-09 02:43:38 EDT
Since july 2

Lightning 1.0 beta 4 is available for Windows, Mac OS X and Linux in 37 different languages including English

So it could be interesting to update lightning and make all language available
Comment 12 Remi Collet 2011-07-20 02:43:09 EDT
A working solution:
https://github.com/remicollet/remirepo/commit/74c253b43e4f3bbcbb54e91fb04d675822ac3fcc

Need to extract the langpack from the upstream XPI, as I don't find upstream source tarball (but langpack, are source)
Comment 13 Fedora Update System 2011-08-09 15:38:19 EDT
thunderbird-lightning-1.0-0.47.b5rc3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/thunderbird-lightning-1.0-0.47.b5rc3.fc15
Comment 14 Fedora Update System 2011-08-09 23:20:50 EDT
Package thunderbird-lightning-1.0-0.47.b5rc3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing thunderbird-lightning-1.0-0.47.b5rc3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/thunderbird-lightning-1.0-0.47.b5rc3.fc15
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2011-08-17 22:27:06 EDT
thunderbird-lightning-1.0-0.47.b5rc3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.