This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 505145 - include also AMD ucode
include also AMD ucode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: microcode_ctl (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kyle McMartin
Fedora Extras Quality Assurance
http://www.amd64.org/support/microcod...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 15:51 EDT by acount closed by user
Modified: 2010-01-18 11:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-18 11:27:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2009-06-10 15:51:15 EDT
get it from http://www.amd64.org/support/microcode.html

-thanks-
Comment 1 Kyle McMartin 2009-06-10 20:26:09 EDT
I don't believe we can redistribute it, because they don't grant the right to redistribute explicitly, and it's all rights reserved. I'll subscribe spot to this bug to review the legal text in case I am wrong.

I'll poke someone to poke someone at AMD to see if we can get this sorted out.

regards, Kyle


; Copyright 2008, ADVANCED MICRO DEVICES, INC.  All Rights Reserved.
;
; AMD is granting you permission to use this Microcode Patch software
; internally in object code form only (the "Materials"), subject to the
; following terms and conditions.  Your use of any portion of the Materials
; shall constitute your acceptance of the following terms and conditions.  If
; you do not agree to the following terms and conditions, please do not use or
; retain any portion of the Materials.
;
; LIMITATION OF LIABILITY: THE MATERIALS ARE PROVIDED "AS IS" WITHOUT ANY
; EXPRESS OR IMPLIED WARRANTY OF ANY KIND, INCLUDING BUT NOT LIMITED TO
; WARRANTIES OF MERCHANTABILITY, NONINFRINGEMENT, TITLE, FITNESS FOR ANY
; PARTICULAR PURPOSE, OR WARRANTIES ARISING FROM CONDUCT, COURSE OF DEALING,
; OR USAGE OF TRADE.  IN NO EVENT SHALL AMD OR ITS LICENSORS BE LIABLE FOR ANY
; DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF
; PROFITS, BUSINESS INTERRUPTION, OR LOSS OF DATA OR INFORMATION) ARISING OUT
; OF AMD'S NEGLIGENCE, GROSS NEGLIGENCE, THE USE OF OR INABILITY TO USE THE
; MATERIALS, EVEN IF AMD HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
; BECAUSE SOME JURISDICTIONS PROHIBIT THE EXCLUSION OR LIMITATION OF LIABILITY
; FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES OR THE EXCLUSION OF IMPLIED
; WARRANTIES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.
; AMD does not assume any responsibility for any errors which may appear in
; the Materials or result from use of the Materials.
;
; You agree that you will not reverse engineer or decompile the Materials.
;
; NO SUPPORT OBLIGATION: AMD is not obligated to furnish, support, or make any
; further information, software, technical information, know-how, or show-how
; available to you.  Additionally, AMD retains the right to modify the
; Materials at any time, without notice, and is not obligated to provide such
; modified Materials to you.
;
; U.S. GOVERNMENT RESTRICTED RIGHTS: The Materials are provided with
; "RESTRICTED RIGHTS." Use, duplication, or disclosure by the Government is
; subject to the restrictions as set forth in FAR 52.227-14 and
; DFAR252.227-7013, et seq., or its successor.  Use of the Materials by the
; Government constitutes acknowledgement of AMD's proprietary rights in them.
;
; EXPORT ASSURANCE:  You agree and certify that neither the Materials, nor any
; direct product thereof will be exported directly or indirectly, into any
; country prohibited by the United States Export Administration Act and the
; regulations there under, without the required authorization from the U.S.
; government nor will be used for any purpose prohibited by the same.
Comment 2 Tom "spot" Callaway 2009-07-02 14:17:01 EDT
You are correct. We do not have the right to redistribute this content. If possible, we should ask AMD/ATI to explicitly grant this permission.
Comment 3 acount closed by user 2009-08-23 11:12:56 EDT
Any news out there ? , otherwise I will close it

-thanks-
Comment 4 Tom "spot" Callaway 2009-08-23 13:39:36 EDT
Don't close this one. I opened a dialog with AMD, and they're "working on the issue". No idea when or if it will happen, but it isn't dead in the water.
Comment 5 Bhavna Sarathy 2009-08-28 12:25:02 EDT
You may download the AMD microcode from this site.  The necessary changes 
to the license has been made and pushed through legal.

http://www.amd64.org/support/microcode.html

Russ, please follow through to ensure this package is included in RHEL6 as well.

Thanks,
Bhavna
Comment 6 Tom "spot" Callaway 2009-08-28 13:42:20 EDT
Bhavna,

Thanks for the update. We'll need to run this past our Legal counsel first to make sure that this is appropriate.
Comment 7 Kyle McMartin 2009-09-14 21:56:37 EDT
Tom, any updates from legal about this?

cheers, Kyle
Comment 8 Tom "spot" Callaway 2009-09-15 10:20:33 EDT
I have not yet heard back from AMD. While their new license is improved over the previous one, some of the wording ("for internal evaluation only") is unacceptable for Fedora. I am hopeful that AMD will drop that restriction so that we can move forward.
Comment 9 Tom "spot" Callaway 2009-10-12 10:15:19 EDT
AMD dropped the restriction around "evaluation" usage, so the current license text is acceptable for Fedora.
Comment 10 Tom "spot" Callaway 2009-10-30 15:42:05 EDT
Lifting FE-Legal, the AMD microcode should be fine to go into this package.
Comment 11 Kyle McMartin 2009-11-03 23:45:40 EST
Thanks, I'll get on this this week.

cheers, Kyle
Comment 12 Bug Zapper 2009-11-16 05:03:11 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 acount closed by user 2009-12-02 13:31:54 EST
(In reply to comment #11)

> Thanks, I'll get on this this week.

any news out there ?
Comment 14 Kyle McMartin 2009-12-02 23:12:30 EST
Ok, didn't get to it that week, but some week... ;-)

http://koji.fedoraproject.org/koji/taskinfo?taskID=1845056

Feel free to try this scratch build, I don't have an AMD box to test this on, so I'll rely on someone external to tell me I didn't make a hash of things.

spot, I assumed that we were required to distribute the microcode license along with it, so I did so, but my head was spinning a bit due to all the legalese.

regards, Kyle
Comment 15 Kyle McMartin 2009-12-02 23:33:53 EST
http://koji.fedoraproject.org/koji/taskinfo?taskID=1845071

For some bizarre reason the last one had a broken initscript for an unrelated reason... Fixed build here tested by jforbes.
Comment 16 Kyle McMartin 2009-12-04 13:08:42 EST
Ok, confirmed as working by a bunch of folks, so uploaded it to F11, F12, and rawhide.
Comment 17 Fedora Update System 2009-12-04 13:10:55 EST
microcode_ctl-1.17-1.56.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/microcode_ctl-1.17-1.56.fc12
Comment 18 Fedora Update System 2009-12-04 13:11:45 EST
microcode_ctl-1.17-1.52.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/microcode_ctl-1.17-1.52.fc11
Comment 19 Fedora Update System 2009-12-07 02:26:58 EST
microcode_ctl-1.17-1.56.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update microcode_ctl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12779
Comment 20 Fedora Update System 2009-12-07 02:32:42 EST
microcode_ctl-1.17-1.52.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update microcode_ctl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-12837
Comment 21 acount closed by user 2009-12-07 11:10:09 EST
# /etc/init.d/microcode_ctl start
/etc/init.d/microcode_ctl: line 59: syntax error near unexpected token `}'
/etc/init.d/microcode_ctl: line 59: `}'

see bug #527701

Note You need to log in before you can comment on or make changes to this bug.