Bug 527701 - microcode_ctl init script syntax error
microcode_ctl init script syntax error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: microcode_ctl (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Anton Arapov
Fedora Extras Quality Assurance
: Reopened
: 546594 (view as bug list)
Depends On:
Blocks: 584910
  Show dependency treegraph
 
Reported: 2009-10-07 08:21 EDT by Edward Sheldrake
Modified: 2014-06-18 04:02 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 584910 (view as bug list)
Environment:
Last Closed: 2010-05-26 05:31:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
init script with both problems fixed (1.18 KB, text/plain)
2009-10-07 08:21 EDT, Edward Sheldrake
no flags Details
Fix init script output (1.35 KB, text/plain)
2009-12-16 16:21 EST, Edward Sheldrake
no flags Details
Alternate script that fixes an issue with AMD microcode updates not printing OK/FAILURE (1.41 KB, text/plain)
2010-04-22 15:15 EDT, Philip Pokorny
no flags Details

  None (edit)
Description Edward Sheldrake 2009-10-07 08:21:29 EDT
Created attachment 363962 [details]
init script with both problems fixed

Description of problem:
[root@ejs-desktop ~]# /etc/rc.d/init.d/microcode_ctl start
/etc/rc.d/init.d/microcode_ctl: line 52: syntax error near unexpected token `}'
/etc/rc.d/init.d/microcode_ctl: line 52: `}'

Also, on fixing the syntax error, it doesn't print the "[  OK  ]" or "[FAILED]" anymore.

Version-Release number of selected component (if applicable):
microcode_ctl-1.17-1.55.fc12

How reproducible:
Always.

Steps to Reproduce:
1. (as root) service microcode_ctl start
2.
3.
  
Actual results:
Syntax error.

Expected results:
Applying Intel CPU microcode update:                       [  OK  ]

Additional info:
It looks like bash doesn't allow empty functions. The empty stop function and references to it could be removed.
Comment 1 Bug Zapper 2009-11-16 08:21:32 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Edward Sheldrake 2009-11-23 15:45:35 EST
microcode_ctl-1.17-1.55.fc12 isn't in Fedora 12 or even rawhide, only koji.
Comment 3 acount closed by user 2009-12-07 11:08:15 EST
microcode_ctl-1.17-1.56.fc12 from updates-testing is still broken:

# /etc/init.d/microcode_ctl start
/etc/init.d/microcode_ctl: line 59: syntax error near unexpected token `}'
/etc/init.d/microcode_ctl: line 59: `}'
Comment 4 Frank Murphy 2009-12-15 06:21:39 EST
Seems to be now fixed with:
http://koji.fedoraproject.org/koji/buildinfo?buildID=144680
Comment 5 Edward Sheldrake 2009-12-16 16:21:29 EST
Created attachment 378853 [details]
Fix init script output

There's no syntax error in microcode_ctl-1.17-1.57.fc12, but the init script still doesn't output the [  OK  ] or [FAILED], the line that is printed is with "echo -n" so the message from whatever starts next will be printed on the same line.

Also the init script's "Usage:" line doesn't print out correctly due to a stray $ (the first one).
Comment 6 Edward Sheldrake 2009-12-16 16:38:41 EST
Re-opening.
Comment 7 Robert Scheck 2009-12-26 11:02:48 EST
Still busted. Note, the initscript misses a "\n" as well, it's just 2 lines
and not three as bugzilla will make it. The third line with the prompt is
directly appended to the second.

[root@tux ~]# /etc/init.d/microcode_ctl start 
Applying Intel CPU microcode update: Applying Intel CPU microcode update: [root@tux ~]#
Comment 8 Philip Pokorny 2010-04-22 13:12:20 EDT
Also an issue with Red Hat 6 beta.
Comment 9 Philip Pokorny 2010-04-22 15:15:47 EDT
Created attachment 408426 [details]
Alternate script that fixes an issue with AMD microcode updates not printing OK/FAILURE

Updated version of script that fixes logic issue where AMD updates wouldn't print OK/FAILURE

Also attached to cloned bug 584910
Comment 10 Justin Clift 2010-04-29 04:22:56 EDT
Hi Philip,

Nice that it supports both Intel and AMD.

Only one query... unsure about the hard coded exit returning 0 in the "start" section of the main case statement.

Is it possible for the start() function to return an error (ie something went wrong), and this needing to be indicated to the user as [FAILED]?

Thinking "exit $RETVAL" may achieve that?
Comment 11 Michal Nowak 2010-05-03 06:58:53 EDT
*** Bug 546594 has been marked as a duplicate of this bug. ***
Comment 12 Anton Arapov 2010-05-26 05:31:09 EDT
this was fixed a while ago.

Note You need to log in before you can comment on or make changes to this bug.