Bug 50516 - reiserfs umount hangs with Kernel 2.4.3-12
reiserfs umount hangs with Kernel 2.4.3-12
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
http://www.namesys.com/download.html
:
: 50576 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-31 15:50 EDT by Greg Folkert
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 11:07:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Folkert 2001-07-31 15:50:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
If you ever try to umount a reiserfs filesystem the command line will 
never return. Happens when shutting down machine too, it just hangs at: 
Unmounting Filesystems

Have to use the Reset/Power Button to get any further. Which of course 
causes FSCK to kick off everytime it starts up.



How reproducible:
Always

Steps to Reproduce:
1. Mount a reiserfs filesystem at first or second+ level (/var = 1st 
level, /var/spool/squid = second+). Have it mounted at bootup or not makes 
no difference just make sure it is mounted.
2. Umount a reiserfs filesystem or restart machine
3. Wait for a LOOOOOOOONG time as it fails completely


Actual Results:  1. Hit reset/power button, cause your boss is breathing 
down your neck, after waiting 1+ hours for it to return.
2. Cycle box, wait for fsck to fix everything (you hope)
3. Announce cache and webserver is back and running. After first 
announcing it should have been a 5 minute item.
	

Expected Results:  1. Issue command "shutdown -r now"
2. Wait a few moments for box to restart
3. Change Helpdesk announcement to "no current problems".

Additional info:

Known issue with the 2.4.3 kernel.

Goto http://www.namesys.com/download.html

and read the bit about "Warning: VFS...etc"
Comment 1 Arjan van de Ven 2001-07-31 15:52:51 EDT
Please try the 2.4.3-15 kernel at

http://people.redhat.com/arjanv/testkernels/

it should have the fix for this.
Comment 2 Greg Folkert 2001-07-31 20:20:20 EDT
I installed kernel-2.4.3-15...

No luck, still hangs.

Currently made a new kernel(bzImage) with reiserfs in it (not a module), from 
source (2.4.7 from kernel.org), using config "kernel-2.4.3-i686.config" from 
2.4.3-12 source. With the one change (a biggy I know) it now, works.

It was the only way I can get it to NOT hang on umount, so far. This does not 
mean 2.4.7 is going to stay there, it is not default 2.4.3-15 is.


Actual machine is:

http://web.grcc.cc.mi.us
Comment 3 Arjan van de Ven 2001-08-01 05:22:16 EDT
Are you _very_ sure you were running -15 with the hang? The "common"
hang on unmount was fixed in that, and several people reported success with it
so far.
Comment 4 Greg Folkert 2001-08-01 11:07:13 EDT
You are correct, in assuming -12 was running. I archive configs as I go, yep My 
label said -15 but was running -12 (darn vi with yank and put, and me 
forgetting to edit the image line along with the label). My bad.

When actually running the -15 Kernel, it does fix the problem. Although what 
intrigues me, is the 2.4.7 did the same as a module, but not as a compiled in 
component.

Guess this is closed then.
Comment 5 eric gerbier 2001-08-02 07:56:15 EDT
*** Bug 50576 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.