This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 505353 - No sound on HP dv6-1157ez after upgrade from Fedora 10 --> Fedora 11
No sound on HP dv6-1157ez after upgrade from Fedora 10 --> Fedora 11
Status: CLOSED DUPLICATE of bug 508674
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
All Linux
medium Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AlsaVolume
  Show dependency treegraph
 
Reported: 2009-06-11 11:51 EDT by Tobias Vogel
Modified: 2009-06-29 09:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 09:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
alsa-info.sh output (28.38 KB, text/plain)
2009-06-15 12:32 EDT, Tobias Vogel
no flags Details
amixer -c0 output (4.06 KB, text/plain)
2009-06-15 12:38 EDT, Tobias Vogel
no flags Details

  None (edit)
Description Tobias Vogel 2009-06-11 11:51:27 EDT
Description of problem:
No sound on HP dv6-1157ez Notebook after upgrade from Fedora 10 to Fedora 11.


Additional info:

lspci -vv

01:00.1 Audio device: ATI Technologies Inc R700 Audio Device [Radeon HD 4000 Series]
	Subsystem: Hewlett-Packard Company Device 3628
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin B routed to IRQ 17
	Region 0: Memory at da010000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel
Comment 1 Jason Merrill 2009-06-12 12:35:54 EDT
I also have no sound in F11 on my Thinkpad T61 with Intel 82801H audio controller, though it worked fine in the F11 Preview release.  See bug 500434 for more information.
Comment 2 Jason Merrill 2009-06-14 15:44:32 EDT
The solution for me was to enable Speaker output in the Switches tab of Advanced Sound Preferences.  In any case, you probably add this as a blocker for bug 497966 and provide the additional information that bug asks for.
Comment 3 Tobias Vogel 2009-06-15 12:32:20 EDT
Created attachment 347962 [details]
alsa-info.sh output
Comment 4 Tobias Vogel 2009-06-15 12:38:45 EDT
Created attachment 347964 [details]
amixer -c0 output

There is no solution to this issue, so there is no amixer_after.txt
Comment 5 Adam Williamson 2009-06-16 21:04:35 EDT
tobias, if running gst-mixer or alsamixer -c0 and adjusting the settings there cannot solve the problem, it's likely not a blocker of 497966, but something different. Can you confirm that just changing the default volume settings does _not_ fix this?

Jason, there are approximately eleventy billion different reasons why you might get a problem that manifests as "I don't hear any sound" - going around every bug report in Bugzilla that looks like this, and saying how you happened to fix it in your particular case, probably isn't the most productive way you can use your time :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Tobias Vogel 2009-06-22 14:27:31 EDT
Yes, I can confirm, that just changing the default volume settings does not fix this.

BUT: after adding the line

options snd_hda_intel model=hp-m4

to /etc/modprobe.d/alsa.conf

i ran exactly into the bad default volume settings issue.

so two steps are needed as a workaround for this:
1. adjust /etc/modprobe.d/alsa.conf
2. changing the default volume settings in gst-mixer
Comment 7 Adam Williamson 2009-06-23 15:03:58 EDT
tobias: then please report that as a separate bug - they're two different problems, with different solutions which may well be implemented by different people, so tracking both in one bug report doesn't make sense :) thanks!
Comment 8 Tobias Vogel 2009-06-29 09:13:00 EDT
ok, reported as two new bugs.

*** This bug has been marked as a duplicate of bug 508674 ***

Note You need to log in before you can comment on or make changes to this bug.