Bug 505357 - syndaemon fills system up with threads
syndaemon fills system up with threads
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 506357 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 12:04 EDT by Richard Körber
Modified: 2009-06-18 07:44 EDT (History)
6 users (show)

See Also:
Fixed In Version: 2.26.1-7.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 07:44:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (155.59 KB, text/plain)
2009-06-11 12:08 EDT, Richard Körber
no flags Details
updated g-s-d support touchpad patch (15.70 KB, patch)
2009-06-14 23:21 EDT, Peter Hutterer
no flags Details | Diff

  None (edit)
Description Richard Körber 2009-06-11 12:04:07 EDT
Description of problem:
This is a ThinkPad notebook with an external USB keyboard and USB mouse connected. In the mouse settings, "Disable touchpad while typing" is activated.

When I disconnect the mouse or the keyboard, and then reconnect it, there are 8 new syndaemon threads running. This is, after disconnecting both the keyboard and mouse, there are 16 syndaemon threads. When disconnecting and reconnecting again, there are 32 threads, and so on...

Eventually the system locks up because of the number of threads (this is, I cannot start new threads). When I log in from a remote system and invoke "killall syndaemon", everything is working again. But still, there are 8 new threads everytime I disconnect the mouse or the keyboard.

This is especially annoying when the keyboard and mouse is connected via a KVM switch, because there are 16 new threads everytime I switch back from the other system. Anyhow this bug is reproducible even without a KVM switch.

This bug does not occur if "Disable touchpad while typing" is deactivated.

Version-Release number of selected component (if applicable):
Fedora 11 x86_64, with all updates applied
xorg-x11-drv-synaptics-1.1.0-7.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Activate "Disable touchpad while typing".
2. Disconnect your USB keyboard or USB mouse, then reconnect it.
3. Count the number of "syndaemon" threads.
  
Actual results:
8 more syndaemon threads after every reconnect

Expected results:
no more than one syndaemon thread

Additional info:
There is no xorg.conf file. I will attach the Xorg.0.log in a few minutes, but it contains no hint about syndaemon.
Comment 1 Richard Körber 2009-06-11 12:08:12 EDT
Created attachment 347432 [details]
Xorg log file

The Xorg.0.log after disconnecting and reconnecting the USB mouse.
Comment 2 How 2009-06-14 01:10:12 EDT
same goes for here lots of syndaemon thread is running resuming after hibernate. Disabling in mouse preference doesnt work, had to manually kill the threads.


(In reply to comment #1)
> Created an attachment (id=347432) [details]
> Xorg log file
> 
> The Xorg.0.log after disconnecting and reconnecting the USB mouse.
Comment 3 Peter Hutterer 2009-06-14 23:18:34 EDT
verified, missing check in gnome-settings-daemon's mouse plugin before activating syndaemon.
Comment 4 Peter Hutterer 2009-06-14 23:21:14 EDT
Created attachment 347884 [details]
updated g-s-d support touchpad patch

Patch adds three lines to set_disable_w_typing to check whether syndaemon has been started already.


static int
set_disable_w_typing (GsdMouseManager *manager, gboolean state)
{
	GError	*error = NULL;

	if (state) {
		char	*args[4];

+		if (manager->priv->syndaemon_spawned)
+			return 0;
+
		args[0] = "syndaemon";
		args[1] = "-i";
		args[2] = "0.5";
		args[3] = NULL;



koji test build: http://koji.fedoraproject.org/koji/taskinfo?taskID=1414144
Comment 5 Richard Körber 2009-06-15 13:23:15 EDT
Koji build fixes this bug for me. Thank you!
Comment 6 How 2009-06-15 22:08:36 EDT
yes me too ! Thank you
Comment 7 Peter Hutterer 2009-06-16 18:11:11 EDT
*** Bug 506357 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2009-06-18 07:44:53 EDT
gnome-settings-daemon-2.26.1-7.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.