This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 505376 - numpy not using atlas?
numpy not using atlas?
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: numpy (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 13:12 EDT by Neal Becker
Modified: 2009-06-15 22:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.2.0-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 21:20:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2009-06-11 13:12:19 EDT
Description of problem:
 python
Python 2.6 (r26:66714, Mar 17 2009, 11:44:14) 
[GCC 4.4.0 20090313 (Red Hat 4.4.0-0.26)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import numpy
>>> numpy.show_config()
blas_info:
    libraries = ['blas']
    library_dirs = ['/usr/lib64']
    language = f77

lapack_info:
    libraries = ['lapack']
    library_dirs = ['/usr/lib64']
    language = f77

atlas_threads_info:
  NOT AVAILABLE

blas_opt_info:
    libraries = ['blas']
    library_dirs = ['/usr/lib64']
    language = f77
    define_macros = [('NO_ATLAS_INFO', 1)]

atlas_blas_threads_info:
  NOT AVAILABLE

lapack_opt_info:
    libraries = ['lapack', 'blas']
    library_dirs = ['/usr/lib64']
    language = f77
    define_macros = [('NO_ATLAS_INFO', 1)]

atlas_info:
  NOT AVAILABLE

lapack_mkl_info:
  NOT AVAILABLE

blas_mkl_info:
  NOT AVAILABLE

atlas_blas_info:
  NOT AVAILABLE

mkl_info:
  NOT AVAILABLE

 rpm -q numpy
numpy-1.3.0-4.fc11.x86_64

Now, I download numpy-1.3.0-4.fc11.src.rpm and rebuild it myself.

Reinstall numpy, then:
python
Python 2.6 (r26:66714, Mar 17 2009, 11:44:14) 
[GCC 4.4.0 20090313 (Red Hat 4.4.0-0.26)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import numpy
>>> numpy.show_config()
atlas_threads_info:
    libraries = ['lapack', 'ptf77blas', 'ptcblas', 'atlas']
    library_dirs = ['/usr/lib64/atlas']
    language = f77
    include_dirs = ['/usr/include']

blas_opt_info:
    libraries = ['ptf77blas', 'ptcblas', 'atlas']
    library_dirs = ['/usr/lib64/atlas']
    define_macros = [('ATLAS_INFO', '"\\"3.8.3\\""')]
    language = c
    include_dirs = ['/usr/include']

atlas_blas_threads_info:
    libraries = ['ptf77blas', 'ptcblas', 'atlas']
    library_dirs = ['/usr/lib64/atlas']
    language = c
    include_dirs = ['/usr/include']

lapack_opt_info:
    libraries = ['lapack', 'ptf77blas', 'ptcblas', 'atlas']
    library_dirs = ['/usr/lib64/atlas']
    define_macros = [('ATLAS_INFO', '"\\"3.8.3\\""')]
    language = f77
    include_dirs = ['/usr/include']

lapack_mkl_info:
  NOT AVAILABLE

blas_mkl_info:
  NOT AVAILABLE

mkl_info:
  NOT AVAILABLE

>>> 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jef Spaleta 2009-06-11 13:54:55 EDT
Just as a note. When you say you rebuilt locally do you mean rebuilt on the local system with altas installed already? 

Or did you rebuild it inside a clean fedora build environment via mock or other tool?

I'm assuming that the local rebuild you did automatically detected atlas was available on the installed system.

if this is true all we need to do then is adjust the numpy specfile to buildrequire atlas so that its available in the buildroot.

Scipy already does this correctly. I'll look at doing this in rawhide over the next couple of days.  

Jon any objections to making numpy require altas?

The OLPC people may have objections about pulling in atlas as a new dep for numpy.
But I don't know a reasonable way to provide atlas/non-atlas compiled versions of numpy in parallel.

-jef
Comment 2 Gwyn Ciesla 2009-06-11 14:11:31 EDT
No, no objections whatsoever.  If fact:

<snip>

BuildRequires:  python-devel lapack-devel python-setuptools gcc-gfortran atlas python-nose
Requires:       python-nose

<snip>

* Tue Oct 07 2008 Jon Ciesla <limb@jcomserv.net> 1.2.0-1
- New upstream release, added python-nose BR. BZ 465999.
- Using atlas blas, not blas-devel. BZ 461472.


So I'm not sure why this is happening.
Comment 3 Gwyn Ciesla 2009-06-11 14:12:41 EDT
I see it too. . .

>>> import numpy
>>> numpy.show_config()
blas_info:
    libraries = ['blas']
    library_dirs = ['/usr/lib']
    language = f77

lapack_info:
    libraries = ['lapack']
    library_dirs = ['/usr/lib']
    language = f77

atlas_threads_info:
  NOT AVAILABLE

blas_opt_info:
    libraries = ['blas']
    library_dirs = ['/usr/lib']
    language = f77
    define_macros = [('NO_ATLAS_INFO', 1)]

atlas_blas_threads_info:
  NOT AVAILABLE

lapack_opt_info:
    libraries = ['lapack', 'blas']
    library_dirs = ['/usr/lib']
    language = f77
    define_macros = [('NO_ATLAS_INFO', 1)]

atlas_info:
  NOT AVAILABLE

lapack_mkl_info:
  NOT AVAILABLE

blas_mkl_info:
  NOT AVAILABLE

atlas_blas_info:
  NOT AVAILABLE

mkl_info:
  NOT AVAILABLE
Comment 4 Jef Spaleta 2009-06-11 14:35:19 EDT
Jon:
You need
BuildRequires  atlas-devel

not BuildRequires atlas
Comment 5 Gwyn Ciesla 2009-06-11 14:41:15 EDT
<facepalm>

Only on ppc.  I'd need atlas-sse*-devel on x86.

Soluble with conditionals in the spec?
Comment 6 Gwyn Ciesla 2009-06-11 14:43:49 EDT
Or, rather, since atlas 3.8.2. . .
Comment 7 Gwyn Ciesla 2009-06-11 15:17:27 EDT
Yeah, atlas-devel fixes it on F-10.  Looks like the provides are there in F-11 and F-12.  I'll get fixes in post haste.
Comment 8 Fedora Update System 2009-06-11 16:00:55 EDT
numpy-1.2.0-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/numpy-1.2.0-3.fc10
Comment 9 Fedora Update System 2009-06-11 16:00:59 EDT
numpy-1.3.0-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/numpy-1.3.0-5.fc11
Comment 10 Fedora Update System 2009-06-11 16:01:04 EDT
numpy-1.2.0-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/numpy-1.2.0-3.fc9
Comment 11 Fedora Update System 2009-06-15 21:20:39 EDT
numpy-1.2.0-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-06-15 22:06:45 EDT
numpy-1.3.0-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2009-06-15 22:10:57 EDT
numpy-1.2.0-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.