This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 505402 - 1922868 - Sabayon does not save mandatory GConf settings
1922868 - Sabayon does not save mandatory GConf settings
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sabayon (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Tomáš Bžatek
Desktop QE
: Patch, Reopened
Depends On:
Blocks: 502912 590060 786154
  Show dependency treegraph
 
Reported: 2009-06-11 14:59 EDT by Issue Tracker
Modified: 2015-03-03 17:40 EST (History)
10 users (show)

See Also:
Fixed In Version: sabayon-2.12.4-9.el5
Doc Type: Bug Fix
Doc Text:
Cause: Several GConf directories were listed in the list of folders to ignore Consequence: Changes made in the Mandatory GConf settings were not saved Fix: Entries were removed from the list Result: All changes are saved properly now.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:51:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cendio-sabayon-lockdown-save.patch (899 bytes, patch)
2009-09-29 08:09 EDT, Peter Åstrand
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 23167 None None None Never

  None (edit)
Description Issue Tracker 2009-06-11 14:59:09 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2009-06-11 14:59:11 EDT
Event posted on 09-06-2009 04:50pm IST by spoyarek

Description of problem:

Base OS: RHEL-5.3

Sabayon does not save mandatory gconf settings to a profile.

How reproducible:

Always.

Steps to Reproduce:

1) Start sabayon
2) "Add" a new profile with the name "sample"
3) Click on "Edit"
4) In the profiles window, Right Click on the top panel and click on Properties
5) In the Panel Properties, enable and disable the "Autohide" check box
6) In the sabayon "Changes" window, click on the lock against the latest entry (Panel Autohide key to false) to lock it
7) Save the profile and close the X nested window
8) Click on Details
9) Double click on Mandatory GConf settings

Actual results:

Mandatory GConf settings window is empty

Expected results:

The Autohide property should be mentioned in the Mandatory GConf settings window

Additional info:

I've attached a patch which merely removes the .gconf.xml.mandatory directory from the ignored directories list when saving the profile. This fixes the issue but I am not sure why it was put there in the first place. I have not given a test package to the customer. Will do so if the change is acceptable.
This event sent from IssueTracker by rkhadgar  [Support Engineering Group]
 issue 305322
Comment 2 Issue Tracker 2009-06-11 14:59:13 EDT
Event posted on 09-06-2009 05:17pm IST by spoyarek

Seeing the following upstream bugzilla:

http://bugzilla.gnome.org/show_bug.cgi?id=551535

it looks like my fix is probably the correct approach since the
sabayon-lockdown-save.patch fixes regular configurations
(.gconf.xml.defaults) in a similar manner.


This event sent from IssueTracker by rkhadgar  [Support Engineering Group]
 issue 305322
Comment 3 Peter Åstrand 2009-09-29 08:09:04 EDT
Created attachment 363001 [details]
cendio-sabayon-lockdown-save.patch

As far as I can tell, no attachment was made, but here's a patch that I have done that seems to work.
Comment 5 RHEL Product and Program Management 2009-11-06 13:57:48 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 7 RHEL Product and Program Management 2010-08-09 15:04:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2011-05-31 10:20:23 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 14 Tomáš Bžatek 2011-10-04 10:48:34 EDT
(In reply to comment #2)
> Seeing the following upstream bugzilla:
> 
> http://bugzilla.gnome.org/show_bug.cgi?id=551535

Funny to see my patch that I made for bug 442132 going back as a new issue on already fixed package.

*** This bug has been marked as a duplicate of bug 442132 ***
Comment 22 Tomáš Bžatek 2012-01-20 12:59:22 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Several GConf directories were listed in the list of folders to ignore

Consequence: Changes made in the Mandatory GConf settings were not saved

Fix: Entries were removed from the list

Result: All changes are saved properly now.
Comment 26 errata-xmlrpc 2012-02-21 00:51:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0202.html

Note You need to log in before you can comment on or make changes to this bug.