Bug 505421 - snd-seq is not loaded on startup
snd-seq is not loaded on startup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
11
All Linux
medium Severity high
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, EasyFix, Regression
: 501048 527075 (view as bug list)
Depends On:
Blocks: 516998 527107
  Show dependency treegraph
 
Reported: 2009-06-11 16:38 EDT by Fernando Lopez-Lezcano
Modified: 2010-03-10 00:28 EST (History)
18 users (show)

See Also:
Fixed In Version: 3.7-10.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-15 20:11:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fernando Lopez-Lezcano 2009-06-11 16:38:56 EDT
Description of problem:

ALSA sequencer module is not loaded automatically on startup. 

Version-Release number of selected component (if applicable):

How reproducible:

Always.

Steps to Reproduce:

1. boot the computer in f11
2. try to use the ALSA sequencer, for example install and start qjackctl
(control application for Jack)
3. qjackctl complains on startup:

"Could not open ALSA sequencer as a client"
"ALSA MIDI patchbay will not be available"

and of course no midi ports are shown in the connections dialog.
  
Actual results:

qjackctl can't access the ALSA sequencer interface. 

Expected results:

qjackctl accesses the ALSA sequencer interface.  

Additional info:

This is solved by manually loading snd-seq as in:
1. su root
2. /sbin/modprobe snd-seq

This should happen automatically. Users should not be required to load kernel modules by hand to access functionality of installed hardware. This was working in Fedora < 11. This is independent on whether the computer has a working MIDI interface or not. Applications can communicate between them using the ALSA sequencer interface regardless of the existence of a hardware MIDI port.
Comment 1 Orcan Ogetbil 2009-06-11 20:24:24 EDT
*** Bug 501048 has been marked as a duplicate of this bug. ***
Comment 2 Brian G. Anderson 2009-06-11 20:59:23 EDT
tuxguitar also needs "modprobe snd-seq-oss" to work properly
Comment 3 Chuck Ebbert 2009-06-12 13:32:03 EDT
We removed snd-seq along with snd-seq-oss when commenting out the line in /etc/modprobe.d/dist-oss.conf. Ad according to comment #2 we need snd-seq-oss for at least one application too.
Comment 4 Fernando Lopez-Lezcano 2009-06-12 14:03:19 EDT
(In reply to comment #3)
> We removed snd-seq along with snd-seq-oss when commenting out the line in
> /etc/modprobe.d/dist-oss.conf. Ad according to comment #2 we need snd-seq-oss
> for at least one application too.  

Can snd-seq be added back ASAP? Or is the fix already in the pipeline? It breaks a lot of the sound software (qjackctl is just one example). In particular anything that uses the ALSA MIDI sequencer. Some software is nice and warns the user, others just fails to start.
Comment 5 Fernando Lopez-Lezcano 2009-06-12 14:05:00 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > We removed snd-seq along with snd-seq-oss when commenting out the line in
> > /etc/modprobe.d/dist-oss.conf. Ad according to comment #2 we need snd-seq-oss
> > for at least one application too.  
> 
> Can snd-seq be added back ASAP? Or is the fix already in the pipeline? It
> breaks a lot of the sound software (qjackctl is just one example). In
> particular anything that uses the ALSA MIDI sequencer. Some software is nice
> and warns the user, others just fails to start.  

Is there an interim fix I could push somehow in the Planet CCRMA repository? (ie: a package that would be overriden when the official package with the fix becomes available from Fedora). Right now Fedora 11 is quite broken because of this problem.
Comment 6 Hans de Goede 2009-06-13 04:46:53 EDT
(In reply to comment #3)
> We removed snd-seq along with snd-seq-oss when commenting out the line in
> /etc/modprobe.d/dist-oss.conf. Ad according to comment #2 we need snd-seq-oss
> for at least one application too.  

No thats a typo in comment 2, tuxguitar just needs snd-seq, afaik.
Comment 7 Orcan Ogetbil 2009-06-13 12:46:48 EDT
(In reply to comment #6)
> (In reply to comment #3)
> > We removed snd-seq along with snd-seq-oss when commenting out the line in
> > /etc/modprobe.d/dist-oss.conf. Ad according to comment #2 we need snd-seq-oss
> > for at least one application too.  
> 
> No thats a typo in comment 2, tuxguitar just needs snd-seq, afaik.  

From the error output of Bug 501048 I can say that tuxguitar needs the presence of /dev/sequencer which is generated by snd-seq-oss. It might be that the MIDI part of the Java sound API needs /dev/sequencer, not just tuxguitar.

The weird thing is, on my fresh F-11 system, snd-seq-oss is not blacklisted and is loaded by default.
Comment 8 Fernando Lopez-Lezcano 2009-07-08 12:24:00 EDT
(In reply to comment #0)
> 1. boot the computer in f11
> 2. try to use the ALSA sequencer, for example install and start qjackctl
> (control application for Jack)
> 3. qjackctl complains on startup:
> 
> "Could not open ALSA sequencer as a client"
> "ALSA MIDI patchbay will not be available"
> 
> and of course no midi ports are shown in the connections dialog.

Still broken, users can't use MIDI out of the box in Fedora 11!
What would be a recommended workaround??
Comment 9 Adam Williamson 2009-07-21 13:22:58 EDT
I think the snd-seq-oss thing is confusing the issue. That's truly part of OSS, so if we're serious about disabling OSS by default, that one should stay blacklisted. But the failure to load snd-seq appears to be simply an error and should be fixed ASAP.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Fernando Lopez-Lezcano 2009-08-11 16:23:45 EDT
(In reply to comment #9)
> I think the snd-seq-oss thing is confusing the issue. That's truly part of OSS,
> so if we're serious about disabling OSS by default, that one should stay
> blacklisted. But the failure to load snd-seq appears to be simply an error and
> should be fixed ASAP.

Does anyone in the cc' list know what incantation I should use for fixing this issue?? Are devices still loaded through udev rules? 

What would be required is, if something tries to access /dev/snd/seq then snd-seq should be modprobed automatically (this was happening for fedora < 11). 

What is the currently proper way of doing this?
Comment 11 Adam Williamson 2009-08-11 16:52:29 EDT
Harald Hoyer is in CC, he ought to know.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Hans de Goede 2009-08-12 04:46:50 EDT
Ok, I've been discussing this with Harald Hoyer on irc. Here is a summary:

The issue is that in F-10 and before we had a modprobe rule which caused the oss compat modules to be loaded as soon as snd-pcm got loaded, this also caused the snd-seq module to get loaded. Now we (rightfully) no longer cause the oss stuff to auto load, snd-seq also does not get loaded.

However since we now live in a udev world this means /dev/snd/seq never gets created, and since it does not exist the module also will not get autoloaded by the old kernel autoload mechanism.

Normally there would be 2 options to solve this:
1) force snd-seq to be always loaded (or atleast as soon as snd-pcm is loaded)
2) "manually" create the /dev/snd/seq node

2) Would be the preferred solution here, modifying /sbin/start_udev to
create a /dev/snd/seq node, so that the module will be autoloaded by
the kernel autoload mechanism as soon as an application needs it,
this is how this is done for other virtual devices such as loopback and
/dev/net/tun. However 2) cannot be used since alsa uses dynamic minor numbers

So we will have to use option 1), and always load snd_seq, atleast on systems
where a soundcard is present.

So the solution to this bug is to create an /etc/modprobe.d/dist-alsa.conf file with the following contents:
# Make midi applications work on systems with a soundcard:
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe snd-seq
Comment 13 Hans de Goede 2009-08-12 04:47:30 EDT
Note the snd-seq should be at the same line as the "install snd-pcm /sbin/modprobe ..."
Comment 14 Fernando Lopez-Lezcano 2009-08-13 19:57:53 EDT
(In reply to comment #13)
> Note the snd-seq should be at the same line as the "install snd-pcm
> /sbin/modprobe ..."  

Thanks very much!! At least now I have a workaround. Hopefully it will make to fc11+...

Now, I _think_ this (snd-seq not autoloading) happened before in the fedora cycle (2?, 3?, can't remember). I'll see if I can find an email or something about it.
Comment 15 Fernando Lopez-Lezcano 2009-10-02 14:45:19 EDT
(In reply to comment #14)
> (In reply to comment #13)
> > Note the snd-seq should be at the same line as the "install snd-pcm
> > /sbin/modprobe ..."  
> 
> Thanks very much!! At least now I have a workaround. Hopefully it will make to
> fc11+...

Reported in June, it is now October. 

I still can't honestly recommend Fedora 11 to new users of Planet CCRMA (and any other serious audio users that are still using Fedora, fewer and fewer as time goes by, of course) as they _will_ get an error _when_ they try to start Jack through Qjackctl. The error and the usability of MIDI can't be fixed if you are not root, and fixing it requires loading a kernel module by hand. Not acceptable. 

The issue is solved (see previous posts). When is a _fix_ going to be released? Is this even fixed in Fedora 12??????
Comment 16 Steevithak 2009-10-02 15:02:22 EDT
I'm experiencing this bug as well. It prevents the proper operation of the M-Audio USB MIDIMAN multiport MIDI interfaces, which used to work fine with previous version of Fedora. We've dropped back to Fedora 10 until a fix is available for this bug.
Comment 17 Hans de Goede 2009-10-02 15:06:21 EDT
(In reply to comment #15)
> (In reply to comment #14)
> > (In reply to comment #13)
> > > Note the snd-seq should be at the same line as the "install snd-pcm
> > > /sbin/modprobe ..."  
> > 
> > Thanks very much!! At least now I have a workaround. Hopefully it will make to
> > fc11+...
> 
> Reported in June, it is now October. 
> 
> I still can't honestly recommend Fedora 11 to new users of Planet CCRMA (and
> any other serious audio users that are still using Fedora, fewer and fewer as
> time goes by, of course) as they _will_ get an error _when_ they try to start
> Jack through Qjackctl. The error and the usability of MIDI can't be fixed if
> you are not root, and fixing it requires loading a kernel module by hand. Not
> acceptable. 
> 
> The issue is solved (see previous posts). When is a _fix_ going to be released?
> Is this even fixed in Fedora 12??????  

Erm, I don't think it is. I'll poke Jon about this on monday and make sure we get this fixed asap.
Comment 18 Adam Williamson 2009-10-02 15:23:42 EDT
R. Steven Rainwater: the workaround is fairly easy, you just have to load the snd-seq at each boot. You can just stick 'modprobe snd-seq' at the bottom of /etc/rc.local to save having to do it manually each boot.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Fernando Lopez-Lezcano 2009-10-03 16:50:44 EDT
(In reply to comment #18)
> (In reply to comment #15)
> > (In reply to comment #14)
> > > (In reply to comment #13)
> > > > Note the snd-seq should be at the same line as the "install snd-pcm
> > > > /sbin/modprobe ..."  
> > > 
> > > Thanks very much!! At least now I have a workaround. Hopefully it will make to
> > > fc11+...
> > 
> > Reported in June, it is now October. 
> > 
> > I still can't honestly recommend Fedora 11 to new users of Planet CCRMA (and
> > any other serious audio users that are still using Fedora, fewer and fewer as
> > time goes by, of course) as they _will_ get an error _when_ they try to start
> > Jack through Qjackctl. The error and the usability of MIDI can't be fixed if
> > you are not root, and fixing it requires loading a kernel module by hand. Not
> > acceptable. 
> > 
> > The issue is solved (see previous posts). When is a _fix_ going to be released?
> > Is this even fixed in Fedora 12??????  
> 
> Erm, I don't think it is. I'll poke Jon about this on monday and make sure we
> get this fixed asap.  

Could you please remember? I can file another bug against 12 or rawhide or 13 if needed.

I could very well have released some hack in the Planet CCRMA repository to fix this, but I talked myself out of it. This is very VERY basic, and should have had a suitable response from the maintainers of the package that broke this (plus anything I could release would probably conflict with whatever is the final fix). 

Workarounds should not be even mentioned as options at this point given that the release cycle of Fedora is only 6 months and this regression breaks basic functionality and was properly reported. 

As to the workaround being "fairly easy", it depends on your background. Most new users that try Fedora, want to do serious audio work, and have the bad luck of arriving in the Fedora 11 timeframe, will just walk away (ie: not much to look forward to when the very first program that you have to use to do serious audio work starts up with an error panel).
Comment 20 Adam Williamson 2009-10-04 03:04:05 EDT
I'm only mentioning the workaround as some people could clearly benefit from it. I'm not suggesting it removes the need to fix the bug, it doesn't.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Fernando Lopez-Lezcano 2009-10-12 16:08:40 EDT
(In reply to comment #19)
> (In reply to comment #18)
> > (In reply to comment #15)
> > > (In reply to comment #14)
> > > > (In reply to comment #13)
> > > > > Note the snd-seq should be at the same line as the "install snd-pcm
> > > > > /sbin/modprobe ..."  
> > > > 
> > > > Thanks very much!! At least now I have a workaround. Hopefully it will make to
> > > > fc11+...
> > > 
> > > Reported in June, it is now October. 
> > > 
> > > I still can't honestly recommend Fedora 11 to new users of Planet CCRMA (and
> > > any other serious audio users that are still using Fedora, fewer and fewer as
> > > time goes by, of course) as they _will_ get an error _when_ they try to start
> > > Jack through Qjackctl. The error and the usability of MIDI can't be fixed if
> > > you are not root, and fixing it requires loading a kernel module by hand. Not
> > > acceptable. 
> > > 
> > > The issue is solved (see previous posts). When is a _fix_ going to be released?
> > > Is this even fixed in Fedora 12??????  
> > 
> > Erm, I don't think it is. I'll poke Jon about this on monday and make sure we
> > get this fixed asap.  
> 
> Could you please remember? I can file another bug against 12 or rawhide or 13
> if needed.

2009.10.12: fully updated fc11 system, still does not load snd-seq by default.
Comment 22 Fernando Lopez-Lezcano 2009-10-12 16:19:52 EDT
(In reply to comment #21)
> (In reply to comment #19)
> > (In reply to comment #18)
> > > (In reply to comment #15)
> > > > (In reply to comment #14)
> > > > > (In reply to comment #13)
> > > > > > Note the snd-seq should be at the same line as the "install snd-pcm
> > > > > > /sbin/modprobe ..."  
> > > > > 
> > > > > Thanks very much!! At least now I have a workaround. Hopefully it will make to
> > > > > fc11+...
> > > > 
> > > > Reported in June, it is now October. 
> > > > 
> > > > I still can't honestly recommend Fedora 11 to new users of Planet CCRMA (and
> > > > any other serious audio users that are still using Fedora, fewer and fewer as
> > > > time goes by, of course) as they _will_ get an error _when_ they try to start
> > > > Jack through Qjackctl. The error and the usability of MIDI can't be fixed if
> > > > you are not root, and fixing it requires loading a kernel module by hand. Not
> > > > acceptable. 
> > > > 
> > > > The issue is solved (see previous posts). When is a _fix_ going to be released?
> > > > Is this even fixed in Fedora 12??????  
> > > 
> > > Erm, I don't think it is. I'll poke Jon about this on monday and make sure we
> > > get this fixed asap.  
> > 
> > Could you please remember? I can file another bug against 12 or rawhide or 13
> > if needed.
> 
> 2009.10.12: fully updated fc11 system, still does not load snd-seq by default.  

Just looked at Koji, the builds for fc12 _and_ fc13 do not (AFAICT) include any fixes for this issue (it is not in the changelog, I did not actually look at the files). I guess we wait till fc14? What _is_ the problem?
Comment 23 Orcan Ogetbil 2009-10-14 18:31:55 EDT
What is the problem with fixing this? 

Could a module-init-tool maintainer commit the changes Hans described in comment #12 ? 

This is very important!
Comment 24 Jon Masters 2009-10-15 05:36:02 EDT
Thanks for the ping. I am not ignoring you but have been busy with some other things for the past few days - this is planned for the next build and should be there before Monday.
Comment 25 Jean-Baptiste Hétier 2009-10-15 06:15:47 EDT
Great news! Thank you.
Comment 26 Fedora Update System 2009-10-21 00:35:50 EDT
module-init-tools-3.9-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/module-init-tools-3.9-4.fc12
Comment 27 Jon Masters 2009-10-21 00:36:53 EDT
I have pushed an update to testing. Please test and vote on the update.
Comment 28 Adam Williamson 2009-10-21 01:02:23 EDT
jon, could you file a tag request to have this go in f12 final? i think it's appropriate to be tagged in.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 29 Jon Masters 2009-10-21 02:35:08 EDT
I have filed that request.
Comment 30 Tony White 2009-10-21 17:15:56 EDT
Same problem with /dev/dsp. I made a report. It was not considered a bug.

Wondering if a less amateurish solution to /dev/snd/seq not being created is possible by reporting it upstream to alsa and udev?
Comment 31 Adam Williamson 2009-10-21 18:40:21 EDT
It's not amateurish, it's the correct way to do it. /dev/dsp not being present is indeed not a bug. We have intentionally disabled OSS emulation in ALSA.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 32 Adam Williamson 2009-10-21 18:41:52 EDT
jon: what's the URL of the tag request? searching for 'module-init-tools' in releng trac isn't finding me anything.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 33 Fernando Lopez-Lezcano 2009-10-22 01:53:15 EDT
(In reply to comment #27)
> I have pushed an update to testing. Please test and vote on the update.  

Thank you!! Is this only for fc12? (can't test on fc12 yet). Would it be possible to do it for fc11 as well? (which is where the bug was originally reported).
Comment 34 Orcan Ogetbil 2009-10-22 02:00:25 EDT
(In reply to comment #26)
> module-init-tools-3.9-4.fc12 has been submitted as an update for Fedora 12.
> http://admin.fedoraproject.org/updates/module-init-tools-3.9-4.fc12  

Thank you System but the link is broken.
Comment 35 Adam Williamson 2009-10-22 13:36:03 EDT
the update has been brought in to the main rawhide tree (rather than f12 updates-testing), so just updating any f12 beta install should get the updated version and you can test with that.

jon, I second Fernando on the request for an f11 update :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 36 Fernando Lopez-Lezcano 2009-10-26 19:32:56 EDT
(In reply to comment #35)
> the update has been brought in to the main rawhide tree (rather than f12
> updates-testing), so just updating any f12 beta install should get the updated
> version and you can test with that.
> 
> jon, I second Fernando on the request for an f11 update :)

Please, an update for fc11 would be nice... I see that in the fc12 package it says "Resolves #505421" which is a bit optimistic as the bug was created for fc11 (but it is good, of course, to have it solved on fc12 onwards! :-).
Comment 37 Fernando Lopez-Lezcano 2009-10-26 19:53:02 EDT
(In reply to comment #36)
> (In reply to comment #35)
> > the update has been brought in to the main rawhide tree (rather than f12
> > updates-testing), so just updating any f12 beta install should get the updated
> > version and you can test with that.
> > 
> > jon, I second Fernando on the request for an f11 update :)
> 
> Please, an update for fc11 would be nice... I see that in the fc12 package it
> says "Resolves #505421" which is a bit optimistic as the bug was created for
> fc11 (but it is good, of course, to have it solved on fc12 onwards! :-).  

I can confirm that the Fedora 12 fix works when ported over to Fedora 11's latest released module-init-tools package. I gave up and released a fixed package in the Planet CCRMA repositories with a 9.1* release tag, it will be overriden when/if a -10 release package hits the real Fedora repositories. At least Planet CCRMA users will be able to start qjackctl out of the box without an error if they upgrade. 2009-06-11 is way too long ago.
Comment 38 Fernando Lopez-Lezcano 2009-11-07 14:16:10 EST
(In reply to comment #37)
> (In reply to comment #36)
> > (In reply to comment #35)
> > > the update has been brought in to the main rawhide tree (rather than f12
> > > updates-testing), so just updating any f12 beta install should get the updated
> > > version and you can test with that.
> > > 
> > > jon, I second Fernando on the request for an f11 update :)
> > 
> > Please, an update for fc11 would be nice... I see that in the fc12 package it
> > says "Resolves #505421" which is a bit optimistic as the bug was created for
> > fc11 (but it is good, of course, to have it solved on fc12 onwards! :-).  
> 
> I can confirm that the Fedora 12 fix works when ported over to Fedora 11's
> latest released module-init-tools package. 

FEDORA 11 FIX PLEASE???

Why is this being ignored again and again? Is there a reason? I imagine that having released a fix for Fedora 12 (thanks!) means that issuing the same for Fedora 11 is trivial.
Comment 39 Adam Williamson 2009-11-07 14:26:26 EST
Please do not abuse the priority field. As per the policy, only maintainers should set it.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 40 Orcan Ogetbil 2009-11-07 15:18:07 EST
Fernando, I believe a possible solution would be to ask for comaintainership in pkgdb:
   https://admin.fedoraproject.org/pkgdb/packages/name/module-init-tools

I believe in "if nobody is fixing it, fix it yourself"
Comment 41 Fernando Lopez-Lezcano 2009-11-08 16:56:39 EST
(In reply to comment #39)
> Please do not abuse the priority field. As per the policy, only maintainers
> should set it.

Sorry, did not know that, won't happen again. Is there any other way other than comments in the bug report to express urgency about a fix?
Comment 42 Adam Williamson 2009-11-08 18:11:59 EST
see comment #40 :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 43 Fernando Lopez-Lezcano 2009-11-09 21:28:43 EST
(In reply to comment #42)
> see comment #40 :)

:-) :-P

Sigh... 

I know, I know. I have not been involved in the Fedora packaging loop in a long long time and I think I don't have the resources to do that - last time I tried it was a huge time sink I could not really afford (I'm not criticizing the process, it just did not work for me). The more I can delegate to Fedora maintainers - specially for non-audio specific packages like this one - the better. I naively thought that something like this would be easy to resolve but apparently it is not going to happen. Time to give up, I guess. And perhaps to start looking for greener pastures. 

I understand the "you want it you do it" philosophy, that is what I do every day here at CCRMA. But my time has limits and I can't do everything. Which is true for everyone else, of course.
Comment 44 Orcan Ogetbil 2009-11-09 22:41:26 EST
(In reply to comment #43)
> (In reply to comment #42)
> > see comment #40 :)
> 
> :-) :-P
> 
> Sigh... 
> 
> I know, I know. I have not been involved in the Fedora packaging loop in a long
> long time and I think I don't have the resources to do that - last time I tried
> it was a huge time sink I could not really afford 

Not really. Well, that may be considered true when you are introducing a brand new package. In this case, the package is already in Fedora, so it does not need to go through the review process (I assume that you find this part time consuming). All that need to be done is 
- cvs checkout
- update spec file
- cvs commit
- make the build
- submit to testing/stable (can easily be done via bodhi)
It shouldn't take more than a couple minutes, which also makes me wonder why the assignee is refusing doing it.
Comment 45 Adam Williamson 2009-11-10 02:07:10 EST
it is easy to resolve, and it will happen. but if you really need it to happen yesterday, that's the only sure way.

jon, could you just push the f11 update too? I've wasted more time replying to this bug than it would have taken me to do the fix myself, if I had commit rights. sigh.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 46 Orcan Ogetbil 2009-11-11 03:12:18 EST
Something interesting came to my attention today. I never read the comment part in /etc/modprobe.d/dist-oss.conf before:

# This has been disabled in F11 onwards because it can interfere with the
# PulseAudio sound service (a legacy OSS application can prevent PulseAudio
# applications from playing sound by preventing PulseAudio from (re-)opening
# the sound device).
# install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe snd-pcm-oss && /sbin/modprobe snd-seq-device && /sbin/modprobe snd-seq-oss


Pulseaudio keeps screwing things up even when it's not installed. Oh boy...
Comment 47 Tony White 2009-11-11 05:32:42 EST
>(a legacy OSS application can prevent PulseAudio
># applications from playing sound by preventing PulseAudio from (re-)opening
># the sound device).

So can using alsa directly. I don't see the point in trying to point a finger at oss modules as a direct result of a pulseaudio programming flaw.
pulseaudio does a nice job here but to drop support for oss to accommodate it before legacy apps and drivers have ported away from oss and it is also officially removed from the mainline kernel seems a little premature.
Sound is bad enough on Linux without also limiting the options.
Comment 48 Adam Williamson 2009-11-11 14:18:11 EST
if no-one deprecates OSS, no-one will ever move away from it. The justification in that comment is a little narrow, really we deprecated OSS because apps badly need to stop using it and someone has to give that a push. But this is OT for the bug.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 49 Jon Masters 2009-11-13 13:24:49 EST
A fix is being taken care of.
Comment 50 Jean-Baptiste Hétier 2009-11-14 07:35:37 EST
Great news, thanks.
Comment 51 Jon Masters 2009-11-23 04:17:31 EST
This is in the 3.7-10 build. I will push to updates.
Comment 52 Fedora Update System 2009-11-23 19:28:35 EST
module-init-tools-3.7-10.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/module-init-tools-3.7-10.fc11
Comment 53 Adam Williamson 2009-11-24 12:55:16 EST
can you guys please test the update and confirm that it works? please report to bodhi - the link in comment #52. note you can log in with FAS credentials - there's a 'log in' button at the bottom of the blue bar on the left hand side of the page.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 54 Fedora Update System 2009-11-25 10:30:03 EST
module-init-tools-3.7-10.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update module-init-tools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-12174
Comment 55 Fedora Update System 2009-12-15 20:11:48 EST
module-init-tools-3.7-10.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 56 Orcan Ogetbil 2010-03-10 00:28:56 EST
*** Bug 527075 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.