Bug 527075 - [abrt] crash detected in lash-0.5.4-8.fc12
[abrt] crash detected in lash-0.5.4-8.fc12
Status: CLOSED DUPLICATE of bug 505421
Product: Fedora
Classification: Fedora
Component: lash (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
abrt_hash:e9fc9db8db795e0bbcbc75e3aed...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-04 01:27 EDT by Renich Bon Ciric
Modified: 2010-03-10 00:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-10 00:28:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.71 KB, text/plain)
2009-10-04 01:27 EDT, Renich Bon Ciric
no flags Details

  None (edit)
Description Renich Bon Ciric 2009-10-04 01:27:01 EDT
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Additional information
======


Attached files
----
backtrace

cmdline
-----
lashd 


component
-----
lash


executable
-----
/usr/bin/lashd


kernel
-----
2.6.31.1-56.fc12.x86_64


package
-----
lash-0.5.4-8.fc12


reason
-----
Process was terminated by signal 6
Comment 1 Renich Bon Ciric 2009-10-04 01:27:03 EDT
Created attachment 363584 [details]
File: backtrace
Comment 2 Orcan Ogetbil 2009-10-04 05:58:27 EDT
Could you tell us how to reproduce the bug? Thanks.
Comment 3 Orcan Ogetbil 2009-10-04 15:55:58 EDT
This might be a consequence of the long standing bug 505421. I hope they
fix that soon which is not very hard to do. (if you read that bug you will see
the unresponsiveness of the maintainer which renders F-11 useless for audio
production)

Well, the workaround is to unblacklist snd-seq* modules. Or to issue a
   modprobe snd-seq
and/or
   modprobe snd-seq-oss
which can be put in your /etc/rc.local file. I believe that lash_* applications
will start fine afterwards. 


Please verify the workaround.
Comment 4 Renich Bon Ciric 2009-10-05 00:31:17 EDT
Ok, please, check this out:

[root@introdesk modprobe.d]# grep snd-seq ./*
./dist.conf:alias sound-service-*-1 snd-seq-oss
./dist.conf:alias sound-service-*-8 snd-seq-oss
./dist-oss.conf:# install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe snd-pcm-oss && /sbin/modprobe snd-seq-device && /sbin/modprobe snd-seq-oss


I don't have it blacklisted...
Comment 5 Orcan Ogetbil 2009-10-05 02:00:51 EDT
So, are snd-seq and snd-seq-oss loaded (can be checked via lsmod) but lash fails?
Comment 6 Renich Bon Ciric 2009-10-06 17:00:00 EDT
[renich@introdesk ~]$ lsmod | grep snd
snd_hda_codec_analog    78544  1 
snd_hda_intel          32136  4 
snd_hda_codec          80480  2 snd_hda_codec_analog,snd_hda_intel
snd_usb_audio         101784  0 
snd_pcm                90568  4 snd_hda_intel,snd_hda_codec,snd_usb_audio
snd_timer              24544  1 snd_pcm
snd_usb_lib            19912  1 snd_usb_audio
snd_rawmidi            25888  1 snd_usb_lib
snd_seq_device          8700  1 snd_rawmidi
snd_hwdep               9864  2 snd_hda_codec,snd_usb_audio
snd                    74936  17 snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_pcm,snd_timer,snd_usb_lib,snd_rawmidi,snd_seq_device,snd_hwdep
soundcore               7952  1 snd
snd_page_alloc         10464  2 snd_hda_intel,snd_pcm
Comment 7 Orcan Ogetbil 2009-10-06 22:05:56 EDT
So they are not loaded. Load them via
   modprobe snd-seq
   modprobe snd-seq-oss
Then start your lash application.
Comment 8 Renich Bon Ciric 2009-10-10 04:00:47 EDT
sorry, it doesn't work. 

After the modprobe, I try to run lash and it gives an error about the device already being in use.
Comment 9 Orcan Ogetbil 2009-10-28 23:46:11 EDT
Hmm... What device? Is there more to the error message?
Comment 10 Renich Bon Ciric 2009-10-30 03:57:01 EDT
huh? what device?

Well, it just gives me that message. 

I have an M32N32-WS motherboard. I suppose everything is nvidia. The audio works fine... but I just can't make that modprobe you asked and start lash...

Sorry for the poor info on this
Comment 11 Bug Zapper 2009-11-16 08:14:35 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Orcan Ogetbil 2010-03-09 01:14:37 EST
I think this issue is resolved by the module-init-tools folks. Could you verify if things work for you?
Comment 13 Renich Bon Ciric 2010-03-09 14:05:25 EST
Confirmed, they work fine now ;)
Comment 14 Orcan Ogetbil 2010-03-10 00:28:56 EST
Thanks, nice.

Since this is resolved by fixing of module-init-tools, I mark this as a duplicate of the corresponding bug.

*** This bug has been marked as a duplicate of bug 505421 ***

Note You need to log in before you can comment on or make changes to this bug.