Bug 505478 - working aes1610 device in f10 not found in f11
working aes1610 device in f10 not found in f11
Status: CLOSED DUPLICATE of bug 499732
Product: Fedora
Classification: Fedora
Component: libfprint (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 23:34 EDT by Michael Cronenworth
Modified: 2009-10-03 17:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 04:50:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Cronenworth 2009-06-11 23:34:11 EDT
Description of problem: I had finger print reading working in F10. After updating to F11, and adding the missing fprint packages, I do not have the "Enroll" button in gnome-about-me. If I attempt to run "fprintd-enroll" I get an error about no devices found. I do have finger print auth enabled in system-config-authorizations. I've rebooted several times to make sure it's on. I do see the GDM button for finger print auth, but it is grey'd out and instead of the "hand" icon I get the "default" image icon as if GDM can't find the correct icon.

I have also loaded an F11 live CD (usb stick) and my finger print reader was not found.


Version-Release number of selected component (if applicable): libfprint-0.1.0-6.pre1.fc11.x86_64, fprintd-0.1-9.git04fd09cfa.fc11.x86_64, fprintd-pam-0.1-9.git04fd09cfa.fc11.x86_64, gdm-plugin-fingerprint-2.26.1-10.fc11.x86_64


How reproducible: Always

  
Actual results:
No "Enroll" button in gnome-about-me.
$ fprintd-enroll 

** ERROR **: list_devices failed: No devices available
aborting...
Aborted


Expected results: Ability to enroll my finger prints.


Additional info:
lsusb -v
Bus 005 Device 003: ID 08ff:1600 AuthenTec, Inc. AES1600
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass       255 Vendor Specific Subclass
  bDeviceProtocol       255 Vendor Specific Protocol
  bMaxPacketSize0         8
  idVendor           0x08ff AuthenTec, Inc.
  idProduct          0x1600 AES1600
  bcdDevice            c.10
  iManufacturer           0 
  iProduct                1 
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           32
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0020  1x 32 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval               0
Comment 1 Bastien Nocera 2009-06-12 04:50:56 EDT

*** This bug has been marked as a duplicate of bug 499732 ***
Comment 2 NSLW 2009-10-03 17:23:56 EDT
The same problem for me.

Note You need to log in before you can comment on or make changes to this bug.