This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 499732 - aes1600 device not supported anymore ?
aes1600 device not supported anymore ?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libfprint (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
: Reopened
: 505478 505998 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 15:48 EDT by kakashizilla
Modified: 2009-12-09 08:24 EST (History)
12 users (show)

See Also:
Fixed In Version: 0.1.0-14.pre2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-08 02:46:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description kakashizilla 2009-05-07 15:48:20 EDT
Description of problem:
The fingerprint reader of my laptop is not usable anymore.
fprint_demo says "device not found", but lsusb finds it : 
  Bus 007 Device 002: ID 08ff:1600 AuthenTec, Inc. AES1600
It was perfectly working with fedora 8, and pam_fprint.
 

Version-Release number of selected component (if applicable):


How reproducible:
Try fprint_demo with this device.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
fprint_demo works "out of the box" as in fedora 8

Additional info:
Comment 1 Frank 2009-05-19 01:00:05 EDT
(In reply to comment #0)
> Description of problem:
> The fingerprint reader of my laptop is not usable anymore.
> fprint_demo says "device not found", but lsusb finds it : 
>   Bus 007 Device 002: ID 08ff:1600 AuthenTec, Inc. AES1600
> It was perfectly working with fedora 8, and pam_fprint.
> 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> Try fprint_demo with this device.
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> fprint_demo works "out of the box" as in fedora 8
> 
> Additional info:  

Same issue here:
$ lsusb|grep Auth
Bus 007 Device 002: ID 08ff:1600 AuthenTec, Inc. AES1600

$fprintd-enroll

** ERROR **: list_devices failed: No devices available
aborting...
Aborted

Was working on F10 and apparently on F11 Beta 1.

FL
Comment 2 Bastien Nocera 2009-05-19 11:48:49 EDT
The aes1610 driver (which supported the AuthenTec AES1600) was never ported to the new internal API, so yes, it is and will be broken until somebody with the device does the port.

If you fancy doing the port, you'll need to modify configure.ac, libfprint/Makefile.am and libfprint/core.c to enable the driver by default.
Comment 3 Bastien Nocera 2009-06-12 04:50:56 EDT
*** Bug 505478 has been marked as a duplicate of this bug. ***
Comment 4 Michael Cronenworth 2009-06-12 12:24:07 EDT
Why is this bug closed? The device is not supported as of current release. Shouldn't the bug remain open until the port is complete? Just because someone @rh doesn't want to do the work? Not that I have a problem with that. Since there is no upstream bug tracker (or did I miss it), this is all we have.

Most, if not all, ASUS laptops use a AES1600 device. You'll have more duplicate bugs once people try to install finger print support.
Comment 5 Bastien Nocera 2009-06-12 13:34:00 EDT
(In reply to comment #4)
> Why is this bug closed?

Because the lack of support for the device is a lack of support upstream.

> The device is not supported as of current release.

We know.

> Shouldn't the bug remain open until the port is complete?

Not really.

>  Just because someone
> @rh doesn't want to do the work?

No, because we don't have the hardware to test it. Those discussions should happen upstream.

> Not that I have a problem with that. Since
> there is no upstream bug tracker (or did I miss it), this is all we have.

That sucks, but that's something to discuss upstream as well.

> Most, if not all, ASUS laptops use a AES1600 device. You'll have more duplicate
> bugs once people try to install finger print support.  

Possibly, but that won't get the driver ported either.
Comment 6 Bastien Nocera 2009-06-15 04:34:17 EDT
*** Bug 505998 has been marked as a duplicate of this bug. ***
Comment 7 Bastien Nocera 2009-06-22 10:48:38 EDT
FWIW, there's an attempt at a patch at http://thread.gmane.org/gmane.linux.fprint/1212

People interested and with the hardware should help finish it.
Comment 8 kakashizilla 2009-06-26 11:55:48 EDT
Hello,
I will be happy to help.
What could I do ? Do you have a rpm to test ?
Comment 9 Richard Schwarting 2009-07-07 02:21:08 EDT
I appreciate that Redhat doesn't feel able to do much about this, and that's up to the upstream project to fix this.  But marking the bug closed doesn't really help, since it's a regression for users of this distribution and will lead to people wasting time filing duplicate bug reports whenever they try to be helpful and fail to find an open one in when searching.

Thanks for the pointer to Michael's work, though.

Cheers, 
  me
Comment 10 Bastien Nocera 2009-07-09 15:19:07 EDT
Richard, leaving it open would make people think that the maintainers will be working on it, which isn't the case.
Comment 11 JanS 2009-08-26 13:57:12 EDT
OK, it is little annoying since "Fingerprinting" was one of the main points in Release Notes for Fedora 11. See fourth of the major features list, after the caption: "The following are major features for Fedora 11:" on
http://docs.fedoraproject.org/release-notes/f11/en-US/

I am installing Fedora 11 and it doesn't work. Since I have standard fingerprint reader AES1600 (08ff:1600 AuthenTec) which is mentioned as the first on the list of supported device, I am a bit disappointed.

Is it hard to port this driver to Fedora 11? I have the hardware, but I don't think I could manage to do so. I am only user.
I can test it though. 
I know C and can compile, but do not know the source code of all these libraries used.

JS
Comment 12 Michael Cronenworth 2009-08-26 15:32:32 EDT
(In reply to comment #11)
> Is it hard to port this driver to Fedora 11? I have the hardware, but I don't
> think I could manage to do so. I am only user.

You are not the only user. There's been a driver made that works with the current libfprint but the upstream maintainer has not done anything with it. I've asked the maintainer about it again today.
Comment 13 Guido Grazioli 2009-09-30 20:10:09 EDT
Hello all, if someone would help debugging the driver, i posted to the fprint-devel list a testing version of the aes1600 driver, more than a month ago.
It can be found here:
http://guidograzioli.fedorapeople.org/aes1610/

This new version is based on the AES2501, which is a very similar device. Another guy helped in the list but maybe it's no considered good quality enough (actually, i didnt get much feedback at all from list, even if the driver does line by line the exact same things of his 2501 twin).

If you decide to try it and cannot login anymore to your desktop session, dont blame me (anyway, it just works...)
Comment 14 Michael Cronenworth 2009-09-30 23:32:51 EDT
(In reply to comment #13)
> Hello all, if someone would help debugging the driver, i posted to the
> fprint-devel list a testing version of the aes1600 driver, more than a month
> ago.

The fprint mailing list had been broken up until a week ago. I thought I posted that the driver works for me. Maybe that message went missing.

I'm currently using your RPM on my laptop with no problems. I use it for login and screensaver. You have to get the initial finger print right though. The reader is hard to use in Vista as well so it may be the reader itself is of poor quality and I wouldn't doubt that.
Comment 15 NSLW 2009-10-03 18:06:04 EDT
(In reply to comment #13)
> Hello all, if someone would help debugging the driver, i posted to the
> fprint-devel list a testing version of the aes1600 driver, more than a month
> ago.

Hello Guido,
First thank you for this driver. In most cases it displays that my finger doesn't match but I can successfully login with it into my account so it works.

Do you need any help in testing it?

BTW.
I created rpms for 32 bit Fedora 11. It can be found on fileshare server
http://www.speedyshare.com/584384762.html
Comment 16 JanS 2009-10-07 18:05:22 EDT
I have installed the 32 bit Fedora 11 rpm from NSLW. It works somehow, i.e. it is possible to see finger image in fprint_demo, but Very hard.

- In 50 percent of cases I get "Scan failed: error -22".
- In 40 percent of cases I get "Bad scan. Detected X minutiae", where X is between 0-10, usually 3-5.
- In 9 percent of cases I get "Finger does not match."

I have seen "Finger match" once.
All of my login attempts were unsuccessful.

System > Preferences > About Me in 95% of swipes tells "Place your finger on the reader again".

Also sometimes fprint_demo crashes.
About Me usually reports "Could not access AuthenTec AS1610 device" and then crashes, if I have fprint_demo running.


Even if in future driver will be working without an errors, I think that threshold of 10 minutiae to accept a scan is too large for this VERY small sensor, which can see only a fraction (~1/8) of a finger area.


Nevertheless many thanks for working on this!

If you need more information about the logs or something, please write what I should do.
Comment 17 Richard Schwarting 2009-10-07 18:15:58 EDT
I'll note that I occasionally get fprintd segfaults (listed in dmesg) with the "08ff:1600 AuthenTec, Inc. AES1600" and this driver.  When that happens, I just retry the application that was calling it (e.g. hit cancel at the screensaver) and it lets me try again (perhaps the library gets reloaded each time?).  

Here's the message: 
messages:Oct  7 14:56:20 dendril kernel: fprintd[2658]: segfault at 100a7f410 ip 00007fb2428d68b5 sp 00007ffffeb9d4a0 error 4 in libfprint.so.0.0.0[7fb2428be000+33000]

Success occurs occasionally.
Comment 18 Guido Grazioli 2009-10-08 19:07:22 EDT
Hello, thanks for looking into this.

(In reply to comment #16)
> I have installed the 32 bit Fedora 11 rpm from NSLW. It works somehow, i.e. it
> is possible to see finger image in fprint_demo, but Very hard.
> 
> - In 50 percent of cases I get "Scan failed: error -22".
> - In 40 percent of cases I get "Bad scan. Detected X minutiae", where X is
> between 0-10, usually 3-5.
> - In 9 percent of cases I get "Finger does not match."

The -22 error, along with random segfaults, are due to an error post assembling the captured image in the driver, when image height is < 12 pixels. That happens usually when your swipe over the reader was too slow (or you kept the finger still over it). I added an (ugly) hack in the new version linked below that fixes this in most cases (as yet). 

10 is now the minimum number of minutiae needed to accept the captured image; 16-22 is considered a good result with such a small frame as it is in the 1601 reader. Among those ones, you should get 1-3 matches over 10 swipes; you have to practice a bit with swipe direction, speed, and pressure, because there's no (optimally tuned) gain adjustment in the driver yet. In the new version below i added some adjustments made by wxCover in a patch sent to the mailing list about 1 year ago, targeted at the old driver. 
If you look at the captured image, you will see some more noise than before, but the "binarized" image should look somewhat better. An important thing is that you dont get whitened areas in the binarized image, those are due to over-exposure, and wont do any good.


> I have seen "Finger match" once.
> All of my login attempts were unsuccessful.

I think the enrollment phase should be improved quite a bit, just doing one swipe to change the captured image is far from optimal. In windows, it took about 5 minutes of continued swiping to convince the producer driver to accept my fingerprint for logging on with that.

> About Me usually reports "Could not access AuthenTec AS1610 device" and then
> crashes, if I have fprint_demo running.

I need to investigate that yet. If you could send me some screenshots of fprint_demo running verify (binarized with minutiae shown) along with the stdout it would be helpful

> 
> Even if in future driver will be working without an errors, I think that
> threshold of 10 minutiae to accept a scan is too large for this VERY small
> sensor, which can see only a fraction (~1/8) of a finger area.

It depends on your swipe speed, try a little more and you will get your almost whole fingerprint area.


(In reply to comment #17)
> I'll note that I occasionally get fprintd segfaults (listed in dmesg) with 
> the "08ff:1600 AuthenTec, Inc. AES1600" and this driver.  When that happens, 
> I just retry the application that was calling it (e.g. hit cancel at the 
> screensaver) and it lets me try again (perhaps the library gets reloaded each
> time?).  

Please try one of the rpms below, segfault should be fixed now.



---
Here are updated rpms for F11 i586 and x86_64, you will need --force (i used the rawhide vanilla libfprint.spec and didnt bump the revision).
http://guidograzioli.fedorapeople.org/aes1610/
Comment 19 NSLW 2009-10-10 12:17:12 EDT
It's better now. No segfaults and my fingerprint is accepted many more times than before. Thanks for this driver.
Comment 20 Richard Schwarting 2009-10-10 14:59:11 EDT
Yah, no more segfaults and greatly improved recognition.  

My girlfriend's left thumb has some issues with being recognised.  Perhaps I should send it in the mail for debugging?  Oh, how morbid. :)
Comment 21 JanS 2009-10-30 17:32:47 EDT
Yes, I can confirm that newer version is way better! 

Now I can learn how to place finger, and how fast to swipe, as there is no segfaults. And actually I get a feedback how my finger looked instead of errors like before.
So in 50% of cases or more I can login. 

(And I haven't got any errors while installing this new rpm)

So great, thanks for your work!
JanS


PS. I am sending to Guido some more logs he requested, but as they contain pictures of my fingerprint, it is not safe to place them on Bugzilla. So I am sending to private email.
Comment 22 Richard Schwarting 2009-11-27 16:41:42 EST
Noting that Fedora 12 does not support aes1600 by default, despite the driver above's availability.
Comment 23 Guido Grazioli 2009-11-27 16:59:02 EST
Unfortunately upstream is unresponsive; could this patch be applied to fedora libfprint.spec?
Comment 24 Bastien Nocera 2009-11-27 17:43:06 EST
If somebody gives me an updated patch...
Comment 25 Guido Grazioli 2009-11-27 18:55:35 EST
Hi Bastien, here i have the patch:
http://guidograzioli.fedorapeople.org/aes1610/0001-Reinclude-Aes1610-Driver.patch
the updated spec if needed:
http://guidograzioli.fedorapeople.org/aes1610/libfprint.spec
and the srpm containing all togheter:
http://guidograzioli.fedorapeople.org/aes1610/libfprint-0.1.0-13.pre2.fc11.src.rpm

Please ask me if you need anything other, thanks.
Comment 26 Bastien Nocera 2009-11-27 19:14:33 EST
(In reply to comment #25)
> Hi Bastien, here i have the patch:
> http://guidograzioli.fedorapeople.org/aes1610/0001-Reinclude-Aes1610-Driver.patch

Could you please get a git formatted patch instead of one containing all the changes to generated files?
Comment 27 Guido Grazioli 2009-11-28 05:33:51 EST
ok; i've never used git before, hope this is what you are asking for
http://guidograzioli.fedorapeople.org/aes1610/aes1610_patch_against_010_pre1.patch
Comment 28 Fedora Update System 2009-11-30 06:28:06 EST
libfprint-0.1.0-13.pre2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libfprint-0.1.0-13.pre2.fc12
Comment 29 Bastien Nocera 2009-11-30 06:29:17 EST
Updated patch coming up, please make sure you base your future patches on that.

Also make sure to add those lines to your ~/.gitconfig:
[color]
        ui = auto
and check for trailing spaces and tabs in your diff output.

There's a few places where the indentation doesn't match the code:
+               else { // minimum gain needed
+               if (pos_list_BE > 0)
+                               pos_list_BE--;
+
+                       if (pos_list_BD > 0)
+                               pos_list_BD--;
+
+                       strip_scan_reqs[1].value = 0x07;
+                       strip_scan_reqs[2].value = 0x35;
                }
-               fp_dbg("sum=%d", sum);
-               if (sum == 0)
-                       count_blank++;
+
+               strip_scan_reqs[0].value = list_BE_values[pos_list_BE];
+               strip_scan_reqs[3].value = list_BD_values[pos_list_BD];
+
+               fp_dbg("gain: %x %x %x %x %x %x %x %x", strip_scan_reqs[0].reg, strip_scan_reqs[0].value, strip_scan_reqs[1].reg, strip_scan_reqs[1].value, strip_scan_reqs[2].reg, strip_scan_reqs[2].value, strip_scan_reqs[3].reg, strip_scan_reqs[3].value);
+       }
Comment 31 Fedora Update System 2009-11-30 23:30:26 EST
libfprint-0.1.0-13.pre2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libfprint'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12401
Comment 32 NSLW 2009-12-01 06:43:06 EST
I've did su -c 'yum --enablerepo=updates-testing update libfprint' and installed libfprint but my fingerprint reader doesn't work. When I start fprint_demo there is "Status: No device found"
Comment 33 Guido Grazioli 2009-12-01 07:01:39 EST
(In reply to comment #30)
> Patch at:
> http://cvs.fedoraproject.org/viewvc/rpms/libfprint/devel/libfprint-aes1610-driver.patch?view=log  

This file looks empty, are you waiting a new rev from me with indentation cleaned?
Can you please push a testing update for F-11 also?
Comment 34 Pavel Mynarsky 2009-12-01 10:42:38 EST
I've installed the newest version of libfprint (libfprint-0.1.0-13.pre2.fc12.x86_64) and it doesn't work for me either with AES1600. I get  "Status: No device found". I can provide more info if needed.
Comment 35 Frank 2009-12-01 18:17:19 EST
Hi all,

it is not working here either. Installed libfprint-0.1.0-13.pre2.fc12.x86_64 and still can't use my finger reader.

# lsusb
Bus 007 Device 002: ID 08ff:1600 AuthenTec, Inc. AES1600

fprint_demo --> Device Not Found

Regards
Frank
Comment 36 Fedora Update System 2009-12-01 23:49:26 EST
libfprint-0.1.0-14.pre2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libfprint'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12401
Comment 37 NSLW 2009-12-02 03:43:02 EST
libfprint-0.1.0-14.pre2.fc12 works for me but it wasn't installed by entering following command 
su -c 'yum --enablerepo=updates-testing update libfprint'
Comment 38 Richard Schwarting 2009-12-05 16:21:07 EST
Using libfprint from updates-testing works here.

Thank you for helping us.
Comment 39 Fedora Update System 2009-12-08 02:46:27 EST
libfprint-0.1.0-14.pre2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 40 Jan Valenta 2009-12-09 08:10:38 EST
Using the libfprint-0.1.0-14.pre2.fc12.x86_64 and AES1600 reader on TOSHIBA M10 causes crash of the fprintd. It is not always reproducable. Probably happens when using different finger from that one which is "learned". Moreover I can log in using this different finger. I don't know if this a bug in the driver or if it relates to the fprintd crash.

See also bug 543194 -- https://bugzilla.redhat.com/show_bug.cgi?id=543194
Comment 41 Jan Valenta 2009-12-09 08:24:32 EST
Now I have made several tests using the fprintd-verify and I got 

Verify result: verify-match (done)

for any of my fingers. 

It seems, that the criteria for template and candidate fingerprint comparison should be set more strictly.

Note You need to log in before you can comment on or make changes to this bug.