Bug 505587 - mdadm schedules sync checks on RAID-0 arrays
mdadm schedules sync checks on RAID-0 arrays
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
: 510946 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 10:25 EDT by Pim Zandbergen
Modified: 2009-07-22 18:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.0-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 18:00:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pim Zandbergen 2009-06-12 10:25:20 EDT
Description of problem:
mdadm install a cron job in /etc/cron.weekly that schedules
check actions that are not appropriate for RAID-0

Version-Release number of selected component (if applicable):
mdadm-3.0-0.devel3.7.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. install mdadm
2. configure a RAID-0 array
3. wait for the cron job to finish
  
Actual results:
Error message by e-mail
/etc/cron.weekly/raid-check: line 4: /sys/block/md0/md/sync_action: No such file or directory


Expected results:
No e-mails containg error messages


Additional info:
Comment 1 Doug Ledford 2009-06-29 15:31:23 EDT
This should be fixed in mdadm-3.0-1.fc11
Comment 2 Fedora Update System 2009-06-29 15:39:16 EDT
mdadm-3.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/mdadm-3.0-1.fc11
Comment 3 Fedora Update System 2009-07-02 01:48:06 EDT
mdadm-3.0-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mdadm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7227
Comment 4 Doug Ledford 2009-07-21 13:48:00 EDT
*** Bug 510946 has been marked as a duplicate of this bug. ***
Comment 5 Jan ONDREJ 2009-07-21 14:13:55 EDT
Looks that this will work for me. Tested running cron.weekly scrip manually from shell without any problem.
Comment 6 Fedora Update System 2009-07-22 18:00:07 EDT
mdadm-3.0-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.