This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 510946 - /sys/block/md2/md/sync_action: No such file or directory
/sys/block/md2/md/sync_action: No such file or directory
Status: CLOSED DUPLICATE of bug 505587
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-12 14:13 EDT by Jan ONDREJ
Modified: 2009-07-21 13:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 13:48:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2009-07-12 14:13:21 EDT
Description of problem:
Looks like there is no sync_action file in proc for raid0 devices and raid-check script for cron reports an script error for these devices.

Version-Release number of selected component (if applicable):
mdadm-3.0-0.devel3.7.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. create an raid0 device
2. run: /etc/cron.weekly/raid-check
  
Actual results:
[root@kvm2 ~]# /etc/cron.weekly/raid-check 
/etc/cron.weekly/raid-check: riadok 4: /sys/block/md2/md/sync_action: Adresár alebo súbor neexistuje

Expected results:
Nothing.

Additional info:
Please, update your list of devices to only those, which are redundant arrays.
You also can check, if there is /sys/block/md*/md/sync_action file for current device, if not, silently skip this device.
Comment 1 Doug Ledford 2009-07-21 13:48:00 EDT

*** This bug has been marked as a duplicate of bug 505587 ***

Note You need to log in before you can comment on or make changes to this bug.