Bug 505588 - gpsd has a broken initscript that fails to launch daemon
gpsd has a broken initscript that fails to launch daemon
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gpsd (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Marek Mahut
Fedora Extras Quality Assurance
:
: 521147 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 10:26 EDT by Solomon Peachy
Modified: 2009-09-08 21:49 EDT (History)
7 users (show)

See Also:
Fixed In Version: 2.39-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-08 21:49:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed initscript (2.29 KB, application/octet-stream)
2009-06-12 10:26 EDT, Solomon Peachy
no flags Details

  None (edit)
Description Solomon Peachy 2009-06-12 10:26:59 EDT
Created attachment 347574 [details]
fixed initscript

Description of problem:

GPSd has broken initscript

Version-Release number of selected component (if applicable):

gpsd-2.39-3.fc11.x86_64

How reproducible:

Always

Steps to Reproduce:
1. service gpsd start
2. Watch it fail.
  
Additional info:

There are two problems with the initscript:

1) The path to the gpsd binary is wrong; it should be /usr/sbin/gpsd instead of /usr/bin/gpsd

2) gpsd uses -P <pidfile> instead of -p <pidfile>

I've attached the fixed initscript.
Comment 1 Fredrik Öhrn 2009-06-24 13:08:35 EDT
There is one additional problem with the init script, it sources /etc/sysconfig/gpsd but then immediately overwrites the OPTIONS and DEVICE settings. Lines 38 and 39 should be deleted.
Comment 2 Joel 2009-07-06 00:01:50 EDT
I reproduced this bug.
Comment 3 Stephen 2009-07-12 13:45:21 EDT
Have noticed all the above bugs.

In addition, gpsd is not started by default.  As the package is not installed by default, if someone explicitly installs it they probably also want it to run.
Comment 4 Marek Mahut 2009-08-12 10:30:28 EDT
This scratch build should fix this bug, please go ahead and try it.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1601092
Comment 5 Fredrik Öhrn 2009-08-15 14:43:32 EDT
The new package works great!
Comment 6 Fedora Update System 2009-08-18 10:41:20 EDT
gpsd-2.39-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gpsd-2.39-4.fc11
Comment 7 Fedora Update System 2009-08-19 19:16:17 EDT
gpsd-2.39-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gpsd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8759
Comment 8 Kurt Seifried 2009-09-08 12:53:48 EDT
*** Bug 521147 has been marked as a duplicate of this bug. ***
Comment 9 Juan A. Burgos 2009-09-08 13:28:15 EDT
works for me.
Comment 10 Fedora Update System 2009-09-08 21:49:45 EDT
gpsd-2.39-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.