Bug 521147 - flaws in /etc/init.d/gpsd
flaws in /etc/init.d/gpsd
Status: CLOSED DUPLICATE of bug 505588
Product: Fedora
Classification: Fedora
Component: gpsd (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Douglas E. Warner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-03 17:14 EDT by Kurt Seifried
Modified: 2009-09-08 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-08 12:53:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Seifried 2009-09-03 17:14:44 EDT
Description of problem:

Multiple flaws in /etc/init.d/gpsd

1) script points to /usr/bin/gpsd, gpsd is actually installed to /usr/sbin/gpsd
2) script uses -p $PIDFILE, gpsd uses -P (capital)

Version-Release number of selected component (if applicable):

gpsd-2.39-3.fc11.i586

How reproducible:

always, "service start gpsd" 

Steps to Reproduce:
1. service start gpsd
2.
3.
  
Actual results:

Fails to run (complains about missing /usr/bin/gpsd, once you fix that it complains about -p invalid option.

Expected results:

It should run gpsd.

Additional info:
Comment 1 Juan A. Burgos 2009-09-08 04:58:49 EDT
This likes to be dup of 505588
Comment 2 Kurt Seifried 2009-09-08 12:53:48 EDT

*** This bug has been marked as a duplicate of bug 505588 ***

Note You need to log in before you can comment on or make changes to this bug.