Bug 505616 - Alter Channel Subscriptions Generates ISE
Alter Channel Subscriptions Generates ISE
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Jeff Ortel
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-06-12 11:36 EDT by Devan Goodwin
Modified: 2009-09-10 16:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:37:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2009-06-12 11:36:42 EDT
Description of problem:

Viewing a system's details and selecting alter channel subscriptions will generate an ISE.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090612.0-i386-embedded-oracle.iso


How reproducible:

Should be deterministic.

Steps to Reproduce:
1. Sync RHEL channel.
2. Register system.
3. Navigate to system details and "Alter Channel Subscriptions"
  
Actual results:

ISE:

	at com.redhat.rhn.common.db.datasource.SelectMode.execute(SelectMode.java:105)
	at com.redhat.rhn.manager.BaseManager.makeDataResult(BaseManager.java:57)
	at com.redhat.rhn.manager.channel.ChannelManager.lookupLatestEusChannelForRhelVersion(ChannelManager.java:2248)
	at com.redhat.rhn.manager.channel.ChannelManager.listBaseChannelsForSystem(ChannelManager.java:1963)
	at com.redhat.rhn.frontend.action.systems.sdc.SystemChannelsAction.unspecified(SystemChannelsAction.java:124)
	at org.apache.struts.actions.DispatchAction.dispatchMethod(DispatchAction.java:249)
	at org.apache.struts.actions.DispatchAction.execute(DispatchAction.java:187)
	at org.apache.struts.actions.LookupDispatchAction.execute(LookupDispatchAction.java:150)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
	... 40 more
Caused by: java.sql.SQLException: ORA-00904: "RCM"."IS_DEFAULT": invalid identifier

	... 67 more


Expected results:

Obvious. :)

Additional info:

Caused by fix for bug #503243 where is_default column of rhnReleaseChannelMap  was dropped from the database and the appropriate changes were made to the backend. The Java webui however still references it in it's Hibernate mappings, unit tests, a handful of datasource queries, and depends on it for the logic which determines which EUS channels are suitable candidates for switching too. All of these will need to be updated.
Comment 1 Devan Goodwin 2009-06-12 11:37:53 EDT
Hibernate mappings removed:

spacewalk.git: d4feb1cf9f56c5838269f1e54d54e6836353d6cd
satellite.git: 159042694bfe4d7901b27b20f17b1aa538ebd95f
Comment 13 Milan Zázrivec 2009-08-20 09:12:30 EDT
Stage 5.3.0 verification: everything works as expected as long as the
satellite system does have complete package profile from the client
system (or at least it can see redhat-release package)

See bugs #503090 and bug #510798 for details.

RELEASE_PENDING
Comment 14 Brandon Perkins 2009-09-10 16:37:50 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.