Bug 505704 - Anaconda crashes during post-install if filesystems are mounted under others
Anaconda crashes during post-install if filesystems are mounted under others
Status: CLOSED DUPLICATE of bug 504986
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 21:50 EDT by a_thing
Modified: 2009-08-07 11:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 11:42:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debugging output from Anaconda crash (122.97 KB, text/plain)
2009-06-12 21:50 EDT, a_thing
no flags Details

  None (edit)
Description a_thing 2009-06-12 21:50:00 EDT
Created attachment 347693 [details]
debugging output from Anaconda crash

Description of problem:
From the Fedora 11 x86 KDE Live CD, I tried to install Fedora to my harddrive. In my partition setup, I had a filesystem (/dev/sda6) mounted as /home/notroot/shared and another (/dev/sda2) as /home. When Anaconda tried to umount /dev/sda2 (/home), it ran into an error: it could not umount /home because there was another filesystem, /dev/sda6 (/home/notroot/shared), mounted under it. 

Version-Release number of selected component (if applicable):
11

How reproducible:
every time

Steps to Reproduce:
1. Boot Fedora 11 KDE Live CD (or probably any other Fedora 11 installation media)
2. Mount a filesystem somewhere when creating the partition layout and mount another as a subdirectory of the former filesystem's mountpoint.
3. Continue through the installation process.
  
Actual results:
Anaconda crashes during the post-install operations.

Expected results:
The post-install operations work.

Additional info:
I opened a Konsole window and ran su. I tried umounting /mnt/sysimage/home but got an error saying the filesystem was busy. After successfully umounting /mnt/sysimage/home/notroot/shared, I umounted /mnt/sysimage/home fine.

Trying to install Fedora again but without telling Anaconda to mount /dev/sda6 as /home/notroot/shared worked fine.
Comment 1 Chris Lumens 2009-08-07 11:42:09 EDT

*** This bug has been marked as a duplicate of bug 504986 ***

Note You need to log in before you can comment on or make changes to this bug.