Bug 504986 - F11-F13 x86-64 LiveUSB backtrace
F11-F13 x86-64 LiveUSB backtrace
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:7cd12fd4cd7d2aa14...
: Reopened
: 505704 518327 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2009-06-10 06:15 EDT by Bastien Nocera
Modified: 2010-05-18 20:06 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-13.41-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 20:06:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (142.74 KB, text/plain)
2009-06-10 06:15 EDT, Bastien Nocera
no flags Details

  None (edit)
Description Bastien Nocera 2009-06-10 06:15:00 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59-1.fc11 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/isys.py", line 198, in umount
    rc = _isys.umount(what)
  File "/usr/lib/anaconda/storage/formats/fs.py", line 612, in unmount
    rc = isys.umount(self._mountpoint, removeDir = False)
  File "/usr/lib/anaconda/storage/formats/fs.py", line 802, in teardown
    return self.unmount(*args, **kwargs)
  File "/usr/lib/anaconda/livecd.py", line 286, in _doFilesystemMangling
    e.format.teardown()
  File "/usr/lib/anaconda/livecd.py", line 349, in doPostInstall
    self._doFilesystemMangling(anaconda)
  File "/usr/lib/anaconda/backend.py", line 285, in doPostInstall
    anaconda.backend.doPostInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1360, in handleRenderCallback
    self.currentWindow.renderCallback()
SystemError: (2, None)
Comment 1 Bastien Nocera 2009-06-10 06:15:08 EDT
Created attachment 347184 [details]
Attached traceback automatically from anaconda.
Comment 2 Bastien Nocera 2009-06-10 06:27:15 EDT
This happens after doing an installation with a custom hard drive layout. Some existing partitions were kept (/home and /home/data) and all the other ones wiped.

No partition changes were made, /boot was formatted as ext3, / as ext4 and the swap reformatted as well.

No encryption options were selected.
Comment 3 Bastien Nocera 2009-06-10 07:29:30 EDT
I think the problem is because it tries to umount /home without having umounted /home/data. Will try an installation to verify that this works around the problem.
Comment 4 Bastien Nocera 2009-06-10 07:40:07 EDT
Verified. I didn't add a mountpoint for /home/data, and it finished the installation properly.
Comment 5 Chris Lumens 2009-08-07 11:42:09 EDT
*** Bug 505704 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2009-08-14 11:51:41 EDT
Fixed for rawhide
Comment 7 Chris Lumens 2009-08-19 17:08:18 EDT
*** Bug 518327 has been marked as a duplicate of this bug. ***
Comment 8 Paul W. Frields 2009-08-20 07:39:03 EDT
I have a LiveUSB that I created from the F12 Alpha x86_64 image, updated it to anaconda-12.16-1, and this is still not working.  I have separate /var/www/fedora and /var/www partitions that are still triggering this problem.  

Yesterday I had this problem with 12.15-1, and filed bug 518327.  Didn't get a chance to rewrite the LiveUSB and retry until this morning, but I did update to 12.16-1 before attempting a liveinst.  I'm filing a new bug using the Save to Bugzilla feature so someone can take another gander at this.
Comment 9 Paul W. Frields 2009-08-20 07:41:45 EDT
Sorry, Save to Bugzilla means my TB got appended to bug 518327.
Comment 10 Jeremy Katz 2009-08-21 15:07:49 EDT
Are you sure that you had the update?  The code looks right (my rawhide live install is failing for other reasons at the moment)
Comment 11 Paul W. Frields 2009-08-21 15:43:38 EDT
Check the latest traceback attached to bug 518327: https://bugzilla.redhat.com/attachment.cgi?id=358070

Note the 12.16-1.fc12... The installation wouldn't work properly until I tried leaving out the /var/www/fedora partition.  I did a normal 'yum update anaconda' to get that latest version, and the update completed properly.
Comment 12 Jeremy Katz 2009-08-26 11:07:25 EDT
It worked for me just now, but I've fixed something  that could possibly be related and also added a fair bit more debugging.  So should hopefully be good in 12.1.7 and if not, we'll have more info on why not :)
Comment 13 Tom Horsley 2010-04-16 22:39:39 EDT
I'm not sure what version is on the F13 Beta KDE Live CD but I just
added a traceback to bug 518327 from an attempt to install it on hard
disk. I was indeed using a custom layout:

/ /dev/sda5 reformat as ext4
/boot /dev/sda1 reformat as ext3
/space /dev/sda6 keep existing ext4 partition
/win98 /dev/sda2 keep exiting vfat partition
swap /dev/sdb1
/spike /dev/sdb5 keep exiting ext3 partition
Comment 14 Paul W. Frields 2010-04-19 09:10:41 EDT
Reopening against F13.  I'm also setting "F13Blocker," not because I'm sure this is a blocker, but because I'd like someone more informed than us to make that call, since this appears to be a regression.

I also have a traceback attached to bug 518327 gathered from liveinst on the F13 Beta x86_64 Desktop Live image.

The traceback and other attachments have the full partition information, but just to sum up:

/dev/sda1, /dev/sda2 -- Dell OEM stuff (keep)
/dev/sda3 -- /boot -- reformat ext4
/dev/sda5 -- Linux LVM:
  /                       -- reformat ext4
  /home                   -- keep ext4
  swap                    -- reformat swap
  /var                    -- reformat ext4
  /var/lib/mysql          -- keep ext4
  /var/www                -- reformat ext4 (*)
  /var/www/fedora         -- keep ext4 (*)
  /var/lib/libvirt/images -- keep ext4

(*) appears to have caused the problem, not properly unmounting and tearing down /var/www/fedora before trying to unmount and tear down /var/www.

When I reran, and had anaconda ignore the /var/www/fedora, /var/lib/libvirt/images, and /var/lib/mysql partitions, everything went swimmingly.  However, it would be far preferable for system owners not to have to figure this part out on their own.
Comment 15 Adam Williamson 2010-04-23 12:39:09 EDT
Discussed at 2010/04/23 blocker review meeting. Agreed that this is a blocker. Anaconda team will investigate and try to fix.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 David Lehman 2010-04-26 17:18:55 EDT
Is there anyone who can reliably reproduce this failure? I have been unable to do so. I suspect it has something to do with the contents or state of some of these preexisting filesystems.
Comment 17 Tom Horsley 2010-04-26 19:14:15 EDT
As long as we are suspecting, I suspect it has something to do with
partition boundary alignment. Apparently there are rules for what
cylinder boundaries partitions are supposed to be on, and every single
operating system distro as well as every single partitioning tool
has those rules built into it.

Unfortunately, absolutely all of the rules conflict and produce partition
layouts the other tools honk about :-).

The system that generated my backtrace had Windows 98 installed on it,
then ubuntu with some new partitions created, then fedora 13 with the KDE
live CD (where I got the error attempting to mount all the existing
partitions in the initial fstab), and now has had f13 from the dvd image
installed on it successfully (by not mounting any other filesystems
till after the primary install was completed).

Even after that success, I had to install the DOS version of grub on
the MBR to be able to get Windows 98 to boot as the f13 grub seems to
confuse win98 completely when chainloading.
Comment 18 David Lehman 2010-04-27 10:27:09 EDT
The fundamental problem is a failure to unmount a filesystem. If the problem was related to partition alignment we would likely have seen the failure when trying to mount.

I'm still interested in identifying anyone who can hit this at will.
Comment 19 Paul W. Frields 2010-04-27 19:59:51 EDT
Dave, I think my case above is fully reproducible, if that's what you mean.  If I didn't provide enough info, though, let me know and I'll be happy to help, especially since I brought up the blocker status.
Comment 20 David Lehman 2010-04-28 13:25:36 EDT
(In reply to comment #19)
> Dave, I think my case above is fully reproducible, if that's what you mean.  If
> I didn't provide enough info, though, let me know and I'll be happy to help,
> especially since I brought up the blocker status.    

I tried to reproduce by creating a vg with separate lvs for /, swap, /home, /var, /var/www, and /var/www/fedora. I completed that install, then started another. In the second install, I chose to reformat /, swap, /var, and /var/www, but not /var/www/fedora. It completed successfully, so the idea that the /var structure you used is sufficient to reproduce seems to be inaccurate.
Comment 21 David Lehman 2010-04-28 14:05:05 EDT
Feel free to completely disregard comment 20. I am so used to non-live installs that as soon as I saw the bootloader config screen I assumed I was in the clear. Not so.
Comment 22 Adam Williamson 2010-04-30 12:26:38 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 23 James Laska 2010-04-30 12:32:06 EDT
Reassigning to dlehman@redhat.com per discussion at 2010-04-30 blocker review meeting.
Comment 24 Adam Williamson 2010-05-05 08:05:33 EDT
Ping, Dave?
Comment 25 David Lehman 2010-05-05 11:11:08 EDT
Patch just sent out for review:

https://www.redhat.com/archives/anaconda-devel-list/2010-May/msg00126.html
Comment 26 Fedora Update System 2010-05-07 03:42:39 EDT
anaconda-13.41-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.41-1.fc13
Comment 27 Tom Horsley 2010-05-09 14:57:01 EDT
(In reply to comment #13)

Yesterday I installed the RC2 Live CD (i686) on this same machine, told
anaconda to mount all the same partitions I had problems with before,
and this time it worked fine. So there was either something specific to
the KDE live cd (which I used the first time), or the problem is now fixed
for me.
Comment 28 Adam Williamson 2010-05-10 09:01:11 EDT
Yeah, it should be fixed in RC2, good to get confirmation. Can anyone else confirm this?
Comment 29 Adam Williamson 2010-05-18 20:06:28 EDT
well, let's close it.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.