Bug 505711 - RFE: volume-control applet can't be positioned independently of notification area
RFE: volume-control applet can't be positioned independently of notification ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 506850 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 23:00 EDT by Zing
Modified: 2009-06-19 11:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 06:09:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zing 2009-06-12 23:00:02 EDT
Description of problem:

It seems in F11 the volume control mixer is now tied to the notification area.

I like to have the volume control to the extreme right of the panel and the notification area somewhere in the middle so it can "dynamically grow/shrink" as apps pop in and out of the notification area.  

As it is now, i'm forced to have the notification area in the extreme right where it shifts all the other stuff on my panel when, for example, i start or stop rythmbox.


Version-Release number of selected component (if applicable):
gnome-media-2.26.0-6.fc11.x86_64

How reproducible:
always

Expected results:
ability to place the volume control where I want it.

Additional info:
in < F11, i guess volume control was an independent applet?  that would be a fine solution for me.
Comment 1 Denny Crane 2009-06-15 23:02:32 EDT
Is this part of the new version of Gnome, or specific to Fedora?

I agree it is completely annoying that it cannot be moved independently of the notification area. I (normally) put the volume applet to the extreme right of the top panel and would normally be able to move my mouse to that corner and use the scroll wheel to adjust the volume without even having to look at what I'm doing.

I have also experienced a slew of other bugs relating to the new volume control icon, but those will have to be in other bug reports.
Comment 2 Bastien Nocera 2009-06-16 06:09:28 EDT
The volume "applet" became a notification area icon due to a number of reasons, that have been hashed out on fedora-devel-list and upstream already.

The specific problem of the volume control icon not being in a particular place across restarts is a problem for the panel that's being worked on upsteam.

See:
http://bugzilla.gnome.org/show_bug.cgi?id=583115
Comment 3 Bastien Nocera 2009-06-19 06:10:27 EDT
*** Bug 506850 has been marked as a duplicate of this bug. ***
Comment 4 Zing 2009-06-19 11:12:04 EDT
my search-fu is weak and i'm having trouble separating the "wheat from the chaff".  if someone could pinpoint the links to the relevant discussion(s) i would greatly appreciate it.

From what you say, it sounds like tying the sound mixer to the notification area is a done deal.  :(

Note You need to log in before you can comment on or make changes to this bug.