Bug 505725 - Anaconda fails with exception while detecting storage
Anaconda fails with exception while detecting storage
Status: CLOSED DUPLICATE of bug 521033
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i586 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: 506572 (view as bug list)
Depends On:
Blocks: 513462
  Show dependency treegraph
Reported: 2009-06-13 04:59 EDT by Sergey Kurtsev
Modified: 2009-09-08 11:31 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-09-08 11:31:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Anaconda dump (132.44 KB, text/plain)
2009-06-29 13:24 EDT, Sergey Kurtsev
no flags Details
Anaconda traceback for probably the same problem. (183.35 KB, text/plain)
2009-08-23 07:45 EDT, 260795
no flags Details
Bug Report Data (5.55 MB, image/jpeg)
2009-09-06 21:16 EDT, Lynch Davis
no flags Details

  None (edit)
Description Sergey Kurtsev 2009-06-13 04:59:55 EDT
Description of problem:
Anaconda traces back an exception after while detecting storage

Version-Release number of selected component (if applicable):

How reproducible:
Boot to Upgrade grub menu item after Preupgrade reboot.
Comment 1 Sergey Kurtsev 2009-06-13 05:01:13 EDT
This might be helpful:

I've got some ext4 partitions installed on Fedora 10.

# /etc/fstab
# Created by anaconda on Thu Jan 29 12:08:53 2009
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
/dev/Terabyte/root      /                       ext3    defaults        1 1
/dev/Terabyte/home      /home                   ext4    defaults        1 2
/dev/Terabyte/usr       /usr                    ext4    defaults        1 2
/dev/Terabyte/var       /var                    ext4    defaults        1 2
UUID=87f31671-4bae-4178-a12d-b553e06a7a3c /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/swap    swap                    swap    defaults        0 0
/dev/Terabyte/swap      swap                    swap    defaults        0 0
Comment 2 Bruno Medeiros 2009-06-16 23:42:49 EDT
I'm having the same problem here trying to upgrade a Fedora 10 X86_64, with both preupgrade or DVD media install.

I could not provide de stack trace because when I try to save the bug, anaconda tries to detect the disks again and the report bug window freezes too.. If needed, i could provide a screenshot...

The version of anaconda in both preupgrade and DVD is

I also have some ext4 partitions in fedora 10 as follows:

# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

tmpfs	/dev/shm	tmpfs	defaults	0	0
devpts	/dev/pts	devpts	gid=5,mode=620	0	0
sysfs	/sys	sysfs	defaults	0	0
proc	/proc	proc	defaults	0	0
UUID=4f873cab-857c-4dab-a503-8b25ca5186fc	/	ext3	defaults	1	1
UUID=4a7904fb-fc38-41a7-b3c6-4130971109b4	/boot	ext3	defaults	1	2
UUID=861cfd9a-f8f4-412e-9741-84fb995aca21	/home	ext3	defaults	1	2
UUID=24E4EE3F0DBD2057	/media/Save	ntfs-3g	defaults,locale=en_US.UTF-8	0	0
UUID=37F5F6D8390554C2	/media/WinVista	ntfs-3g	defaults,nosuid,nodev,uhelper=hal,locale=en_US.UTF-8	0	0
UUID=A8B043E6B043B998	/media/WinXP	ntfs-3g	defaults,nosuid,nodev,uhelper=hal,locale=en_US.UTF-8	0	0
UUID=b41a3ff4-6e0b-4f3a-be6d-078ec2bb15ba	/media/Films	ext4	defaults	1	2
UUID=9fdb9e72-df7e-4777-ba68-dca62bb40c87	/media/Musics	ext4	defaults	1	2
UUID=ef25c484-4820-4e28-a530-848edae54e24	/media/Shelter	ext3	defaults	1	2
UUID=ed296f08-14c7-435c-b390-a7768cec5ae8	swap	swap	defaults	0	0

I hope I could help...
Comment 3 Bruno Medeiros 2009-06-26 07:01:23 EDT
I have a soft RAID 1 volume, which uses a partition on sda and other in sdc (both identical disks). After removing this RAID partition, that was the UUID=ef25c484-4820-4e28-a530-848edae54e24 (/dev/md0) disk above, anaconda starts normally.

I think is a problem related with mounting this RAID volume.
Comment 4 Chris Lumens 2009-06-29 11:29:49 EDT
Sergey - please attach the complete traceback to this bug report so we can work on this?  It's hard to tell what the problem is without the actual traceback.
Comment 5 Sergey Kurtsev 2009-06-29 13:24:42 EDT
Created attachment 349826 [details]
Anaconda dump

Here goes the anaconda dump file.

I was sure I had attached it in first place :(
Comment 6 Chris Lumens 2009-07-17 16:07:01 EDT
*** Bug 506572 has been marked as a duplicate of this bug. ***
Comment 7 Sergey Kurtsev 2009-07-23 04:49:32 EDT
Some additional information I've figured out occasionally yesterday:

How to reproduce:
1. Select custom layout or review/modify layout. 
2. Delete default layout .
3. Create swap partition as a standalone physical partition, e.g. outside of any RAID/LVM volumes.
4. Create your custom layout.
5. Apply.
This causes anaconda to fail permanently with format error.

How to avoid the problem (when creating RAID):
1. Do not create swap outside LVM or RAID.
2. Create RAID volumes and then RAID array.
3. Create LVM on top of RAID array.
4. Create Volume Group.
5. Create swap as a Logical Volume inside Volume Group.
6. Create other Logical Volumes you need.

That's it. Swap will be used on top of RAID but that's better then nothing.
Comment 8 James Laska 2009-08-07 13:17:40 EDT
Attaching traceback for searching.

anaconda exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 289, in setup
    raise FormatSetupError("invalid device specification")
  File "/usr/lib/anaconda/storage/formats/swap.py", line 118, in setup
    DeviceFormat.setup(self, *args, **kwargs)
  File "/usr/lib/anaconda/storage/__init__.py", line 1581, in turnOnSwap
  File "/usr/lib/anaconda/upgrade.py", line 313, in upgradeMountFilesystems
    anaconda.id.storage.fsset.turnOnSwap(anaconda, upgrading=True)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
  File "/usr/lib/anaconda/dispatch.py", line 227, in currentStep
  File "/usr/lib/anaconda/gui.py", line 1372, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1534, in setup_window
  File "/usr/lib/anaconda/gui.py", line 1544, in run
  File "/usr/lib/anaconda/gui.py", line 1292, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 965, in <module>
FormatSetupError: invalid device specification
Comment 9 260795 2009-08-23 07:45:51 EDT
Created attachment 358347 [details]
Anaconda traceback for probably the same problem.

Anaconda dump for a problem pretty much similar to the one described and probably caused by the same source. The system is an old one which has been upgraded many times starting from RH 7.3. The problem was caused by the swap partitions and, probably, by a change in the name of the disk devices. After removing the swap partitions from fstab I've been able to upgrade the system. The swap partitions have been added back later, changing the device name appropriately.
Comment 10 Lynch Davis 2009-09-01 07:51:43 EDT
I am having the same problem as described above.  I have a ASUS based Intel mb configuration, with a SATA HD (seagate) and SATA DVD-RW (Plextor).  No fancy raid, and the only bios configuration change is to boot from CD/DVD before HD.

Anyway, Boot up goes fine.  The "verify media" requires keyboard input since the mouse (usb, HID) has not been initialized yet.  After media, it launches anaconda, screen goes into a high-res mode.  I'm prompted for language and keyboard selection.  The it starts to search for storage media, and gets the exception.  I have tried to save off, but the machine then locks up.

Existing disk has both linux, swap, and NTFS partitions, but I already had working configurations (including Fedora 8 and 9) previously.
Comment 11 Joel Andres Granados 2009-09-02 08:38:06 EDT

If you tested with current rawhide, can you pls attach the trace back.  if your test was not with current rawhide, can you pls test with it.
Comment 12 Lynch Davis 2009-09-02 21:29:23 EDT
hey Joel,
Sorry, not able to capture the traceback since it locks up.  I just reinstalled Fedora 10 x86_64 from 11/20/08 and it installs without a problem.  Sorry I don't have more details.  Any suggestions for capturing the traceback?
Comment 13 Joel Andres Granados 2009-09-03 08:19:56 EDT
If  you see the traceback in the screen you have one of two choices.  Write it down somewhere or take a picture.  I like the picture idea better.
Comment 14 Lynch Davis 2009-09-06 21:16:21 EDT
Created attachment 359934 [details]
Bug Report Data

Here is the crash data on storage identification for Fedora 11 installation.
Comment 15 Joel Andres Granados 2009-09-08 11:31:31 EDT

*** This bug has been marked as a duplicate of bug 521033 ***

Note You need to log in before you can comment on or make changes to this bug.