This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 506572 - Attempting to Upgrade from FC10
Attempting to Upgrade from FC10
Status: CLOSED DUPLICATE of bug 505725
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:3fea10818b0712f4d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 15:14 EDT by Skip
Modified: 2009-08-05 01:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-17 16:07:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (190.71 KB, text/plain)
2009-06-17 15:15 EDT, Skip
no flags Details
Attached traceback automatically from anaconda. (158.40 KB, text/plain)
2009-06-21 17:30 EDT, Bruce Drake
no flags Details
Attached traceback automatically from anaconda. (260.82 KB, text/plain)
2009-07-27 13:55 EDT, Michal Jaegermann
no flags Details
Attached traceback automatically from anaconda. (88.75 KB, text/plain)
2009-08-04 21:45 EDT, Jerry Vonau
no flags Details

  None (edit)
Description Skip 2009-06-17 15:14:57 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 289, in setup
    raise FormatSetupError("invalid device specification")
  File "/usr/lib/anaconda/storage/formats/swap.py", line 118, in setup
    DeviceFormat.setup(self, *args, **kwargs)
  File "/usr/lib/anaconda/storage/__init__.py", line 1581, in turnOnSwap
    device.format.setup()
  File "/usr/lib/anaconda/upgrade.py", line 313, in upgradeMountFilesystems
    anaconda.id.storage.fsset.turnOnSwap(anaconda, upgrading=True)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
FormatSetupError: invalid device specification
Comment 1 Skip 2009-06-17 15:15:03 EDT
Created attachment 348326 [details]
Attached traceback automatically from anaconda.
Comment 2 Bruce Drake 2009-06-21 17:30:33 EDT
Created attachment 348822 [details]
Attached traceback automatically from anaconda.
Comment 3 Bruce Drake 2009-06-21 17:35:03 EDT
Prior to experiencing this exception (see comment #2), I had another error, which displayed in a pop-up saying something like device sdb unreadable, ignore or reinitalize.  I selected ignore because that device is one of my MSWindows volumes.  Don't know if this is related or not.
Comment 4 Chris Lumens 2009-07-17 16:07:01 EDT

*** This bug has been marked as a duplicate of bug 505725 ***
Comment 5 Michal Jaegermann 2009-07-27 13:55:43 EDT
Created attachment 355301 [details]
Attached traceback automatically from anaconda.
Comment 6 Michal Jaegermann 2009-07-27 15:17:09 EDT
I am not sure why an automatic submission classified that in this report.
An ultimate error appears to be

ImportError: cannot import name CTC

triggered by an attempt to convert a firewall configuaration and associated with a segfault while running some triggers for system-firewall-config package.

I removed that offending package and the whole update is running right now (with still some two hundreds packages to go).
Comment 7 Jerry Vonau 2009-08-04 21:45:35 EDT
Created attachment 356249 [details]
Attached traceback automatically from anaconda.
Comment 8 Jerry Vonau 2009-08-05 01:39:30 EDT
Mine appears to be caused by the "swap in fstab" issue, my swap lives on LVM

Note You need to log in before you can comment on or make changes to this bug.