Bug 505740 - ImageMagick convert segfault
ImageMagick convert segfault
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
: 507661 508690 529481 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 06:54 EDT by Nickolay Bunev
Modified: 2009-10-17 15:15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 09:17:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace convert output (86.60 KB, text/plain)
2009-06-13 06:54 EDT, Nickolay Bunev
no flags Details
test jpg file (20.74 KB, image/jpeg)
2009-06-13 06:55 EDT, Nickolay Bunev
no flags Details
test jpg file 2 (23.07 KB, image/jpeg)
2009-06-13 06:55 EDT, Nickolay Bunev
no flags Details

  None (edit)
Description Nickolay Bunev 2009-06-13 06:54:02 EDT
Created attachment 347728 [details]
strace convert output

Description of problem:

convert segfault when trying to convert more than one jpg file to pdf.There is no problem when converting only one image to pdf.

Version-Release number of selected component (if applicable):

convert --version
Version: ImageMagick 6.5.1-2 2009-04-13 Q16 OpenMP http://www.imagemagick.org

Nick@Atlantis:[Sat Jun 13 13:39:29]:[~/Download/pdf]$ rpm -qa | grep ImageMagick
ImageMagick-debuginfo-6.5.1.2-1.fc11.x86_64
ImageMagick-perl-6.5.1.2-1.fc11.x86_64
ImageMagick-devel-6.5.1.2-1.fc11.x86_64
ImageMagick-6.5.1.2-1.fc11.x86_64
ImageMagick-c++-6.5.1.2-1.fc11.x86_64
ImageMagick-c++-devel-6.5.1.2-1.fc11.x86_64


How reproducible:
Everytime, when trying to convert more than one image. 

Steps to Reproduce:
1. convert *.jpg allinone.pdf
  
Actual results:

Segmentation fault and one corrupted pdf file.

Expected results:

A pdf file with one image per page.

Additional info:

convert is working as expected on Fedora 10 (x86_64), with:
convert --version
Version: ImageMagick 6.4.0 07/27/08 Q16 http://www.imagemagick.org


(gdb) run *.jpg to.pdf
Starting program: /usr/bin/convert *.jpg to.pdf
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x0000003e0f8dea63 in CloneImage (image=0x61fc80, columns=0, rows=0, orphan=MagickFalse, exception=0x622ef8) at magick/image.c:1129
1129            clone_image->next->previous=clone_image;
Current language:  auto; currently minimal
(gdb)
Comment 1 Nickolay Bunev 2009-06-13 06:55:06 EDT
Created attachment 347729 [details]
test jpg file
Comment 2 Nickolay Bunev 2009-06-13 06:55:31 EDT
Created attachment 347730 [details]
test jpg file 2
Comment 3 Hans de Goede 2009-06-15 09:17:28 EDT
I've just build 6.5.3.7 for rawhide / F-12 development, and that fixes this. Unfortunately I cannot do an F-11 update with this version in as the ABI is changed.
Comment 4 Pavel Alexeev 2009-06-15 09:21:06 EDT
Hans de Goede, I'm also make this update...

But shouldn't me inspire dependency-rebuild on this case? Segfault is critical bug, and closing this bug do not care reported problem, as I understood...
Comment 5 Hans de Goede 2009-06-15 09:25:11 EDT
(In reply to comment #4)
> Hans de Goede, I'm also make this update...
> 
> But shouldn't me inspire dependency-rebuild on this case? Segfault is critical
> bug, and closing this bug do not care reported problem, as I understood...  

This is a bug which almost no-one will hit, so it is not critically enough
to force a rebuild of all packages depending on ImageMagick.
Comment 6 Pavel Alexeev 2009-06-23 14:30:51 EDT
*** Bug 507661 has been marked as a duplicate of this bug. ***
Comment 7 Pavel Alexeev 2009-06-29 11:37:37 EDT
*** Bug 508690 has been marked as a duplicate of this bug. ***
Comment 8 Pavel Alexeev 2009-10-17 15:15:47 EDT
*** Bug 529481 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.