Bug 507661 - imageMagick convert segmentation fault
imageMagick convert segmentation fault
Status: CLOSED DUPLICATE of bug 505740
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 12:56 EDT by Klaatu
Modified: 2009-06-23 15:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-23 14:30:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaatu 2009-06-23 12:56:47 EDT
Description of problem:
When converting a batch of images to a single pdf file, imageMagick "convert" returns a Segmentation Fault

Version-Release number of selected component (if applicable):
Version: ImageMagick 6.5.1-2 2009-04-13 Q16 OpenMP

How reproducible:
Every time.

Steps to Reproduce:
1. gather a group of image files...I used digital images named sequentially starting with 101_2167.JPG

2. issue this command:
convert 101_21??.JPG output.pdf

3. you will get a result similar to this:
[klaatu@fedora disabilityForms]$ convert -verbose imagefiles*.JPG output.pdf
101_2167.JPG JPEG 850x1100 850x1100+0+0 8-bit PseudoClass 256c 195kb         
101_2168.JPG JPEG 850x1100 850x1100+0+0 8-bit PseudoClass 256c 160kb         
101_2169.JPG JPEG 850x1100 850x1100+0+0 8-bit PseudoClass 256c 160kb         
101_2170.JPG JPEG 850x1100 850x1100+0+0 8-bit PseudoClass 256c 328kb         
101_2171.JPG JPEG 850x1100 850x1100+0+0 8-bit PseudoClass 256c 266kb         
101_2172.JPG JPEG 850x1100 850x1100+0+0 8-bit PseudoClass 256c 258kb         
101_2173.JPG JPEG 850x1100 850x1100+0+0 8-bit PseudoClass 256c 128kb         
101_2174.JPG JPEG 850x1100 850x1100+0+0 8-bit PseudoClass 256c 218kb         
Segmentation fault   
  
Actual results:
A pdf file is created, but it is corrupt and cannot be opened.

Expected results:
A pdf file that is not corrupt.

Additional info:
This worked as expected in Fedora 10.
Comment 1 Pavel Alexeev 2009-06-23 14:30:51 EDT
Thank you for the report.
I think it is duplicate of: https://bugzilla.redhat.com/show_bug.cgi?id=505740
Please reopen, If you think it is another problem.

*** This bug has been marked as a duplicate of bug 505740 ***

Note You need to log in before you can comment on or make changes to this bug.