Bug 505768 - Unable to Print with HP DeskJet 815C
Unable to Print with HP DeskJet 815C
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 12:19 EDT by Daniel Qarras
Modified: 2009-08-13 09:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-13 09:03:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cups access log (3.74 KB, text/plain)
2009-06-13 12:19 EDT, Daniel Qarras
no flags Details
cups error log (71.78 KB, text/plain)
2009-06-13 12:20 EDT, Daniel Qarras
no flags Details
foomatic rip log (3.10 KB, text/plain)
2009-06-28 06:57 EDT, Daniel Qarras
no flags Details
foomatic rip ps (871.10 KB, text/plain)
2009-06-28 06:58 EDT, Daniel Qarras
no flags Details
lpinfo output (2.54 KB, text/plain)
2009-07-17 10:59 EDT, Daniel Qarras
no flags Details
Default PPD for 815C (not working) (20.32 KB, text/plain)
2009-07-28 13:07 EDT, Daniel Qarras
no flags Details

  None (edit)
Description Daniel Qarras 2009-06-13 12:19:42 EDT
Created attachment 347748 [details]
cups access log

Description of problem:
I logged in as an ordinary user, started System->Administration->Printing and added a new printer. My HP DeskJet 815C was correctly found but the test page is forever queued. Also any other document I wish to print is stuck in the queue.

Version-Release number of selected component (if applicable):
cups-1.4-0.b2.18.fc11.i586

How reproducible:
Always.

Steps to Reproduce:
1. System->Administration->Printing
2. Add HP DeskJet 815C
3. Try to print the test page
  
Actual results:
Page queued forever.

Expected results:
Page printed.

Additional info:
I'm attaching access_log and error_log after such an attempt.
Comment 1 Daniel Qarras 2009-06-13 12:20:01 EDT
Created attachment 347749 [details]
cups error log
Comment 2 Tim Waugh 2009-06-17 09:28:23 EDT
Please edit /etc/foomatic/filter.conf and add this line to the end:

debug: 1

Then print a test page again.  You should now have two files /tmp/foomatic-rip.ps and /tmp/foomatic-rip.log -- please attach them here.  Afterwards you can change filter.conf so that it no longer has 'debug: 1' in it.
Comment 3 cornel panceac 2009-06-17 15:07:38 EDT
i had similar symptoms with my brother 5250dn. the problem seems to be i configured it as a network printer (with an ip). the above trick (debug: 1) never worked but, removing the printer and configuring as jet direct worked. one problem is i had to choose the driver by hand, by default it was identified as "generic printer". now i'll dig deeper with my office brother 1430 wich no longer works after installing f11. this is usb connected so the only thing i can think off, is that the driver is wrong.
Comment 4 Tim Waugh 2009-06-17 17:22:15 EDT
(In reply to comment #3)
> i had similar symptoms with my brother 5250dn.

Please report them in a separate bug report.  Printing problems can very often appear to be the same but have different root causes.  What we currently know about this particular problem is that the foomatic-rip filter is failing with exit status 3, which is why I'm requesting debugging information from foomatic.
Comment 5 cornel panceac 2009-06-18 09:01:11 EDT
done.

https://bugzilla.redhat.com/show_bug.cgi?id=506708
Comment 6 cornel panceac 2009-06-18 13:45:29 EDT
and

https://bugzilla.redhat.com/show_bug.cgi?id=506803
Comment 7 Daniel Qarras 2009-06-28 06:57:59 EDT
Created attachment 349695 [details]
foomatic rip log
Comment 8 Daniel Qarras 2009-06-28 06:58:36 EDT
Created attachment 349696 [details]
foomatic rip ps
Comment 9 Tim Waugh 2009-06-29 07:18:32 EDT
It seems as though the hpijs driver is unable to understand the device ID the printer gives.

Please attach the output from this command, run as root when the printer is powered and connected:

/usr/sbin/lpinfo -l --include-schemes=usb -v
Comment 10 Daniel Qarras 2009-07-17 10:59:56 EDT
Created attachment 354160 [details]
lpinfo output

Hi,

it produces no output at all:

root@localhost:~# /etc/init.d/cups status                     
cupsd (pid  2352) is running...
root@localhost:~# /usr/sbin/lpinfo -l --include-schemes=usb -v
root@localhost:~# 

But this is not a USB printer.. I'm attaching the output from:

/usr/sbin/lpinfo -l -v

Thanks.
Comment 11 Tim Waugh 2009-07-17 11:18:09 EDT
Thanks, and sorry for the incorrect assumption.  Fishing out the Device ID, we get this:

MFG:HEWLETT-PACKARD;
MDL:DESKJET 815C;
CMD:MLC,PCL,PML;
CLASS:PRINTER;
DESCRIPTION:Hewlett-Packard DeskJet 815C;
SERN:ES97E141WQIE;
VSTATUS:$HB0$FC0,ff,DN,IDLE,CUT;

Needs further investigation into hpijs source code to see why it has a problem with that.
Comment 12 Tim Waugh 2009-07-28 06:53:32 EDT
Looks like you are using the wrong PPD for this printer.

What does 'rpm -q system-config-printer' say?

Please delete the queue and re-add it.  Does printing work now?  If not, please attach the PPD file which has been set for the printer (from the /etc/cups/ppd/ directory).  Thanks.
Comment 13 Daniel Qarras 2009-07-28 13:07:05 EDT
Hi,

root@localhost:~# rpm -q system-config-printer
system-config-printer-1.1.7-4.fc11.i586

The PPD file was for 910 (not for my 815C). Just in case, I'll attach the PPD file.

After manually browsing for 815C from the list printing works now.

If wanted, I could purge all my configs and try to figure out where did this wrong PPD file came up.

Thanks.
Comment 14 Daniel Qarras 2009-07-28 13:07:41 EDT
Created attachment 355446 [details]
Default PPD for 815C (not working)
Comment 15 Tim Waugh 2009-07-28 16:49:26 EDT
(In reply to comment #13)
> If wanted, I could purge all my configs and try to figure out where did this
> wrong PPD file came up.

Yes please.  I think that's the root of the problem.
Comment 16 Daniel Qarras 2009-08-13 09:03:49 EDT
> If wanted, I could purge all my configs and try to figure out where did this
> wrong PPD file came up.

I was unable to reproduce this anymore so it might have been a local hickup or some update has fixed this already since the initial report.

Sorry for the noise and thanks a lot for your help!

Note You need to log in before you can comment on or make changes to this bug.