Bug 505801 - Vino produces black screen when compiz is enabled
Vino produces black screen when compiz is enabled
Status: CLOSED DUPLICATE of bug 505558
Product: Fedora
Classification: Fedora
Component: vino (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-13 20:15 EDT by James Rankin
Modified: 2014-06-18 05:11 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-11 10:47:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Rankin 2009-06-13 20:15:05 EDT
Description of problem:
Using F11 x86_64, I've noticed that vino presents a black screen whenever I turn on compiz. With compiz off, vino presents the screen to remote clients properly.



Version-Release number of selected component (if applicable):
vino-2.26.1-2.fc11.x86_64
tigervnc-0.0.90-0.10.fc11.x86_64
libvncserver-0.9.1-4.fc11.x86_64



Steps to Reproduce:
1. turn on vino and compiz
2. VNC into the machine and observe black screen
3. turn compiz off
4. VNC should now work properly
Comment 1 Jimmy Sapède 2009-06-16 08:07:36 EDT
same report here !

i only get first screen then impossible to see changes on remote desktop

turning off compiz solves the problem !
Comment 2 Samuel Irlapati 2009-07-02 12:18:10 EDT
I get the same problem. 

My packages are
vino-2.26.2-1.fc11.x86_64
compiz-0.7.8-18.fc11.x86_64
tigervnc-0.0.91-0.11.fc11.x86_64
libvncserver-0.9.1-4.fc11.x86_64
Comment 3 Samuel Irlapati 2009-07-02 17:10:56 EDT
This does not happen with x11vnc even without the noxdamage option. So it looks like it is a vino-server problem. 

My workaround was to install x11vnc (had to compile from source since there are no rpm's for fedora 11) and use the following .x11vncrc file.

# --noxdamage
-rfbauth .vnc/passwd
-forever
-display :0
-tightfilexfer
-solid black
-cursor arrow
-loop


I am using crontab to restart it after server reboot.
Comment 4 Colin.Simpson 2009-08-10 07:11:50 EDT
I have this issue too, this seems to have been present through the whole life of F11.
Comment 5 Michael Cronenworth 2009-08-11 16:40:21 EDT
Adding "me too" as under F10 and the old version of vino with compiz turned on allowed you to view your desktop and work.
Comment 6 kevinjnewman 2009-08-31 15:52:31 EDT
Just FYI, the folks over in Ubuntu discovered the same bug:

https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/353126

Would much appreciate a fix to this ... one of my basic needs of this desktop is to connect to an existing session remotely, which as far as I can tell, only vino can do.
Comment 7 Samuel Irlapati 2009-11-23 10:37:24 EST
Still a problem in fedora 12.
Comment 8 Michael Cronenworth 2009-12-11 10:47:47 EST
This is a dupe of bug 505558. Even though the initial screen symptoms are different, the bug is still the same. XDAMAGE events are not be propagated any more from the VNC server to the client.

*** This bug has been marked as a duplicate of bug 505558 ***

Note You need to log in before you can comment on or make changes to this bug.