Bug 505558 - Vino only shows first picture, changes on remote screen aren't visible
Vino only shows first picture, changes on remote screen aren't visible
Status: CLOSED DUPLICATE of bug 214446
Product: Fedora
Classification: Fedora
Component: vino (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
: 505801 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 08:51 EDT by Jimmy Sapède
Modified: 2014-06-18 05:11 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 11:59:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jimmy Sapède 2009-06-12 08:51:42 EDT
Description of problem:

When i try to connect to vino, it seems to work showing the remote desktop. I try to move cursor to interact with windows but nothing seems to happen, like if keyboard and mouse aren't actives.

But if i disconnect and immediately reconnect i get a new remote desktop image showing that changes applied with mouse were taken into account. 

So it seems that vino seems to work but it only sends the first image of the desktop.

I tried from a Windows XP machine with 3 differents vnc viewers : UltraVNC, RealVNC, and Tightvnc. Same result !

Everything worked perfectly well under FC10.

I've been able to find mention of this problem on an old bug delcaration here :

https://bugzilla.redhat.com/show_bug.cgi?id=208983#c13


Version-Release number of selected component (if applicable):

rpm -q vino compiz xorg-x11-server-Xorg
vino-2.26.1-2.fc11.i586
compiz-0.7.8-18.fc11.i586
xorg-x11-server-Xorg-1.6.1.901-1.fc11.i586


How reproducible:


Steps to Reproduce:
1.Enable remote desktop
2.Connect with any VNC viewer
3.
  
Actual results:

Control seems possible but changes in remote desktop are not transmitted to viewer !

Expected results:

working remote desktop

Additional info:
Comment 1 Jimmy Sapède 2009-06-12 09:06:35 EDT
forgot to say that i have compiz fusion running on vino server
Comment 2 Jimmy Sapède 2009-06-16 08:09:01 EDT
turning off compiz solve the problem of remote desktop

same bug as :

https://bugzilla.redhat.com/show_bug.cgi?id=505801
Comment 3 Nicolas Varney 2009-07-09 12:10:33 EDT
I confirm that I have exactly the same trouble:

If compiz is enabled, vino show the first picture of the screen, then changes on remote screen aren't visible.

If compiz is disabled, all works fine.

Occurs on my F11 after F10 upgrade.

#rpm -q vino compiz xorg-x11-server-Xorg
#vino-2.26.2-1.fc11.x86_64
#compiz-0.7.8-18.fc11.x86_64
#xorg-x11-server-Xorg-1.6.1.901-1.fc11.x86_64
Comment 4 Dennis Wagelaar 2009-09-21 05:13:39 EDT
Same symptoms here with:
- vino-2.26.2-1.fc11.x86_64
- compiz-0.7.8-19.fc11.x86_64
- xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64
Comment 5 Andy Lawrence 2009-11-08 17:20:53 EST
This also effects F12.  No screen refresh if compiz is enabled on the "remote" end when viewing with vncviewer to vino.
Comment 6 Michael Cronenworth 2009-12-11 10:45:49 EST
There's a bug with X and XDAMAGE. The X server in F8 worked great. Everything after that isn't sending xdamage events. Ubuntu have packaged a version where XDAMAGE is not used, but that causes extra bandwidth usage due to full screen updates instead of partial.

This bug is very old[1] and very annoying. It's probably best reassigned to xorg. I don't think the Gnome/vino guys can do much about it.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=208983
Comment 7 Michael Cronenworth 2009-12-11 10:47:47 EST
*** Bug 505801 has been marked as a duplicate of this bug. ***
Comment 8 Michael Cronenworth 2009-12-11 10:58:18 EST
All that writing and I forgot to mention the workaround.

Set the GConf key of "/desktop/gnome/remote_access/disable_xdamage" to true. VNC will work again. :)

It's not a permanent workaround though.
Comment 9 A Oepping 2009-12-16 12:14:38 EST
The above workaround in your shell: gconftool-2 -s -t bool /desktop/gnome/remote_access/disable_xdamage true
Comment 10 Andy Lawrence 2010-01-13 19:24:53 EST
This needs confirmed, the version changed to F12 and probably reassigned.
Comment 11 Bug Zapper 2010-04-27 10:49:18 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 A Oepping 2010-04-27 11:44:26 EDT
As mentioned by Andy twice, this also applies to Fedora 12. The version needs to be changed to 12 before 11 EOL.
Comment 13 Andy Lawrence 2010-04-27 17:19:08 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=567410, in another bug I was asked to resubmit this for F12.

But just to confirm, this is still a problem on F12.
Comment 14 A Oepping 2010-04-27 18:24:57 EDT
As Michael mentioned this is not an actual bug with VNC or vino but with xorg or perhaps the nvidia proprietary drivers and the XDAMAGE event not being fired. 

This bug also appears to be a *DUPLICATE* of the incredibly old bug https://bugzilla.redhat.com/show_bug.cgi?id=214446 which is also improperly listed as a vino bug.
Comment 15 Michael Cronenworth 2010-06-30 11:59:01 EDT
See bug 214446 comment 22.

*** This bug has been marked as a duplicate of bug 214446 ***

Note You need to log in before you can comment on or make changes to this bug.