Bug 505818 - ETPS/2 Elantech Touchpad not responding
ETPS/2 Elantech Touchpad not responding
Status: CLOSED DUPLICATE of bug 522126
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 00:58 EDT by Joshua Baldock
Modified: 2009-10-13 08:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 08:39:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Synclient -l output file (2.07 KB, text/plain)
2009-06-16 06:32 EDT, Joshua Baldock
no flags Details
Xorg log (34.60 KB, text/plain)
2009-06-16 06:34 EDT, Joshua Baldock
no flags Details
output file of dmesg (37.34 KB, application/octet-stream)
2009-06-25 05:03 EDT, Joshua Baldock
no flags Details

  None (edit)
Description Joshua Baldock 2009-06-14 00:58:18 EDT
Description of problem:
I have an Acer 3230 with an "ETPS/2 Elantech Touchpad". I am unable to move the cursor during install or afterwards in the installed session with the touchpad. When at the desktop the buttons for the mouse seem to work, eg. "right mouse button brings up desktop menu". However no movement is sensed during touching of the touchpad.

I have also noticed that after pushing the buttons on the touchpad to test if
they are working, the keyboard stops responding. Eg. "Press right mouse button
to show desktop menu, then unable to tab to open windows, switch to console, or
restart Xsession with ctrl+alt+backspace"

This has only happened since installing Fedora 11 on this laptop. Everything
was working great with Fedora 10.  


Version-Release number of selected component (if applicable):


How reproducible:
Not sure if this issue is reproducible on all laptops with an "ETPS/2 Elantech Touchpad"

Steps to Reproduce:
1. Latop with "ETPS/2 Elantech Touchpad" (mine is an Acer TM3230)
2. Install Fedora 11 - notice touchpad not working
3. once Fedora 11 installed, notice touchpad still not responding to touch, however buttons seem to respond.
  
Actual results:
Cursor not moving when touchpad touched.
Keyboard unresponsive after touchpad buttons pressed.

Expected results:
Cursor to respond to touchpad interaction
Keyboard and touchpad to work fine together and not become unresponsive.

Additional info:
Comment 1 Peter Hutterer 2009-06-14 23:34:40 EDT
Please attach your Xorg log and the output of evtest when run against the device file. You can get evtest from http://people.freedesktop.org/~whot/evtest.c, compile it with gcc -o evtest evtest.c and run it (as root) against the /dev/input/eventX file, where X is the number corresponding to the device (see /proc/bus/input/devices to get the number).

Note that you will need to VT switch away from the server before running it, synaptics has a grab on the device otherwise. Once evtest is running, move your finger around on the touchpad and click a button.

This should tell us whether the movement is detected and forwarded to the X server and also what the value ranges are.

Finally, please attach the output of synclient -l.
Comment 2 Joshua Baldock 2009-06-16 06:32:40 EDT
Created attachment 348079 [details]
Synclient -l output file
Comment 3 Joshua Baldock 2009-06-16 06:34:12 EDT
Created attachment 348080 [details]
Xorg log
Comment 4 Joshua Baldock 2009-06-16 06:34:33 EDT
Hi Peter,

I have attached both the Xorg log and synclient output, however i am unable to provide the evtest results. After running the evtest and testing the touchpad, i do see output logging, but then the keyboard becomes unresponsive, so I am unable to terminate the applications and the only way to proceed is to reboot.

However what i notice is, that evtest reports my first touch of the touchpad as a button1 press and then doesn't log anything further from the touchpad. The toucpad buttons themselve continue to log response however.

If you can think of a way that i can record the details from evtest, please let me know. I have already attempted to use stout to a file, however this doesn't work either (output file is blank).

Thanks for your help.
Comment 5 Peter Hutterer 2009-06-17 19:54:50 EDT
this is on the VT, right? If so, that sounds like a hardware or kernel bug.
please switch to runlevel 3 ("init 3" as root) and run evtest again.
no X server is running in runlevel 3, so if the problem still occurs then, it's either a hardware issue or kernel bug.
Comment 6 Joshua Baldock 2009-06-18 04:59:03 EDT
switched to runlevel 3 and ran evtest again. Got the same result, ie. evtest captures first touch of touchpad as button1 press and then the keyboard will no longer respond.

I agree this is looking more like a kernel issue. I have ruled out any hardware issue as the laptop touchpad functions fine in many other OS's eg. WinXP, Knoppix, Fedora 10, etc.

How should i proceed from here?
Comment 7 Joshua Baldock 2009-06-21 18:13:20 EDT
Would like some information on how to proceed with my issue.
Comment 8 Joshua Baldock 2009-06-23 22:49:11 EDT
Anyone able to assist? Im happy to provide all information required to help diagnose this issue.
Comment 9 Joshua Baldock 2009-06-25 05:03:27 EDT
Created attachment 349358 [details]
output file of dmesg
Comment 10 Joshua Baldock 2009-06-25 05:05:18 EDT
i have attached my dmesg in the hope that someone can help me if i provide more information.
Comment 11 Darryl Bond 2009-08-03 06:36:13 EDT
I have a Gigabye M1022M netbook with the same Elantech touch pad. Same results as above, evtest does not print anything and the touchpad does not respond at all in X.
Comment 12 思磊 2009-08-07 22:16:49 EDT
I have a Acer 5500Z laptop.Same results as above.Especially,when I start the laptop with the battery ,the keyboard does not respond at all in X.
Comment 13 Joshua Baldock 2009-08-08 19:40:30 EDT
Further to my testing... i compiled kernel 2.6.30 from kernel.org on my Acer 3230, and this has corrected the issue. Looks like it may be a problem with the Kernel version 2.6.29, which i believe Fedora 11 uses.
Comment 14 Darryl Bond 2009-08-14 02:10:52 EDT
I just compiled a 2.6.30.4 with the fedora11 2.6.29.6-217.2.3.fc11 .config. I ran make oldconfig and guessed the new settings (none around mice). Booted on the new kernel and it still didn't work :(

Joshua, did you do any special or new configuration in the kernel compile?
Comment 15 Joshua Baldock 2009-08-16 18:55:08 EDT
This is what i did.

1) Downloaded and extracted kernel source 2.6.30
2) Copied .config file for fedora 11 kernel (was first released kernel version for Fedora 11)
3) Ran make modules
4) ran make
5) ran make install
6) Confirmed grub is now booting from new kernel.

After booting the new kernel, the touch pad started working.
Comment 16 Darryl Bond 2009-08-20 19:35:24 EDT
Nope, didn't work for me. (tried 2.6.30.4 & 2.6.30.5)
My hardware must be different.
Comment 17 Darryl Bond 2009-09-07 20:56:58 EDT
Worked with Arjan Opmeer (Elantech driver kernel developer) to get a partial fix. 
The hardware does not respond correctly so the PS/2 Aux port does not get initialised. Passing the kernel argument i8042.noloop gets the touchpad working. 
Now to track down exactly why it doesn't work by default.
Comment 18 Chuck Ebbert 2009-10-13 08:39:33 EDT

*** This bug has been marked as a duplicate of bug 522126 ***

Note You need to log in before you can comment on or make changes to this bug.