Bug 522126 - Notebook pointing devices not detected
Summary: Notebook pointing devices not detected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: i586
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 505818 510882 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 14:27 UTC by Johan Vromans
Modified: 2009-10-30 17:52 UTC (History)
4 users (show)

Fixed In Version: 2.6.30.9-90.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-30 17:52:40 UTC


Attachments (Terms of Use)
dmesg output of 2.6.30.5 boot (47.20 KB, text/plain)
2009-09-09 14:27 UTC, Johan Vromans
no flags Details

Description Johan Vromans 2009-09-09 14:27:59 UTC
Created attachment 360234 [details]
dmesg output of 2.6.30.5 boot

Description of problem:

The Synaptics Touchpad stops working after upgrading to 2.6.30.5. It did work correctly in previous versions.

Version-Release number of selected component (if applicable):

Linux version 2.6.30.5-43.fc11.i586 (mockbuild@x86-4.fedora.phx.redhat.com) (gcc version 4.4.1 20090725 (Red Hat 4.4.1-2) (GCC) ) #1 SMP Thu Aug 27 21:18:54 EDT 2009

System is a Toshiba Satellite A200.

How reproducible:

Always.

Steps to Reproduce:
1. Boot 2.6 29 kernel
2. Touchpad works
3. Boot 2.6.30 kernel
  
Actual results:

Touchpad doesn't work.

Expected results:

Touchpad works.

Additional info:

In the 2.6.29.6 dmesg, there's the following lines:

  [drm] Initialized radeon 1.30.0 20080528 for 0000:01:00.0 on minor 0
  Synaptics Touchpad, model: 1, fw: 6.5, id: 0x82e0b1, caps: 0xb04711/0xe0440d
  synaptics: Toshiba Satellite A200 detected, limiting rate to 40pps.
  input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input  /input5
  kjournald starting.  Commit interval 5 seconds
  EXT3-fs: mounted filesystem with ordered data mode.

In the 2.6.30.5 dmesg, this section reads:

  [drm] Initialized radeon 1.30.0 20080528 for 0000:01:00.0 on minor 0
  kjournald starting.  Commit interval 5 seconds
  EXT3-fs: mounted filesystem with ordered data mode.

Comment 1 Johan Vromans 2009-09-16 13:02:41 UTC
It may be intermittent, a bug, or even a false alarm.
Please consider this void unless someone else can confirm.

Comment 2 Johan Vromans 2009-09-24 08:15:59 UTC
Still I often run into this. Warm and cold reboots do not cure it.
I have no clue where to start investigating. Suggestions welcome.

Comment 3 Johan Vromans 2009-10-02 21:36:34 UTC
Upgrade to kernel-2.6.30.8-64.fc11.i586. The problem still persists.
Back to kernel-2.6.29.6-217.2.16.fc11.i586 again.

I have no clue where to start investigating. Suggestions welcome.

Comment 4 Chuck Ebbert 2009-10-08 20:31:51 UTC
Can you try adding 'i8042.noloop=1' to the boot options? Also try 'i8042.nomux=1'.

Comment 5 Johan Vromans 2009-10-08 21:32:51 UTC
Thanks for the suggestions!

With 'i8042.noloop=1' the touchpad is correctly detected.
'i8042.nomux=1' makes no apparent difference (i.e., no touchpad).

Comment 7 Chuck Ebbert 2009-10-13 12:39:33 UTC
*** Bug 505818 has been marked as a duplicate of this bug. ***

Comment 8 Chuck Ebbert 2009-10-13 12:40:11 UTC
*** Bug 510882 has been marked as a duplicate of this bug. ***

Comment 9 Chuck Ebbert 2009-10-17 13:18:44 UTC
Patch is in kernel-2.6.30.9-89.fc11

Comment 10 Fedora Update System 2009-10-18 01:56:07 UTC
kernel-2.6.30.9-90.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kernel-2.6.30.9-90.fc11

Comment 11 Johan Vromans 2009-10-22 14:54:03 UTC
Works for me. Toshiba Satellite A200.
Thanks!

Comment 12 Fedora Update System 2009-10-27 06:45:57 UTC
kernel-2.6.30.9-90.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.