Bug 505831 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 187: ordinal not in range(128)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 187: ord...
Status: CLOSED DUPLICATE of bug 508360
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 03:53 EDT by Tomasz Torcz
Modified: 2014-01-21 18:09 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 16:58:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Torcz 2009-06-14 03:53:56 EDT
Description of problem:
Out of sudden, window appear on desktop with following backtrace:

Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2191, in get_updates
    ygl = self.yumbase.doPackageLists(pkgnarrow='updates')
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1678, in doPackageLists
    for (n,a,e,v,r) in self.up.getUpdatesList():
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 662, in <lambda>
    up = property(fget=lambda self: self._getUpdates(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 546, in _getUpdates
    self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(), self.pkgSack.simplePkgList())
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 649, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 491, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 260, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 162, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 220, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1178, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1342, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1334, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1324, in _loadRepoXML
    return self._groupLoadRepoXML(text, ["primary"])
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1307, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1148, in _commonLoadRepoXML
    if self._latestRepoXML(local):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1126, in _latestRepoXML
    repomd = self.metalink_data.repomd
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 672, in <lambda>
    metalink_data = property(fget=lambda self: self._getMetalink(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 654, in _getMetalink
    print "Could not get metalink $s error was \n$s" $(url, e)
  File "/usr/lib64/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 187: ordinal not in range(128)

Version-Release number of selected component (if applicable):
gnome-packagekit-2.27.2-1.fc11.x86_64

How reproducible:
Happens spontanously

Additional information:
Locale is pl_PL.UTF-8.
Comment 1 Richard Hughes 2009-06-25 05:26:28 EDT
Does this still happen? Can you describe how to reproduce this please? Thanks.
Comment 2 Dams 2009-06-26 09:08:40 EDT
Hello

I've got the same kind of problem with yum.

python-2.6-9.fc11.x86_64
yum-3.2.23-3.fc11.noarch

"LC_ALL=fr_FR.UTF-8 yum provides \*awt\*" horribly dies with : 
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 178, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 352, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 560, in doCommand
    return base.provides(extcmds)
  File "/usr/share/yum-cli/cli.py", line 829, in provides
    callback_has_matchfor=True)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 2000, in searchPackageProvides
    callback(po, tmpvalues)
  File "/usr/share/yum-cli/output.py", line 870, in matchcallback_verbose
    return self.matchcallback(po, values, matchfor, verbose=True)
  File "/usr/share/yum-cli/output.py", line 864, in matchcallback
    print self.fmtKeyValFill(key, item)
  File "/usr/lib64/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 15: ordinal not in range(128)

It doesnt happen with en_US.UTF-8 locale.
Comment 3 Julian Aloofi 2009-07-26 14:18:51 EDT
I can confirm that. Get the same error when building packages in mock for rawhide.
My locale is de_DE.UTF-8. It doesn't happen when building for F10 or F11.
I'm on Fedora 11. I can't decode 0xc3, by the way. Here's the full traceback:

FEHLER mit rpm_check_debug gegen depsolve:
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 261, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 424, in doTransaction
    print to_utf8(msg)
  File "/usr/lib/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 37: ordinal not in range(128)


How reproducable:
mock -r fedora-rawhide-i386 rebuild foo.src.rpm
on Fedora 11 with de_DE.UTF-8.
Comment 4 Julian Aloofi 2009-07-27 13:28:22 EDT
This happens to me in normal yum use now, too.
But, this is not related to gnome-packagekit, as codecs.py is a part of python. This is a python bug.
Curiously, yum whatprovides /usr/lib/python-2.6/codecs.py reproduces that error.
yum whatprovides */codecs.py also lists python, but doesn't reproduce the error.

So, could someone please change the component to python?
I'm using python-2.6-9.fc11
Comment 5 Julian Aloofi 2009-07-27 13:29:45 EDT
Changed component to python, I'm still not used to the fact I can do such things myself now ;)
Comment 6 James Antill 2009-07-27 16:58:35 EDT
Works for me, so I think this is a dup of 508360

*** This bug has been marked as a duplicate of bug 508360 ***

Note You need to log in before you can comment on or make changes to this bug.