Bug 505880 - Install from harddisk image needs clarification
Install from harddisk image needs clarification
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
All Linux
low Severity medium
: ---
: ---
Assigned To: Ruediger Landmann
David Nalley
http://docs.fedoraproject.org/install...
: Documentation
: 552777 (view as bug list)
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-06-14 10:41 EDT by Edwin ten Brink
Modified: 2013-09-17 05:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 05:57:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edwin ten Brink 2009-06-14 10:41:47 EDT
There is no clear process documented on how to install from a harddisk image. The information is fragmentized over several sections which do not yet form a step-by-step guide which can be followed by a first time user. The affected sections could be restructured to this purpose.

Ideally, the user should recognize his chosen source/boot method (from 2.3. "Which Files Do I Download?") in each step of the process (generally).

Affected sections I identified:
2.3. Which Files Do I Download?
2.6 How do I start the installation program?
3.4.1. Alternative Boot Methods
3.4.2. Making an Installation Boot CD-ROM
3.6. Preparing for a Hard Drive Installation
6.2. Installing from a Different Source
7.3. Starting the Installation Program
7.4. Selecting an Installation Method
7.6. Installing from a Hard Drive
9.1.4. Specifying the Installation Method


Some specific remarks follow:

3.6. Preparing for a Hard Drive Installation
This part is missing the notion that you should create some bootable media. It only refers to saving iso images to the file system.
<quote>
To prepare your system for a hard drive installation, you must set the system up in one of the following ways:
* Using a set of CD-ROMs, or a DVD — Create ISO image files from each installation CD-ROM, or from the DVD.
<snip>
* Using ISO images — transfer these images to the system to be installed.
<snip>
</quote>


7.6. Installing from a Hard Drive
This part should be a preparatory part; in this point in the process we have already booted the machine for installation. This should be moved to 3.6.
<quote>
The ISO files must be located on a hard drive that is either internal to the computer, or attached to the machine by USB. In addition the install.img file from within the ISO files must be copied to a directory named images Use this option to install Fedora on computers that are without a network connection or CD/DVD drives.
To extract the install.img from the ISO follow the procedure:

  mount -t iso9660 /path/to/Fedora11.iso /mnt/point -o loop,ro
  cp -pr /mnt/point/images /path/images/
  umount /mnt/point

Before you begin installation from a hard drive, check the partition type to ensure that Fedora can read it. To check a partition's file system under Windows, use the Disk Management tool. To check a partition's file system under Linux, use the fdisk utility. 

Cannot Install from LVM Partitions
You cannot use ISO files on partitions controlled by LVM (Logical Volume Management).
</quote>

This is a generalization of bug 504973, which only describes one symptom.
Comment 1 Chris Lumens 2010-01-06 15:52:34 EST
*** Bug 552777 has been marked as a duplicate of this bug. ***
Comment 2 JW 2010-01-06 17:56:30 EST
I disagree. Bug 552777 is not a duplicate of this bug.  Bug 552777 does mention in passing that the documentation is not what it should be, but it also describes the failure of the install from hard disk without a "repo" boot parameter.  Bug 552777 clearly describes how anaconda fails to look in the correct location for packages.

This bug only complains about the documentation.

This bug does not mention how the "repo" boot parameter is necessary.

This bug does not mention that anaconda, by default, looks in the wrong place for the package iso.
Comment 3 Ruediger Landmann 2010-01-15 01:51:41 EST
Thanks very much Edwin for the helpful and thoughtful feedback.

I've implemented fixes for the specifically problematic areas that you identified, along with a more general re-shuffling of some of the preliminary parts of the guide and a few more explicit pointers at various stages to act as guideposts for people jumping straight into the middle of the guide. Hopefully, it's a bit better. 

These changes will be visible the next time that we republish the guide.

Thanks again for your help, and please revisit the bug if you think we can do better! :)

Cheers

Ruediger

Note You need to log in before you can comment on or make changes to this bug.