Bug 50591 - Grub fail to boot(or install) when 2nd cciss controller used as a boot controller
Summary: Grub fail to boot(or install) when 2nd cciss controller used as a boot contro...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 53585 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-01 13:37 UTC by Bryan Leopard
Modified: 2005-10-31 22:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-12 20:13:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryan Leopard 2001-08-01 13:37:28 UTC
Grub fail to boot(or install) when 2nd cciss controller used as a boot 
controller.

System: DL380 G2 - I experienced the same problem on ML530.
Controller: SA5i(Embedded), SA532(Boot controller)

Steps to reproduce:
1. Configure SA532 as a boot controller
2. Begin installation
3. Select grub as a bootloader and choose to install to /dev/cciss/c1d0p1
4. Finish install
  - right after a postinstall, text console message shows following 
message.
   "/boot/grub/device.map:3:error:Bad device number"
5. Make rescue floppy and reboot - it will fail to boot 
6. Insert 1st CD again and try to reboot from it
7. Switch to console terminal at first GUI screen
8. Mount /dev/cciss/c1d0p2( / ) and /dev/cciss/c1d0p1(/boot).
9. chroot to /dev/cciss/c1d0p2
10. cd /boot/grub
11. "/sbin/grub-install /dev/cciss/c1d0p1" will generate following message.
  - " /dev/cciss/c1d0p1 does not have any corresponding BIOS drive"
12. "more device.map" in /boot/grub
  - (fd0)	/dev/fd0
    (hd2)    /dev/cciss/c1d0
13. Reboot the system again, and try to boot from rescue floppy.
14. Rescue boot also failed and generating;
  > mount : error 19 mounting ext3
  > pivot root : pivot_root(/sysroot,/sysroot/initrd) failed : 2
  > Freeing unused kernel memory: 232k freed
  > Kernel panic: No init found. Try passing int=option to kernel.

Comment 1 Glen Foster 2001-08-01 20:24:05 UTC
This defect is considered SHOULD-FIX for Fairfax.

Comment 2 Jeremy Katz 2001-08-08 06:20:08 UTC
Just out of curiosity, does LILO actually work in this configuration without any
tweaks to /etc/lilo.conf?  Also, what drives actually exist in the system?

Comment 3 Bryan Leopard 2001-08-09 14:32:08 UTC
"LILO works perfectly without any problem.
On SA532 controller, I have one RAID 5 logical volume configured which consist 
of 3 Compaq 18G ultra 3 scsi drives in the storage box."

Comment 4 Jeremy Katz 2001-08-10 03:55:34 UTC
And there are no other hard drives in the system other than the ones in the RAID
controller?  What does `/usr/sbin/kudzu -p -c HD` show?

Comment 5 Glen Foster 2001-08-23 21:47:53 UTC
This defect is *now* considered MUST-FIX for Fairfax.

Comment 6 prago 2001-08-27 13:59:29 UTC
Per Compaq:

And there are no other hard drives in the system other than the ones in the RAID
controller?  
Answer:
I have 2 Compaq RAID controllers in the system with following config:

SA5i - Embedded controller.  2 logical volumes configured
        /dev/cciss/c0d0
        /dev/cciss/c0d1

SA532 - BOOT CONTROLLER - 1 logical volume configured
        /dev/cciss/c1d0 
                /dev/cciss/c1d0p1 - /boot
                /dev/cciss/c1d0p2 - /
                /dev/cciss/c1d0p3 - swap
 
What does `/usr/sbin/kudzu -p -c HD` show?
There's nothing returned from executing the command.



Comment 7 Jeremy Katz 2001-09-04 14:51:38 UTC
I really don't know that there's a way to do this unless there's something
better exported to user space about BIOS ordering of drives.  Other
possibilities are having the driver order the drives correctly.

If lilo works with the stock configuration file generated with anaconda, could
you give the output of
/sbin/lilo -v -v -v
?

Comment 8 Jeremy Katz 2001-09-12 20:05:04 UTC
Didn't make it for Enigma.  For the next release, I'm looking at redoing the
boot loader screen with a way to give advanced information such as this.

Comment 9 Jeremy Katz 2001-10-12 20:13:52 UTC
*** Bug 53585 has been marked as a duplicate of this bug. ***

Comment 10 Jeremy Katz 2002-01-22 01:09:15 UTC
You'll be able to manually change the detected drive order for Hampton


Note You need to log in before you can comment on or make changes to this bug.